summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-07-10 01:07:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-07-10 01:07:42 +0000
commita9bb3ee68033415805a4a61babed8418eb0593be (patch)
tree328b77319ddc2e71014be1f1adbfdd3e11e4831f /games-roguelike
parentAdded ~x86-fbsd keyword. (diff)
downloadgentoo-2-a9bb3ee68033415805a4a61babed8418eb0593be.tar.gz
gentoo-2-a9bb3ee68033415805a4a61babed8418eb0593be.tar.bz2
gentoo-2-a9bb3ee68033415805a4a61babed8418eb0593be.zip
fix building when neither oss or alsa is specified - patch from Preston Crow via bug #139785
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog7
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild7
2 files changed, 11 insertions, 3 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index 043d40f78b61..80de12f2d56c 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/crossfire-client
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.16 2006/07/04 02:23:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.17 2006/07/10 01:07:42 mr_bones_ Exp $
+
+ 10 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ crossfire-client-1.9.1.ebuild:
+ fix building when neither oss or alsa is specified - patch from Preston Crow
+ via bug #139785
*crossfire-client-1.9.1 (04 Jul 2006)
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild
index 71ff49f5e40c..71572d032b60 100644
--- a/games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild
+++ b/games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild,v 1.1 2006/07/04 02:23:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild,v 1.2 2006/07/10 01:07:42 mr_bones_ Exp $
inherit games
@@ -48,7 +48,10 @@ src_compile() {
myconf="${myconf} --disable-sound"
fi
egamesconf ${myconf} || die
- emake -j1 -C sound-src || die "sound building failed"
+ # bug 139785
+ if use alsa || use oss ; then
+ emake -j1 -C sound-src || die "sound building failed"
+ fi
emake || die "emake failed"
}