summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-03-08 06:44:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-03-08 06:44:58 +0000
commitb72ab91496095ed0660ada6d10973bd30667f1b9 (patch)
treee9c977994e36716852c5caefe3a8f06f74c1f57c /games-roguelike
parentChanged the harddep on sys-libs/pam for virtual/pam. Assigned DEPEND explicit... (diff)
downloadgentoo-2-b72ab91496095ed0660ada6d10973bd30667f1b9.tar.gz
gentoo-2-b72ab91496095ed0660ada6d10973bd30667f1b9.tar.bz2
gentoo-2-b72ab91496095ed0660ada6d10973bd30667f1b9.zip
EAPI=2; add use-based dep; fix bug #257601
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/scourge/ChangeLog8
-rw-r--r--games-roguelike/scourge/scourge-0.21.1.ebuild28
2 files changed, 24 insertions, 12 deletions
diff --git a/games-roguelike/scourge/ChangeLog b/games-roguelike/scourge/ChangeLog
index 8f028096dd7f..0b15daed7981 100644
--- a/games-roguelike/scourge/ChangeLog
+++ b/games-roguelike/scourge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/scourge
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.32 2008/12/30 15:25:56 mr_bones_ Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.33 2009/03/08 06:44:58 mr_bones_ Exp $
+
+ 08 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ scourge-0.21.1.ebuild:
+ EAPI=2; add use-based dep; fix bug #257601
*scourge-0.21.1 (30 Dec 2008)
diff --git a/games-roguelike/scourge/scourge-0.21.1.ebuild b/games-roguelike/scourge/scourge-0.21.1.ebuild
index 79420466f8f5..198a600dcfff 100644
--- a/games-roguelike/scourge/scourge-0.21.1.ebuild
+++ b/games-roguelike/scourge/scourge-0.21.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.21.1.ebuild,v 1.1 2008/12/30 15:25:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.21.1.ebuild,v 1.2 2009/03/08 06:44:58 mr_bones_ Exp $
-inherit eutils wxwidgets games
+EAPI=2
+inherit autotools eutils wxwidgets games
DESCRIPTION="A graphical rogue-like adventure game"
HOMEPAGE="http://scourgeweb.org/"
@@ -16,10 +17,10 @@ IUSE=""
RDEPEND="virtual/glu
virtual/opengl
- >=media-libs/freetype-2
- media-libs/libsdl
+ media-libs/freetype:2
+ media-libs/libsdl[joystick]
media-libs/sdl-net
- media-libs/sdl-mixer
+ media-libs/sdl-mixer[vorbis]
media-libs/sdl-ttf
virtual/libintl"
DEPEND="${RDEPEND}
@@ -27,13 +28,20 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}
-src_compile() {
+src_prepare() {
+ # bug #257601
+ sed -i \
+ -e '/AC_CHECK_HEADERS.*glext/ s:):, [#include <GL/gl.h>] ):' \
+ configure.in \
+ || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
egamesconf \
--disable-dependency-tracking \
--with-data-dir="${GAMES_DATADIR}"/${PN} \
- --localedir=/usr/share/locale \
- || die
- emake || die "emake failed"
+ --localedir=/usr/share/locale
}
src_install() {