summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-05-27 19:30:04 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-05-27 19:30:04 +0000
commit8f1befbbbd356cc26cc13f88d8cc538f278cdb74 (patch)
tree1a510728360c946e467c7f0cb0565b9cbfd86fce /games-rpg/egoboo/egoboo-2.22-r1.ebuild
parentMake BSF support optional via new local USE flag and minor style tweaks. (diff)
downloadgentoo-2-8f1befbbbd356cc26cc13f88d8cc538f278cdb74.tar.gz
gentoo-2-8f1befbbbd356cc26cc13f88d8cc538f278cdb74.tar.bz2
gentoo-2-8f1befbbbd356cc26cc13f88d8cc538f278cdb74.zip
Adding menu entry. Bug #160208
(Portage version: 2.1.2.7)
Diffstat (limited to 'games-rpg/egoboo/egoboo-2.22-r1.ebuild')
-rw-r--r--games-rpg/egoboo/egoboo-2.22-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-rpg/egoboo/egoboo-2.22-r1.ebuild b/games-rpg/egoboo/egoboo-2.22-r1.ebuild
new file mode 100644
index 000000000000..dc425c0fc112
--- /dev/null
+++ b/games-rpg/egoboo/egoboo-2.22-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.22-r1.ebuild,v 1.1 2007/05/27 19:30:04 tupone Exp $
+
+inherit eutils flag-o-matic toolchain-funcs games
+
+DESCRIPTION="A 3d dungeon crawling adventure in the spirit of NetHack"
+HOMEPAGE="http://egoboo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/ego${PV/./}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ use !amd64 && replace-cpu-flags 'athlon*' pentium4 i686
+
+ unpack ${A}
+ cd "${S}"
+
+ # Fix endianess using SDL
+ # amd64 patch must be applied after ${PV}-endian.patch
+ # this addresses bug #104271
+ epatch \
+ ${FILESDIR}/${PV}-endian.patch \
+ ${FILESDIR}/${PV}-amd64.patch
+}
+
+src_compile() {
+ cd code
+ make clean || die "make clean failed"
+ emake FLAGS="-D_LINUX ${CFLAGS}" CC="$(tc-getCC)" egoboo || die "emake failed"
+}
+
+src_install () {
+ games_make_wrapper ${PN} ./${PN} "${GAMES_DATADIR}/${PN}"
+ dodoc egoboo.txt
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r basicdat/ import/ modules/ players/ text/ \
+ code/egoboo controls.txt setup.txt \
+ || die "doins failed"
+ # FIXME: this is stupid. should be patched to run out of GAMES_BINDIR
+ fperms 750 "${GAMES_DATADIR}/${PN}/${PN}"
+ newicon basicdat/icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Egoboo /usr/share/pixmaps/${PN}.bmp
+
+ prepgamesdirs
+ # ugly, but the game needs write here.
+ cd "${D}${GAMES_DATADIR}/${PN}"
+ chmod -R g+w setup.txt basicdat players import
+}