summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-07-04 22:43:21 +0000
committerRoy Marples <uberlord@gentoo.org>2006-07-04 22:43:21 +0000
commit4d0548f86a697ce2aec94beb8b7a33a56dc8bde6 (patch)
tree336a670353d197eac6b9834c8c1b2bfef244e328 /games-rpg
parentFix scim dependency to be on 1.4.4, as reported by Christian Faulhammer in bu... (diff)
downloadgentoo-2-4d0548f86a697ce2aec94beb8b7a33a56dc8bde6.tar.gz
gentoo-2-4d0548f86a697ce2aec94beb8b7a33a56dc8bde6.tar.bz2
gentoo-2-4d0548f86a697ce2aec94beb8b7a33a56dc8bde6.zip
Version bump.
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/eternal-lands-data/ChangeLog8
-rw-r--r--games-rpg/eternal-lands-data/eternal-lands-data-1.3.0.ebuild64
-rw-r--r--games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.3.06
3 files changed, 77 insertions, 1 deletions
diff --git a/games-rpg/eternal-lands-data/ChangeLog b/games-rpg/eternal-lands-data/ChangeLog
index a8f51a41b0b3..311ef3f2ccb1 100644
--- a/games-rpg/eternal-lands-data/ChangeLog
+++ b/games-rpg/eternal-lands-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/eternal-lands-data
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/ChangeLog,v 1.5 2006/07/02 12:52:11 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/ChangeLog,v 1.6 2006/07/04 22:43:21 uberlord Exp $
+
+*eternal-lands-data-1.3.0 (04 Jul 2006)
+
+ 04 Jul 2006; Roy Marples <uberlord@gentoo.org>
+ +eternal-lands-data-1.3.0.ebuild:
+ Version bump.
02 Jul 2006; Roy Marples <uberlord@gentoo.org>
eternal-lands-data-1.2.0_p1-r3.ebuild:
diff --git a/games-rpg/eternal-lands-data/eternal-lands-data-1.3.0.ebuild b/games-rpg/eternal-lands-data/eternal-lands-data-1.3.0.ebuild
new file mode 100644
index 000000000000..302198afba70
--- /dev/null
+++ b/games-rpg/eternal-lands-data/eternal-lands-data-1.3.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/eternal-lands-data-1.3.0.ebuild,v 1.1 2006/07/04 22:43:21 uberlord Exp $
+
+inherit games
+
+MUSIC_DATE="20060803"
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+MY_PN="${PN%*-data}"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="http://www.other-life.com/el/el_${MY_PV}_linux_full.zip
+ music? ( mirror://gentoo/el_music_full-${MUSIC_DATE}.zip )"
+# WARNING: The music file is held at
+# http://www.eternal-lands.com/page/music.php
+# We only mirror it so that it is versioned by the date we mirrored it
+# AND prefixed with el_ so as not cause any conflicts. Maybe oneday they will
+# version their music, maybe not.
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="music"
+
+DEPEND="app-arch/unzip
+ sys-apps/findutils"
+
+src_unpack() {
+ cd "${WORKDIR}"
+ unpack ${A}
+
+ # Remove CVS entries
+ find . -type d -name CVS -exec rm -rf {} \; 2>/dev/null
+
+ # Move our music files to the correct directory
+ use music && mv *.ogg *.pll music
+}
+
+src_install() {
+ cd "${WORKDIR}"
+
+ # These are provided by eternal-lands ebuild
+ rm license.txt
+
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${MY_PN}"
+ doins -r 2dobjects 3dobjects actor_defs animations maps meshes music \
+ particles skeletons sound textures tiles languages \
+ *.lst 3dobjects.txt *.xml \
+ || die "doins failed"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${MY_PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${MY_PN}" -type d -exec chmod g+sx {} \;
+}
diff --git a/games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.3.0 b/games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.3.0
new file mode 100644
index 000000000000..bf08fc86a744
--- /dev/null
+++ b/games-rpg/eternal-lands-data/files/digest-eternal-lands-data-1.3.0
@@ -0,0 +1,6 @@
+MD5 59b4a2370f0e20b62c131b7c61cd1bbf el_130_linux_full.zip 41199794
+RMD160 e3f6c6e3be970f12302af3ea43c518b6e943f8d6 el_130_linux_full.zip 41199794
+SHA256 eddd5f716a7f6df5340e332daea0bc44e02e87712124ad06329aa68859c2bfa2 el_130_linux_full.zip 41199794
+MD5 95220e0df0be0eb4f2b9646cc5d6b7e5 el_music_full-20060803.zip 65511882
+RMD160 63955f223a8472c9956a5b6912dec7db924f32ee el_music_full-20060803.zip 65511882
+SHA256 1ea4de25081034ac684aaebf127ab6ca8524ba5367532863d84d63837dd631ec el_music_full-20060803.zip 65511882