summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-05 05:59:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-05 05:59:04 +0000
commita2192d077fe9e4686f4853e282725b3a8f9d4601 (patch)
treecda60c7614c80e02d42806eab40588e7b8f6ca15 /games-rpg
parentFix for gcc 4.3. (diff)
downloadgentoo-2-a2192d077fe9e4686f4853e282725b3a8f9d4601.tar.gz
gentoo-2-a2192d077fe9e4686f4853e282725b3a8f9d4601.tar.bz2
gentoo-2-a2192d077fe9e4686f4853e282725b3a8f9d4601.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/tmw/files/tmw-0.0.24-desktop.patch22
-rw-r--r--games-rpg/tmw/tmw-0.0.24.ebuild60
2 files changed, 0 insertions, 82 deletions
diff --git a/games-rpg/tmw/files/tmw-0.0.24-desktop.patch b/games-rpg/tmw/files/tmw-0.0.24-desktop.patch
deleted file mode 100644
index 127efd371f3a..000000000000
--- a/games-rpg/tmw/files/tmw-0.0.24-desktop.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Make sure desktop/pixmaps dont get thrown into /usr/games.
-
---- Makefile.in
-+++ Makefile.in
-@@ -163,3 +163,3 @@
- SUBDIRS = data docs src
--desktopdir = $(datadir)/applications
-+desktopdir =/usr/share/applications
- desktop_DATA = tmw.desktop
---- data/icons/Makefile.in
-+++ data/icons/Makefile.in
-@@ -318,7 +318,7 @@
- install-data-local:
-- $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps
-- $(INSTALL) $(srcdir)/tmw.png $(DESTDIR)$(datadir)/pixmaps/tmw.png
-+ $(mkinstalldirs) $(DESTDIR)/usr/share/pixmaps
-+ $(INSTALL) $(srcdir)/tmw.png $(DESTDIR)/usr/share/pixmaps/tmw.png
-
- uninstall-local:
-- rm -f $(DESTDIR)$(datadir)/pixmaps/tmw.png
-+ rm -f $(DESTDIR)/usr/share/pixmaps/tmw.png
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/games-rpg/tmw/tmw-0.0.24.ebuild b/games-rpg/tmw/tmw-0.0.24.ebuild
deleted file mode 100644
index 6e8b641ef469..000000000000
--- a/games-rpg/tmw/tmw-0.0.24.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.0.24.ebuild,v 1.1 2007/12/28 03:02:12 mr_bones_ Exp $
-
-inherit eutils games
-
-MUSIC=tmwmusic-0.0.20
-DESCRIPTION="A fully free and open source MMORPG game with the looks of \"old-fashioned\" 2D RPG"
-HOMEPAGE="http://themanaworld.org/"
-SRC_URI="mirror://sourceforge/themanaworld/${P}.tar.gz
- mirror://sourceforge/themanaworld/${MUSIC}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="opengl"
-
-DEPEND=">=dev-games/physfs-1.0.0
- opengl? ( virtual/opengl )
- dev-libs/libxml2
- media-libs/sdl-mixer
- media-libs/sdl-image
- media-libs/sdl-net
- net-misc/curl
- >=dev-games/guichan-0.7.0"
-
-pkg_setup() {
- games_pkg_setup
- if ! built_with_use dev-games/guichan sdl ; then
- eerror "dev-games/guichan needs to be built with USE=sdl"
- die "please re-emerge dev-games/guichan with USE=sdl"
- fi
- if ! built_with_use media-libs/sdl-mixer vorbis ; then
- eerror "media-libs/sdl-mixer needs to be built with USE=vorbis"
- die "please re-emerge media-libs/sdl-mixer with USE=vorbis"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-desktop.patch
-}
-
-src_compile() {
- egamesconf \
- --disable-dependency-tracking \
- $(use_with opengl) || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README
- cd "${WORKDIR}"
- insinto "${GAMES_DATADIR}"/${PN}/data/music
- doins ${MUSIC}/data/music/*.ogg || die
- newdoc ${MUSIC}/README README.music
- prepgamesdirs
-}