summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-01 15:27:36 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-01 15:27:36 +0000
commitc2f21f90d0a13ff40a93bc3e8da11f53126130cf (patch)
treecae186dc0501a4375bd9e638fbd493dff20da995 /games-rpg
parentx86 stable, bug #219513 (diff)
downloadgentoo-2-c2f21f90d0a13ff40a93bc3e8da11f53126130cf.tar.gz
gentoo-2-c2f21f90d0a13ff40a93bc3e8da11f53126130cf.tar.bz2
gentoo-2-c2f21f90d0a13ff40a93bc3e8da11f53126130cf.zip
Patch to fix building with gcc-4.3 from Martin Väth, bug #218944
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/aklabeth/ChangeLog8
-rw-r--r--games-rpg/aklabeth/aklabeth-1.0.ebuild14
-rw-r--r--games-rpg/aklabeth/files/aklabeth-1.0-gcc43.patch10
3 files changed, 26 insertions, 6 deletions
diff --git a/games-rpg/aklabeth/ChangeLog b/games-rpg/aklabeth/ChangeLog
index c1e2c8f96258..3b4438001ccc 100644
--- a/games-rpg/aklabeth/ChangeLog
+++ b/games-rpg/aklabeth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/aklabeth
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/aklabeth/ChangeLog,v 1.3 2004/12/16 15:35:32 josejx Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/aklabeth/ChangeLog,v 1.4 2008/05/01 15:27:36 nyhm Exp $
+
+ 01 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/aklabeth-1.0-gcc43.patch, aklabeth-1.0.ebuild:
+ Patch to fix building with gcc-4.3 from Martin Väth, bug #218944
17 Dec 2004; Joseph Jezak <josejx@gentoo.org> aklabeth-1.0.ebuild:
Marked ppc stable.
diff --git a/games-rpg/aklabeth/aklabeth-1.0.ebuild b/games-rpg/aklabeth/aklabeth-1.0.ebuild
index 77566a2f9f15..df7ec41713fd 100644
--- a/games-rpg/aklabeth/aklabeth-1.0.ebuild
+++ b/games-rpg/aklabeth/aklabeth-1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/aklabeth/aklabeth-1.0.ebuild,v 1.4 2004/12/16 15:35:32 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/aklabeth/aklabeth-1.0.ebuild,v 1.5 2008/05/01 15:27:36 nyhm Exp $
-inherit games
+inherit eutils games
DESCRIPTION="A remake of Richard C. Garriott's Ultima prequel"
HOMEPAGE="http://www.autismuk.freeserve.co.uk/"
@@ -10,11 +10,17 @@ SRC_URI="http://www.autismuk.freeserve.co.uk/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc ~amd64"
+KEYWORDS="~amd64 ppc x86"
IUSE=""
DEPEND="media-libs/libsdl"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_install() {
dogamesbin src/aklabeth || die "dogamesbin failed"
dodoc AUTHORS README NEWS
diff --git a/games-rpg/aklabeth/files/aklabeth-1.0-gcc43.patch b/games-rpg/aklabeth/files/aklabeth-1.0-gcc43.patch
new file mode 100644
index 000000000000..b9a32dadd430
--- /dev/null
+++ b/games-rpg/aklabeth/files/aklabeth-1.0-gcc43.patch
@@ -0,0 +1,10 @@
+--- src/sdw.hxx
++++ src/sdw.hxx
+@@ -19,6 +19,7 @@
+
+ #include <iostream>
+ #include <string>
++#include <cstdlib>
+
+ namespace SDLWrapper // It's all nicely in a namespace SDLWrapper
+ {