summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-02-11 01:44:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-02-11 01:44:50 +0000
commite31fee59fba9a41705d9ffee35cb9a4f2e0b1875 (patch)
treedde2ac81be0a890ed44d4d3a0621e76b61b23c8b /games-server/crossfire-server/crossfire-server-1.11.0.ebuild
parentRemoved old versions. Added R_HOME environment variable (diff)
downloadgentoo-2-e31fee59fba9a41705d9ffee35cb9a4f2e0b1875.tar.gz
gentoo-2-e31fee59fba9a41705d9ffee35cb9a4f2e0b1875.tar.bz2
gentoo-2-e31fee59fba9a41705d9ffee35cb9a4f2e0b1875.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-server/crossfire-server/crossfire-server-1.11.0.ebuild')
-rw-r--r--games-server/crossfire-server/crossfire-server-1.11.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-server/crossfire-server/crossfire-server-1.11.0.ebuild b/games-server/crossfire-server/crossfire-server-1.11.0.ebuild
new file mode 100644
index 000000000000..a230ceb99fb8
--- /dev/null
+++ b/games-server/crossfire-server/crossfire-server-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/crossfire-server-1.11.0.ebuild,v 1.1 2008/02/11 01:44:50 mr_bones_ Exp $
+
+inherit games
+
+MY_P="${P/-server/}"
+DESCRIPTION="server for the crossfire clients"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${MY_P}.tar.gz
+ mirror://sourceforge/crossfire/crossfire-${PV}.maps.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+
+DEPEND="
+ X? (
+ x11-libs/libXaw
+ media-libs/libpng )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_with X x) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ keepdir "${GAMES_STATEDIR}"/crossfire/{datafiles,maps,players,template-maps,unique-items}
+ dodoc AUTHORS ChangeLog DEVELOPERS NEWS README TODO
+ insinto "${GAMES_DATADIR}/crossfire"
+ doins -r "${WORKDIR}/maps" || die "doins failed"
+ prepgamesdirs
+}