summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-05 04:44:07 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-05 04:44:07 +0000
commit7d6e6c37bf5c664a1136917bc2ca6e3076343be5 (patch)
tree43417b401905686a0ed17a5563f7b8c98a10e0f1 /games-server/hlstats
parentold (diff)
downloadgentoo-2-7d6e6c37bf5c664a1136917bc2ca6e3076343be5.tar.gz
gentoo-2-7d6e6c37bf5c664a1136917bc2ca6e3076343be5.tar.bz2
gentoo-2-7d6e6c37bf5c664a1136917bc2ca6e3076343be5.zip
Version bump #84878.
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-server/hlstats')
-rw-r--r--games-server/hlstats/ChangeLog7
-rw-r--r--games-server/hlstats/files/digest-hlstats-1.321
-rw-r--r--games-server/hlstats/hlstats-1.32.ebuild81
3 files changed, 88 insertions, 1 deletions
diff --git a/games-server/hlstats/ChangeLog b/games-server/hlstats/ChangeLog
index d6d92f39069b..6b235ca2f54e 100644
--- a/games-server/hlstats/ChangeLog
+++ b/games-server/hlstats/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-server/hlstats
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/ChangeLog,v 1.8 2005/03/11 18:12:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/ChangeLog,v 1.9 2005/04/05 04:44:07 vapier Exp $
+
+*hlstats-1.32 (05 Apr 2005)
+
+ 05 Apr 2005; Mike Frysinger <vapier@gentoo.org> +hlstats-1.32.ebuild:
+ Version bump #84878.
*hlstats-1.31 (11 Mar 2005)
diff --git a/games-server/hlstats/files/digest-hlstats-1.32 b/games-server/hlstats/files/digest-hlstats-1.32
new file mode 100644
index 000000000000..43158393f1d7
--- /dev/null
+++ b/games-server/hlstats/files/digest-hlstats-1.32
@@ -0,0 +1 @@
+MD5 4b683fed5b4b7a112a150cc51b6d8c67 hlstats-1.32.tar.gz 2067107
diff --git a/games-server/hlstats/hlstats-1.32.ebuild b/games-server/hlstats/hlstats-1.32.ebuild
new file mode 100644
index 000000000000..94f685cfeb45
--- /dev/null
+++ b/games-server/hlstats/hlstats-1.32.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/hlstats-1.32.ebuild,v 1.1 2005/04/05 04:44:07 vapier Exp $
+
+inherit games webapp
+
+DESCRIPTION="real-time player rankings/statistics for half-life"
+HOMEPAGE="http://www.hlstats.org/"
+SRC_URI="mirror://sourceforge/hlstats/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="dev-lang/perl
+ dev-db/mysql
+ net-www/apache
+ dev-php/mod_php"
+
+pkg_setup() {
+ webapp_pkg_setup
+ games_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ChangeLog
+
+ insinto ${GAMES_LIBDIR}/${PN}
+ doins *.{pm,plib}
+ insinto ${GAMES_DATADIR}/${PN}
+ doins *.sql
+
+ sed -i \
+ -e "s:\./hlstats\.conf:${GAMES_SYSCONFDIR}/hlstats.conf:" \
+ -e "/^\$opt_libdir =/s:=.*:=\"${GAMES_LIBDIR}/${PN}/\";:" \
+ *.pl || die "sed pl failed"
+ dogamesbin *.pl || die "dogamesbin failed"
+ dobin ${FILESDIR}/hlstats
+ dosed "s:GENTOO_DIR:${GAMES_BINDIR}:" /usr/bin/hlstats
+ newinitd ${FILESDIR}/hlstats.rc hlstats
+
+ insinto ${GAMES_SYSCONFDIR}
+ doins hlstats.conf
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r hlstats.php hlstatsimg hlstatsinc ${D}/${MY_HTDOCSDIR}/
+ webapp_serverowned ${MY_HTDOCSDIR}
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "To setup:"
+ einfo " 1. \`mysqladmin create hlstats\`"
+ einfo " 2. \`mysql hlstats < ${GAMES_DATADIR}/${PN}/hlstats.sql\`"
+ einfo " 3. \`mysql hlstats < ${GAMES_DATADIR}/${PN}/gamesupport_GAME.sql\`"
+ einfo " so if you want cstrike support, replace 'GAME' with 'cstrike'"
+ einfo " 4. Edit ${GAMES_SYSCONFDIR}/hlstats.conf"
+ einfo " 5. Edit ${MY_HTDOCSDIR}/hlstats.php"
+ einfo " 6. \`rc-update add hlstats default\`"
+ einfo " 7. \`/etc/init.d/hlstats start\`"
+ einfo " 8. Edit the cfg files of the game servers you want to track ..."
+ einfo " add these lines to your config file:"
+ einfo " log on"
+ einfo " logaddress 1.2.3.4 27500"
+ einfo " (replace 1.2.3.4 with the IP of the server hlstats is running on)"
+ einfo " 9. If you want daily awards, setup a cronjob to run hlstats-awards.pl"
+ einfo " for example, run \`crontab -e\` and add this entry:"
+ einfo " 30 00 * * * ${GAMES_BINDIR}/hlstats-awards.pl"
+ einfo " 10. Finally ! Start up the server and after a while goto"
+ einfo " http://1.2.3.4/hlstats.php"
+ einfo " (replace 1.2.3.4 with the IP of the server hlstats is running on)"
+ echo
+ einfo "To Upgrade:"
+ einfo " 1. \`mysql hlstats < ${GAMES_DATADIR}/${PN}/upgrade_from_1.31.sql\`"
+ webapp_pkg_postinst
+}