summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-05-19 14:40:56 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-05-19 14:40:56 +0000
commit3923fcf7619eeb46bb45452d8b22eff07a8a3c8f (patch)
treed024225d477d7fc1f0a3df87d2ced08d1a414df0 /games-server
parentRemoval of 2.6.34 for compile error and manifest update for bug #319993 (diff)
downloadgentoo-2-3923fcf7619eeb46bb45452d8b22eff07a8a3c8f.tar.gz
gentoo-2-3923fcf7619eeb46bb45452d8b22eff07a8a3c8f.tar.bz2
gentoo-2-3923fcf7619eeb46bb45452d8b22eff07a8a3c8f.zip
Fix build with gcc-4.5 Bug #320477
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/cyphesis/ChangeLog8
-rw-r--r--games-server/cyphesis/cyphesis-0.5.22.ebuild7
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.22-gcc45.patch10
3 files changed, 20 insertions, 5 deletions
diff --git a/games-server/cyphesis/ChangeLog b/games-server/cyphesis/ChangeLog
index d519335b68fc..e9d62a1cfb63 100644
--- a/games-server/cyphesis/ChangeLog
+++ b/games-server/cyphesis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-server/cyphesis
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.10 2009/12/16 06:00:50 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.11 2010/05/19 14:40:56 tupone Exp $
+
+ 19 May 2010; Tupone Alfredo <tupone@gentoo.org> cyphesis-0.5.22.ebuild,
+ +files/cyphesis-0.5.22-gcc45.patch:
+ Fix build with gcc-4.5 Bug #320477 by flameeyes@gentoo.org
*cyphesis-0.5.22 (16 Dec 2009)
diff --git a/games-server/cyphesis/cyphesis-0.5.22.ebuild b/games-server/cyphesis/cyphesis-0.5.22.ebuild
index e43038e3a699..d49228ce3d76 100644
--- a/games-server/cyphesis/cyphesis-0.5.22.ebuild
+++ b/games-server/cyphesis/cyphesis-0.5.22.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/cyphesis-0.5.22.ebuild,v 1.1 2009/12/16 06:00:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/cyphesis-0.5.22.ebuild,v 1.2 2010/05/19 14:40:56 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -29,7 +29,8 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc45.patch
eautoreconf
}
diff --git a/games-server/cyphesis/files/cyphesis-0.5.22-gcc45.patch b/games-server/cyphesis/files/cyphesis-0.5.22-gcc45.patch
new file mode 100644
index 000000000000..7e5c33da049c
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.22-gcc45.patch
@@ -0,0 +1,10 @@
+--- physics/Collision.h.old 2010-05-19 14:31:30.000000000 +0200
++++ physics/Collision.h 2010-05-19 14:31:44.000000000 +0200
+@@ -22,6 +22,7 @@
+
+ #include "physics/Vector3D.h"
+
++#include <wfmath/point.h>
+ #include <wfmath/axisbox.h>
+
+ #include <map>