summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-10-14 05:48:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-10-14 05:48:32 +0000
commitad637a2bcc1f0aa8667abad9842c8cc94a1ca5e0 (patch)
tree263c305ec98ef8b00b1617c0759fa7bea94f7f67 /games-simulation/crashtest/crashtest-1.1.ebuild
parentversion bump (diff)
downloadgentoo-2-ad637a2bcc1f0aa8667abad9842c8cc94a1ca5e0.tar.gz
gentoo-2-ad637a2bcc1f0aa8667abad9842c8cc94a1ca5e0.tar.bz2
gentoo-2-ad637a2bcc1f0aa8667abad9842c8cc94a1ca5e0.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-simulation/crashtest/crashtest-1.1.ebuild')
-rw-r--r--games-simulation/crashtest/crashtest-1.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-simulation/crashtest/crashtest-1.1.ebuild b/games-simulation/crashtest/crashtest-1.1.ebuild
new file mode 100644
index 000000000000..2abc46433b42
--- /dev/null
+++ b/games-simulation/crashtest/crashtest-1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crashtest/crashtest-1.1.ebuild,v 1.1 2009/10/14 05:48:31 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+DESCRIPTION="Educational car crash simulator"
+HOMEPAGE="http://bram.creative4vision.nl/crashtest/"
+SRC_URI="http://bram.creative4vision.nl/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/fltk:1.1[opengl]
+ dev-games/ode
+ media-libs/alsa-lib
+ virtual/opengl
+ virtual/glu
+ virtual/glut"
+DEPEND="${RDEPEND}
+ >=media-libs/plib-1.8.4"
+
+S=${WORKDIR}/${P}/src-${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
+ Makefile ${PN}.cxx \
+ || die "sed failed"
+ append-flags -DHAVE_ISNANF
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+ make_desktop_entry ${PN} Crashtest
+ prepgamesdirs
+}