summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2015-07-11 15:08:35 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2015-07-11 15:08:35 +0000
commit5ca0f68f99cd4e50076007ca20c85dd85b358fab (patch)
treee3dc28b9b6727e070ebe49cb30bff9b4995e1d1c /games-simulation/flightgear
parentVersion bump. Bug #554176. (diff)
downloadgentoo-2-5ca0f68f99cd4e50076007ca20c85dd85b358fab.tar.gz
gentoo-2-5ca0f68f99cd4e50076007ca20c85dd85b358fab.tar.bz2
gentoo-2-5ca0f68f99cd4e50076007ca20c85dd85b358fab.zip
Fix bug 554292.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key B1E955DB)
Diffstat (limited to 'games-simulation/flightgear')
-rw-r--r--games-simulation/flightgear/ChangeLog7
-rw-r--r--games-simulation/flightgear/files/0001-flightgear-3.4.0-cmake.patch30
-rw-r--r--games-simulation/flightgear/files/0002-flightgear-3.4.0-cmake.patch54
-rw-r--r--games-simulation/flightgear/flightgear-3.4.0.ebuild7
4 files changed, 96 insertions, 2 deletions
diff --git a/games-simulation/flightgear/ChangeLog b/games-simulation/flightgear/ChangeLog
index 86b78754e5a1..fe44e2534403 100644
--- a/games-simulation/flightgear/ChangeLog
+++ b/games-simulation/flightgear/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/flightgear
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.81 2015/05/14 22:38:35 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.82 2015/07/11 15:08:35 reavertm Exp $
+
+ 11 Jul 2015; Maciej Mrozowski <reavertm@gentoo.org>
+ +files/0001-flightgear-3.4.0-cmake.patch,
+ +files/0002-flightgear-3.4.0-cmake.patch, flightgear-3.4.0.ebuild:
+ Fix bug 554292.
14 May 2015; Maciej Mrozowski <reavertm@gentoo.org>
-flightgear-3.0.0-r1.ebuild, -flightgear-3.0.0.ebuild,
diff --git a/games-simulation/flightgear/files/0001-flightgear-3.4.0-cmake.patch b/games-simulation/flightgear/files/0001-flightgear-3.4.0-cmake.patch
new file mode 100644
index 000000000000..e14920b246c2
--- /dev/null
+++ b/games-simulation/flightgear/files/0001-flightgear-3.4.0-cmake.patch
@@ -0,0 +1,30 @@
+From 06a260822c0eb10f47533a2cbf5cbbc968878c17 Mon Sep 17 00:00:00 2001
+From: James Turner <zakalawe@mac.com>
+Date: Tue, 17 Mar 2015 23:33:57 +0000
+Subject: [PATCH] Make 3.2.1 fix: make thread check platform specific.
+
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8847614..c881c32 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -109,6 +109,8 @@ IF(APPLE)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mmacosx-version-min=10.7")
+ elseif(${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR
+ ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
++ find_package(Threads REQUIRED)
++
+ set(USE_DBUS_DEFAULT 1)
+
+ find_package(UDev)
+@@ -230,7 +232,6 @@ endif(EVENT_INPUT)
+ # check required dependencies
+ find_package(Boost REQUIRED)
+ find_package(ZLIB REQUIRED)
+-find_package(Threads REQUIRED)
+ find_package(OpenGL REQUIRED)
+ find_package(OpenAL REQUIRED)
+ find_package(OpenSceneGraph 3.2.0 REQUIRED
diff --git a/games-simulation/flightgear/files/0002-flightgear-3.4.0-cmake.patch b/games-simulation/flightgear/files/0002-flightgear-3.4.0-cmake.patch
new file mode 100644
index 000000000000..2151acdbbcf4
--- /dev/null
+++ b/games-simulation/flightgear/files/0002-flightgear-3.4.0-cmake.patch
@@ -0,0 +1,54 @@
+From 14405fe2e397b9a6ab9b004cb8c7459eeb41ec59 Mon Sep 17 00:00:00 2001
+From: "Rebecca N. Palmer" <rebecca_palmer@zoho.com>
+Date: Fri, 3 Apr 2015 19:15:52 +0100
+Subject: [PATCH] Fix compile with CMake 3.2.1, by Kevin Seroux
+
+Explicitly link X11, as this no longer comes with OpenGL
+---
+ CMakeLists.txt | 1 +
+ src/Main/CMakeLists.txt | 4 +++-
+ utils/fgviewer/CMakeLists.txt | 4 ++++
+ 3 files changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c881c32..c443f58 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -110,6 +110,7 @@ IF(APPLE)
+ elseif(${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR
+ ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ find_package(Threads REQUIRED)
++ find_package(X11 REQUIRED)
+
+ set(USE_DBUS_DEFAULT 1)
+
+diff --git a/src/Main/CMakeLists.txt b/src/Main/CMakeLists.txt
+index 949b379..4b6926e 100644
+--- a/src/Main/CMakeLists.txt
++++ b/src/Main/CMakeLists.txt
+@@ -130,7 +130,9 @@ endif()
+ if (CRASHRPT_FOUND)
+ target_link_libraries(fgfs ${CRASHRPT_LIBRARY})
+ endif()
+-
++if(X11_FOUND)
++ target_link_libraries(fgfs ${X11_LIBRARIES})
++endif()
+ target_link_libraries(fgfs
+ ${SQLITE3_LIBRARY}
+ ${SIMGEAR_LIBRARIES}
+diff --git a/utils/fgviewer/CMakeLists.txt b/utils/fgviewer/CMakeLists.txt
+index 165be74..bfc52ad 100644
+--- a/utils/fgviewer/CMakeLists.txt
++++ b/utils/fgviewer/CMakeLists.txt
+@@ -42,6 +42,10 @@ else()
+ endif()
+
+ add_executable(fgviewer ${FGVIEWER_SOURCES} ${FGVIEWER_RTI_SOURCES})
++if(X11_FOUND)
++ target_link_libraries(fgviewer ${X11_LIBRARIES})
++endif()
++
+ target_link_libraries(fgviewer
+ ${SIMGEAR_LIBRARIES}
+ ${OPENSCENEGRAPH_LIBRARIES}
diff --git a/games-simulation/flightgear/flightgear-3.4.0.ebuild b/games-simulation/flightgear/flightgear-3.4.0.ebuild
index cc123e643611..405038025f0b 100644
--- a/games-simulation/flightgear/flightgear-3.4.0.ebuild
+++ b/games-simulation/flightgear/flightgear-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-3.4.0.ebuild,v 1.4 2015/04/19 10:15:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-3.4.0.ebuild,v 1.5 2015/07/11 15:08:35 reavertm Exp $
EAPI=5
@@ -45,6 +45,11 @@ RDEPEND="${COMMON_DEPEND}
~games-simulation/${PN}-data-${PV}
"
+PATCHES=(
+ "${FILESDIR}/0001-${P}-cmake.patch"
+ "${FILESDIR}/0002-${P}-cmake.patch"
+)
+
DOCS=(AUTHORS ChangeLog NEWS README Thanks)
src_configure() {