summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-02-22 21:59:02 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-02-22 21:59:02 +0000
commita757018e6f89506c2f59d99cd9adbf7014739b60 (patch)
treec8d5c87d97cddbb42eff6010e2687648dcd38699 /games-simulation/lincity/lincity-1.12.1.ebuild
parent- redigest (diff)
downloadgentoo-2-a757018e6f89506c2f59d99cd9adbf7014739b60.tar.gz
gentoo-2-a757018e6f89506c2f59d99cd9adbf7014739b60.tar.bz2
gentoo-2-a757018e6f89506c2f59d99cd9adbf7014739b60.zip
Modular X dependency fix
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'games-simulation/lincity/lincity-1.12.1.ebuild')
-rw-r--r--games-simulation/lincity/lincity-1.12.1.ebuild26
1 files changed, 21 insertions, 5 deletions
diff --git a/games-simulation/lincity/lincity-1.12.1.ebuild b/games-simulation/lincity/lincity-1.12.1.ebuild
index c9615136f71f..ebc6894e80b6 100644
--- a/games-simulation/lincity/lincity-1.12.1.ebuild
+++ b/games-simulation/lincity/lincity-1.12.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/lincity/lincity-1.12.1.ebuild,v 1.4 2005/10/29 11:04:32 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/lincity/lincity-1.12.1.ebuild,v 1.5 2006/02/22 21:59:02 tupone Exp $
inherit games
@@ -14,11 +14,27 @@ KEYWORDS="amd64 ppc ~ppc-macos ~sparc x86"
IUSE="nls svga X"
# dep fix (bug #82318)
-DEPEND="virtual/libc
+DEPEND="
nls? ( sys-devel/gettext )
svga? ( media-libs/svgalib )
- X? ( virtual/x11 )
- !X? ( !svga? ( virtual/x11 ) )"
+ X? (
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libSM
+ )
+ virtual/x11
+ )
+ )
+ !svga? (
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libSM
+ )
+ virtual/x11
+ )
+ )"
src_compile() {
local myconf=