summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-04-08 08:48:11 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-04-08 08:48:11 +0000
commit309f755903e81f50e115740fe1ade9f0fbf77fce (patch)
treed37b29403108b8c807bf254ee9a1ee375a8a6591 /games-simulation/qct
parentRemove stale gnome-session-2.24 p.mask entries (diff)
downloadgentoo-2-309f755903e81f50e115740fe1ade9f0fbf77fce.tar.gz
gentoo-2-309f755903e81f50e115740fe1ade9f0fbf77fce.tar.bz2
gentoo-2-309f755903e81f50e115740fe1ade9f0fbf77fce.zip
Force use of python2 . Bug #312281
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-simulation/qct')
-rw-r--r--games-simulation/qct/ChangeLog7
-rw-r--r--games-simulation/qct/qct-0.7.ebuild24
2 files changed, 20 insertions, 11 deletions
diff --git a/games-simulation/qct/ChangeLog b/games-simulation/qct/ChangeLog
index 19ddb002fefa..f890da60d08a 100644
--- a/games-simulation/qct/ChangeLog
+++ b/games-simulation/qct/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/qct
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/ChangeLog,v 1.7 2006/05/24 15:53:48 wolf31o2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/ChangeLog,v 1.8 2010/04/08 08:48:11 tupone Exp $
+
+ 08 Apr 2010; Tupone Alfredo <tupone@gentoo.org> qct-0.7.ebuild:
+ Force use of python2 . Bug #312281 by arfrever@gentoo.org
24 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> qct-0.7.ebuild:
Fixed HOMEPAGE for bug #134218.
diff --git a/games-simulation/qct/qct-0.7.ebuild b/games-simulation/qct/qct-0.7.ebuild
index 4f7746bc6fce..b6a85f3f7abe 100644
--- a/games-simulation/qct/qct-0.7.ebuild
+++ b/games-simulation/qct/qct-0.7.ebuild
@@ -1,27 +1,28 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/qct-0.7.ebuild,v 1.8 2006/05/24 15:53:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/qct-0.7.ebuild,v 1.9 2010/04/08 08:48:11 tupone Exp $
+EAPI=2
+PYTHON_DEPEND="2"
-inherit eutils games
+inherit eutils python games
DESCRIPTION="Quiet Console Town puts you in the place of the mayor of a budding new console RPG city"
HOMEPAGE="http://llynmir.net/qct"
-SRC_URI="mirror://sourceforge/qct/${P}.tar.gz"
+SRC_URI="http://www.sourcefiles.org/Games/Role_Play/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-RDEPEND=">=dev-lang/python-2.2.1
- >=dev-python/pygame-1.5.5"
+RDEPEND=">=dev-python/pygame-1.5.5"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-constant.patch
+ python_convert_shebangs -r 2 .
}
src_install() {
@@ -37,3 +38,8 @@ src_install() {
prepgamesdirs
}
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}