summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-11 12:22:49 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-11 12:22:49 +0000
commit24cea9be2d2942f1a56de593b1a1455defa581f5 (patch)
treebabf0042eddc7e1e9769bfc4c4e9aafa8e876c06 /games-simulation/searchandrescue
parentfix dvdr support (diff)
downloadgentoo-2-24cea9be2d2942f1a56de593b1a1455defa581f5.tar.gz
gentoo-2-24cea9be2d2942f1a56de593b1a1455defa581f5.tar.bz2
gentoo-2-24cea9be2d2942f1a56de593b1a1455defa581f5.zip
simulation type games
Diffstat (limited to 'games-simulation/searchandrescue')
-rw-r--r--games-simulation/searchandrescue/ChangeLog8
-rw-r--r--games-simulation/searchandrescue/Manifest3
-rw-r--r--games-simulation/searchandrescue/files/digest-searchandrescue-0.8.12
-rw-r--r--games-simulation/searchandrescue/searchandrescue-0.8.1.ebuild57
4 files changed, 70 insertions, 0 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
new file mode 100644
index 000000000000..99788f13186e
--- /dev/null
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/searchandrescue
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.1 2003/09/11 12:22:49 vapier Exp $
+
+*searchandrescue-0.8.1 (30 Jul 2003)
+
+ 30 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-simulation/searchandrescue/Manifest b/games-simulation/searchandrescue/Manifest
new file mode 100644
index 000000000000..016bba6d3013
--- /dev/null
+++ b/games-simulation/searchandrescue/Manifest
@@ -0,0 +1,3 @@
+MD5 c62431addfa61f41f7cdccd18b139c9c searchandrescue-0.8.1.ebuild 1429
+MD5 fb2560ede2f6612695ebd7a69761fcf0 files/digest-searchandrescue-0.8.1 146
+MD5 8a1f9312e2b9e14aa8c432e7dfc4213b ChangeLog 365
diff --git a/games-simulation/searchandrescue/files/digest-searchandrescue-0.8.1 b/games-simulation/searchandrescue/files/digest-searchandrescue-0.8.1
new file mode 100644
index 000000000000..eb54fc346855
--- /dev/null
+++ b/games-simulation/searchandrescue/files/digest-searchandrescue-0.8.1
@@ -0,0 +1,2 @@
+MD5 4305a63efc20d9b481a08dfccbf91379 SearchAndRescue-0.8.1.tgz 802927
+MD5 e8fe773432c40c1825a67e956fbe9b45 SearchAndRescue-data-0.8.1.tgz 8192029
diff --git a/games-simulation/searchandrescue/searchandrescue-0.8.1.ebuild b/games-simulation/searchandrescue/searchandrescue-0.8.1.ebuild
new file mode 100644
index 000000000000..c530e2ce2069
--- /dev/null
+++ b/games-simulation/searchandrescue/searchandrescue-0.8.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.1.ebuild,v 1.1 2003/09/11 12:22:49 vapier Exp $
+
+inherit games
+
+MY_PN=SearchAndRescue
+DESCRIPTION="aircraft based rescue simulator"
+HOMEPAGE="http://wolfpack.twu.net/SearchAndRescue/"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${MY_PN}-${PV}.tgz
+ ftp://wolfpack.twu.net/users/wolfpack/${MY_PN}-data-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="joystick"
+
+DEPEND="virtual/x11
+ joystick? ( media-libs/libjsw )
+ virtual/opengl"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${MY_PN}-${PV}.tgz
+ mkdir data ; cd data
+ unpack ${MY_PN}-data-${PV}.tgz
+ cd ${S}
+ bunzip2 sar/man/${MY_PN}.6.bz2
+ sed -i "s:/usr/share/icons:/usr/share/icons/${PN}:g" sar/config.h
+ sed -i '/FeatureCFLAGS.*march/s:=.*:=:g' sar/platforms.ini
+}
+
+src_compile() {
+ local myjoyconf
+ [ `use joystick` ] \
+ && myjoyconf="--enable=joystick" \
+ || myjoyconf="--disable=joystick"
+ ./configure \
+ Linux \
+ --prefix=${GAMES_PREFIX} \
+ ${myjoyconf} \
+ || die
+ make || die
+}
+
+src_install() {
+ dogamesbin sar/${MY_PN}
+ insinto /usr/share/icons/${PN}
+ doman sar/man/${MY_PN}.6
+ doins sar/icons/*.{ico,xpm}
+ dodoc AUTHORS HACKING README
+ cd ${WORKDIR}/data
+ dodir ${GAMES_DATADIR}/${MY_PN}
+ cp -r * ${D}/${GAMES_DATADIR}/${MY_PN}/
+ prepgamesdirs
+}