summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-05-21 15:55:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-05-21 15:55:59 +0000
commit0a5c98b72df2419b7044648c8dcd771e6f155d62 (patch)
tree058b520fa7481de4228b6c3126b0765ec9c4a687 /games-simulation
parentChanged dependency for postgresql from dev-db/postgresql to virtual/postgresq... (diff)
downloadgentoo-2-0a5c98b72df2419b7044648c8dcd771e6f155d62.tar.gz
gentoo-2-0a5c98b72df2419b7044648c8dcd771e6f155d62.tar.bz2
gentoo-2-0a5c98b72df2419b7044648c8dcd771e6f155d62.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/cultivation/cultivation-7.ebuild47
-rw-r--r--games-simulation/cultivation/files/cultivation-7-gentoo.patch86
2 files changed, 0 insertions, 133 deletions
diff --git a/games-simulation/cultivation/cultivation-7.ebuild b/games-simulation/cultivation/cultivation-7.ebuild
deleted file mode 100644
index d5f5d10a1f90..000000000000
--- a/games-simulation/cultivation/cultivation-7.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cultivation/cultivation-7.ebuild,v 1.4 2007/06/12 13:04:43 nyhm Exp $
-
-inherit eutils games
-
-MY_P=Cultivation_${PV}_UnixSource
-DESCRIPTION="A game about the interactions within a gardening community"
-HOMEPAGE="http://cultivation.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="virtual/glut
- media-libs/pablio"
-
-S=${WORKDIR}/${MY_P}/game2/gameSource
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}"-gentoo.patch
- sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
- ../../minorGems/util/TranslationManager.cpp \
- features.cpp \
- game.cpp \
- || die "sed failed"
-}
-
-src_compile() {
- cd ..
- # not an autoconf script
- platformSelection=1 ./configure || die
- cd gameSource
- emake || die "emake failed"
-}
-
-src_install() {
- newgamesbin Cultivation ${PN} || die "newgamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r features.txt font.tga language.txt languages || die "doins failed"
- dodoc ../documentation/*.txt
- prepgamesdirs
-}
diff --git a/games-simulation/cultivation/files/cultivation-7-gentoo.patch b/games-simulation/cultivation/files/cultivation-7-gentoo.patch
deleted file mode 100644
index 03bc8e80bd8e..000000000000
--- a/games-simulation/cultivation/files/cultivation-7-gentoo.patch
+++ /dev/null
@@ -1,86 +0,0 @@
---- ../../minorGems/util/TranslationManager.cpp.old 2007-05-17 00:04:50.000000000 +0200
-+++ ../../minorGems/util/TranslationManager.cpp 2007-05-17 00:05:09.000000000 +0200
-@@ -147,7 +147,7 @@
- mNaturalLanguageStrings( NULL ) {
-
- // default
-- setDirectoryAndLanguage( "languages", "English" );
-+ setDirectoryAndLanguage( "@GENTOO_DATADIR@/languages", "English" );
- }
-
-
---- game.cpp.old 2007-05-17 00:16:44.000000000 +0200
-+++ game.cpp 2007-05-17 00:17:18.000000000 +0200
-@@ -589,7 +589,7 @@
- mStartTimeSeconds( time( NULL ) ),
- mPaused( false ),
- mMaxFrameRate( 400 ), // don't limit frame rate
-- mPrintFrameRate( true ),
-+ mPrintFrameRate( false ),
- mNumFrames( 0 ), mFrameBatchSize( 100 ),
- mFrameBatchStartTimeSeconds( time( NULL ) ),
- mFrameBatchStartTimeMilliseconds( 0 ),
-@@ -897,7 +897,7 @@
- // load font image
- TGAImageConverter tga;
-
-- File fontFile( NULL, "font.tga" );
-+ File fontFile( NULL, "@GENTOO_DATADIR@/font.tga" );
- FileInputStream fontInput( &fontFile );
-
- Image *fontImage = tga.deformatImage( &fontInput );
-@@ -980,7 +980,7 @@
- mCurrentTipStoredItem = -1;
-
- // translation language for tool tips
-- File languageNameFile( NULL, "language.txt" );
-+ File languageNameFile( NULL, "@GENTOO_DATADIR@/language.txt" );
-
- if( languageNameFile.exists() ) {
- char *languageNameText = languageNameFile.readFileContents();
---- features.cpp.old 2007-05-17 00:20:16.000000000 +0200
-+++ features.cpp 2007-05-17 00:20:54.000000000 +0200
-@@ -57,7 +57,7 @@
-
-
- void initializeFeatures() {
-- FILE *featuresFile = fopen( "features.txt", "r" );
-+ FILE *featuresFile = fopen( "@GENTOO_DATADIR@/features.txt", "r" );
-
- char stringBuffer[100];
- int switchValue;
---- sound/SoundPlayer.h.old 2007-05-17 20:23:32.000000000 +0200
-+++ sound/SoundPlayer.h 2007-05-17 20:24:39.000000000 +0200
-@@ -52,8 +52,8 @@
- #include "SoundFilter.h"
- #include "PlayableSound.h"
-
--#include "minorGems/sound/portaudio/pa_common/portaudio.h"
--#include "minorGems/sound/portaudio/pablio/pablio.h"
-+#include <portaudio/portaudio.h>
-+#include <portaudio/pablio.h>
-
-
- #include "minorGems/util/SimpleVector.h"
---- ../Makefile.common.old 2007-05-17 20:33:05.000000000 +0200
-+++ ../Makefile.common 2007-05-17 20:33:37.000000000 +0200
-@@ -51,7 +51,7 @@
-
-
-
--COMPILE_FLAGS = -Wall ${DEBUG_FLAG} ${PLATFORM_COMPILE_FLAGS} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} -I${ROOT_PATH} -I${PORT_AUDIO_PATH}/pa_common
-+COMPILE_FLAGS = $(CXXFLAGS) ${PLATFORM_COMPILE_FLAGS} -I${ROOT_PATH}
-
-
- COMPILE = ${GXX} ${COMPILE_FLAGS} -c
---- ../Makefile.GnuLinux.old 2007-05-17 20:32:12.000000000 +0200
-+++ ../Makefile.GnuLinux 2007-05-17 20:32:35.000000000 +0200
-@@ -17,7 +17,7 @@
-
- # various GL and X windows librariesneeded for linux
- # also need portaudio library (which in turn needs pthreads)
--PLATFORM_LINK_FLAGS = -L/usr/X11R6/lib -lGL -lglut -lGLU -lX11 -lXi -lXext -lXmu ${PORT_AUDIO_PATH}/lib/libportaudio.a -lpthread
-+PLATFORM_LINK_FLAGS = -L/usr/X11R6/lib -lGL -lglut -lGLU -lX11 -lXi -lXext -lXmu -lportaudio -lpthread
-
-
- # All platforms but OSX support g++ and need no linker hacks