summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-03-21 01:44:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-03-21 01:44:13 +0000
commit4c2f90eeb5463c35b3717961c0fcac8e05af7014 (patch)
tree16c9af6d446452f17ba9e0570ceb0f7daec1a46c /games-simulation
parentadd virtual/pkgconfig to DEPEND (diff)
downloadgentoo-2-4c2f90eeb5463c35b3717961c0fcac8e05af7014.tar.gz
gentoo-2-4c2f90eeb5463c35b3717961c0fcac8e05af7014.tar.bz2
gentoo-2-4c2f90eeb5463c35b3717961c0fcac8e05af7014.zip
version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/simutrans/ChangeLog9
-rw-r--r--games-simulation/simutrans/files/simutrans-0.112.2-Makefile.patch102
-rw-r--r--games-simulation/simutrans/files/simutrans-0.112.2-overflow.patch11
-rw-r--r--games-simulation/simutrans/simutrans-0.112.2.ebuild60
4 files changed, 181 insertions, 1 deletions
diff --git a/games-simulation/simutrans/ChangeLog b/games-simulation/simutrans/ChangeLog
index 4493ded86ff0..a2288b20a391 100644
--- a/games-simulation/simutrans/ChangeLog
+++ b/games-simulation/simutrans/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-simulation/simutrans
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/ChangeLog,v 1.30 2013/01/22 22:33:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/ChangeLog,v 1.31 2013/03/21 01:44:13 mr_bones_ Exp $
+
+*simutrans-0.112.2 (21 Mar 2013)
+
+ 21 Mar 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/simutrans-0.112.2-Makefile.patch,
+ +files/simutrans-0.112.2-overflow.patch, +simutrans-0.112.2.ebuild:
+ version bump
*simutrans-0.112.1 (22 Jan 2013)
diff --git a/games-simulation/simutrans/files/simutrans-0.112.2-Makefile.patch b/games-simulation/simutrans/files/simutrans-0.112.2-Makefile.patch
new file mode 100644
index 000000000000..26a563a58454
--- /dev/null
+++ b/games-simulation/simutrans/files/simutrans-0.112.2-Makefile.patch
@@ -0,0 +1,102 @@
+--- Makefile.orig 2013-01-22 16:53:11.574351933 -0500
++++ Makefile 2013-01-22 16:57:38.801999641 -0500
+@@ -90,7 +90,6 @@
+ endif
+ endif
+ else
+- CFLAGS += -O
+ endif
+
+ ifdef DEBUG
+@@ -109,6 +108,7 @@
+ endif
+ else
+ CFLAGS += -DNDEBUG
++ CXXFLAGS += -DNDEBUG
+ endif
+
+ ifneq ($(PROFILE),)
+@@ -121,6 +121,7 @@
+
+ ifneq ($(MULTI_THREAD),)
+ CFLAGS += -DMULTI_THREAD=$(MULTI_THREAD)
++ CXXFLAGS += -DMULTI_THREAD=$(MULTI_THREAD)
+ ifneq ($(MULTI_THREAD),1)
+ ifeq ($(OSTYPE),mingw)
+ #use lpthreadGC2d for debug alternatively
+@@ -135,10 +136,12 @@
+ REV = $(shell svnversion)
+ ifneq ($(REV),)
+ CFLAGS += -DREVISION="$(REV)"
++ CXXFLAGS += -DREVISION="$(REV)"
+ endif
+ endif
+
+ CFLAGS += -Wall -W -Wcast-qual -Wpointer-arith -Wcast-align $(FLAGS)
++CXXFLAGS += -Wall -W -Wcast-qual -Wpointer-arith -Wcast-align $(FLAGS)
+ CCFLAGS += -Wstrict-prototypes
+
+
+@@ -450,6 +453,7 @@
+ ifeq ($(BACKEND),sdl)
+ SOURCES += simsys_s.cc
+ CFLAGS += -DUSE_16BIT_DIB
++ CXXFLAGS += -DUSE_16BIT_DIB
+ ifeq ($(OSTYPE),mac)
+ # Core Audio (Quicktime) base sound system routines
+ SOURCES += sound/core-audio_sound.mm
+@@ -482,6 +486,7 @@
+ endif
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS)
+ endif
+
+@@ -491,6 +496,7 @@
+ SOURCES += sound/sdl_mixer_sound.cc
+ SOURCES += music/sdl_midi.cc
+ CFLAGS += -DUSE_16BIT_DIB
++ CXXFLAGS += -DUSE_16BIT_DIB
+ ifeq ($(SDL_CONFIG),)
+ SDL_CFLAGS := -I$(MINGDIR)/include/SDL -Dmain=SDL_main
+ SDL_LDFLAGS := -lmingw32 -lSDLmain -lSDL
+@@ -505,12 +511,14 @@
+ endif
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS) -lSDL_mixer
+ endif
+
+ ifeq ($(BACKEND),opengl)
+ SOURCES += simsys_opengl.cc
+ CFLAGS += -DUSE_16BIT_DIB
++ CXXFLAGS += -DUSE_16BIT_DIB
+ ifeq ($(OSTYPE),mac)
+ # Core Audio (Quicktime) base sound system routines
+ SOURCES += sound/core-audio_sound.mm
+@@ -538,6 +546,7 @@
+ endif
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS)
+ ifeq ($(OSTYPE),mingw)
+ LIBS += -lopengl32
+@@ -553,6 +562,7 @@
+ endif
+
+ CFLAGS += -DCOLOUR_DEPTH=$(COLOUR_DEPTH)
++CXXFLAGS += -DCOLOUR_DEPTH=$(COLOUR_DEPTH)
+
+ ifneq ($(findstring $(OSTYPE), cygwin mingw),)
+ SOURCES += simres.rc
+@@ -560,7 +570,6 @@
+ endif
+
+ CCFLAGS += $(CFLAGS)
+-CXXFLAGS += $(CFLAGS)
+
+ BUILDDIR ?= build/$(CFG)
+ PROGDIR ?= $(BUILDDIR)
diff --git a/games-simulation/simutrans/files/simutrans-0.112.2-overflow.patch b/games-simulation/simutrans/files/simutrans-0.112.2-overflow.patch
new file mode 100644
index 000000000000..6597ca071f92
--- /dev/null
+++ b/games-simulation/simutrans/files/simutrans-0.112.2-overflow.patch
@@ -0,0 +1,11 @@
+--- besch/reader/obj_reader.cc.orig 2013-01-22 17:22:02.509818038 -0500
++++ besch/reader/obj_reader.cc 2013-01-22 17:22:58.650846577 -0500
+@@ -308,7 +308,7 @@
+ void obj_reader_t::skip_nodes(FILE *fp,uint32 version)
+ {
+ obj_node_info_t node;
+- char load_dummy[OBJ_NODE_INFO_SIZE], *p;
++ char load_dummy[OBJ_NODE_INFO_SIZE + 4], *p; // extra 4 for LARGE_RECORD_SIZE
+
+ p = load_dummy;
+ if( version==COMPILER_VERSION_CODE_11 ) {
diff --git a/games-simulation/simutrans/simutrans-0.112.2.ebuild b/games-simulation/simutrans/simutrans-0.112.2.ebuild
new file mode 100644
index 000000000000..7ace1e68dc98
--- /dev/null
+++ b/games-simulation/simutrans/simutrans-0.112.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/simutrans-0.112.2.ebuild,v 1.1 2013/03/21 01:44:13 mr_bones_ Exp $
+
+EAPI=5
+inherit flag-o-matic eutils games
+
+MY_PV=${PV/0./}
+MY_PV=${MY_PV//./-}
+MY_FOOD_PV=${MY_PV/%-2/-1}
+DESCRIPTION="A free Transport Tycoon clone"
+HOMEPAGE="http://www.simutrans.com/"
+SRC_URI="mirror://sourceforge/simutrans/simutrans-src-${MY_PV}.zip
+ mirror://sourceforge/simutrans/simupak64-${MY_PV}.zip
+ mirror://sourceforge/simutrans/simupak64-addon-food-${MY_FOOD_PV}.zip"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[audio,video]
+ sys-libs/zlib
+ app-arch/bzip2
+ media-libs/libpng:0
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ strip-flags # bug #293927
+ echo "BACKEND=mixer_sdl
+COLOUR_DEPTH=16
+OSTYPE=linux
+VERBOSE=1" > config.default || die
+
+ if use !x86 ; then
+ echo "FLAGS+= -DUSE_C" >> config.default || die
+ fi
+ # make it look in the install location for the data
+ sed -i \
+ -e "s:argv\[0\]:\"${GAMES_DATADIR}/${PN}/\":" \
+ simmain.cc || die
+
+ epatch \
+ "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-overflow.patch
+}
+
+src_install() {
+ newgamesbin build/default/sim ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r simutrans/*
+ dodoc documentation/*
+ doicon simutrans.ico
+ make_desktop_entry simutrans Simutrans /usr/share/pixmaps/simutrans.ico
+ prepgamesdirs
+}