summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-11-08 09:47:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-11-08 09:47:30 +0000
commit5edc3aec183dc2e8af8d94aa8820e17cc5514ea8 (patch)
tree083151ec0356b9455b770db9174e817913f737b4 /games-simulation
parentMove to virtual/jpeg (diff)
downloadgentoo-2-5edc3aec183dc2e8af8d94aa8820e17cc5514ea8.tar.gz
gentoo-2-5edc3aec183dc2e8af8d94aa8820e17cc5514ea8.tar.bz2
gentoo-2-5edc3aec183dc2e8af8d94aa8820e17cc5514ea8.zip
clean old version and files (drops ppc to ~)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/searchandrescue/ChangeLog11
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc33.patch31
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc41.patch669
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc412.patch56
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc441.patch12
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-0.8.2-makejs.patch9
-rw-r--r--games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild82
7 files changed, 10 insertions, 860 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
index 3f26b1946430..c04ca06703ef 100644
--- a/games-simulation/searchandrescue/ChangeLog
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-simulation/searchandrescue
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.27 2010/10/22 14:35:51 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.28 2010/11/08 09:47:29 mr_bones_ Exp $
+
+ 08 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ -searchandrescue-0.8.2-r1.ebuild,
+ -files/searchandrescue-0.8.2-gcc33.patch,
+ -files/searchandrescue-0.8.2-gcc41.patch,
+ -files/searchandrescue-0.8.2-gcc412.patch,
+ -files/searchandrescue-0.8.2-gcc441.patch,
+ -files/searchandrescue-0.8.2-makejs.patch:
+ clean old version and files (drops ppc to ~)
22 Oct 2010; Christian Faulhammer <fauli@gentoo.org>
searchandrescue-1.1.0.ebuild:
diff --git a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc33.patch b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc33.patch
deleted file mode 100644
index b1cbe3ff9e65..000000000000
--- a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc33.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Work around a gcc-3.3.x bug where redefining prototypes with different
-__THROW / attribute(nonnull) markings throws an error:
-
-string.cpp:31: error: declaration of `char* strcasestr(const char*, const char*)' throws different exceptions
-../include/string.h:46: error: than previous declaration `char* strcasestr(const char*, const char*) throw ()'
-
-basically we just use the glibc strcasestr() instead of the internal one.
-
-http://bugs.gentoo.org/show_bug.cgi?id=85780
-
---- sar/string.cpp
-+++ sar/string.cpp
-@@ -38,3 +38,5 @@
- #endif
-+#ifndef _GNU_SOURCE
- char *strcasestr(const char *haystack, const char *needle);
-+#endif
- int strpfx(const char *s, const char *pfx);
-@@ -222,3 +223,4 @@
- */
-+#ifndef _GNU_SOURCE
- char *strcasestr(const char *haystack, const char *needle)
- {
-@@ -281,6 +281,7 @@
-
- return(NULL);
- }
-+#endif
-
- /*
- * Checks if string pfx is a prefix of string s.
diff --git a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc41.patch b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc41.patch
deleted file mode 100644
index 4d89f00415b6..000000000000
--- a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc41.patch
+++ /dev/null
@@ -1,669 +0,0 @@
---- sar/disk.cpp.old 2006-04-08 12:06:34.000000000 +0200
-+++ sar/disk.cpp 2006-04-08 12:08:13.000000000 +0200
-@@ -131,11 +131,7 @@
- return(0);
-
- // Dan S: typecast is due to const.
--#if defined(__cplusplus) || defined(c_plusplus)
-- while(ISBLANK(reinterpret_cast<char>(*path)))
--#else
- while(ISBLANK(*path))
--#endif
- path++;
-
- return(*path == DIR_DELIMINATOR);
---- sar/menumap.c.old 2006-04-08 11:41:01.000000000 +0200
-+++ sar/menumap.c 2006-04-08 11:41:48.000000000 +0200
-@@ -279,9 +279,10 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)map = SAR_MENU_MAP(calloc(
-+ m->object[n] = SAR_MENU_MAP(calloc(
- 1, sizeof(sar_menu_map_struct)
- ));
-+ map = (sar_menu_map_struct *)m->object[n];
- if(map == NULL)
- return(-1);
-
---- sar/sarfioopen.c.old 2006-04-08 11:43:53.000000000 +0200
-+++ sar/sarfioopen.c 2006-04-08 12:02:13.000000000 +0200
-@@ -270,7 +270,7 @@
- )
- {
- sar_parm_version_struct *pv =
-- (sar_parm_version_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_VERSION
- );
-
-@@ -295,7 +295,7 @@
- )
- {
- sar_parm_name_struct *pv =
-- (sar_parm_name_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_NAME
- );
-
-@@ -311,7 +311,7 @@
- )
- {
- sar_parm_description_struct *pv =
-- (sar_parm_description_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_DESCRIPTION
- );
-
-@@ -326,7 +326,7 @@
- )
- {
- sar_parm_player_model_file_struct *pv =
-- (sar_parm_player_model_file_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_PLAYER_MODEL_FILE
- );
-
-@@ -343,7 +343,7 @@
- )
- {
- sar_parm_weather_struct *pv =
-- (sar_parm_weather_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_WEATHER
- );
-
-@@ -361,7 +361,7 @@
- {
- int h, m, s;
- sar_parm_time_of_day_struct *pv =
-- (sar_parm_time_of_day_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_TIME_OF_DAY
- );
-
-@@ -382,7 +382,7 @@
- )
- {
- sar_parm_register_location_struct *pv =
-- (sar_parm_register_location_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_REGISTER_LOCATION
- );
-
-@@ -418,7 +418,7 @@
- )
- {
- sar_parm_scene_gps_struct *pv =
-- (sar_parm_scene_gps_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_SCENE_GPS
- );
-
-@@ -440,7 +440,7 @@
- )
- {
- sar_parm_scene_map_struct *pv =
-- (sar_parm_scene_map_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_SCENE_MAP
- );
-
-@@ -464,7 +464,7 @@
- )
- {
- sar_parm_scene_elevation_struct *pv =
-- (sar_parm_scene_elevation_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_SCENE_ELEVATION
- );
-
-@@ -480,7 +480,7 @@
- )
- {
- sar_parm_scene_cant_struct *pv =
-- (sar_parm_scene_cant_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_SCENE_CANT
- );
-
-@@ -496,7 +496,7 @@
- )
- {
- sar_parm_scene_ground_flags_struct *pv =
-- (sar_parm_scene_ground_flags_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_SCENE_GROUND_FLAGS
- );
-
-@@ -522,7 +522,7 @@
- )
- {
- sar_parm_scene_ground_tile_struct *pv =
-- (sar_parm_scene_ground_tile_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_SCENE_GROUND_TILE
- );
-
-@@ -560,7 +560,7 @@
- )
- {
- sar_parm_texture_base_directory_struct *pv =
-- (sar_parm_texture_base_directory_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_TEXTURE_BASE_DIRECTORY
- );
-
-@@ -576,7 +576,7 @@
- )
- {
- sar_parm_texture_load_struct *pv =
-- (sar_parm_texture_load_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_TEXTURE_LOAD
- );
-
-@@ -605,7 +605,7 @@
- )
- {
- sar_parm_mission_scene_file_struct *pv =
-- (sar_parm_mission_scene_file_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MISSION_SCENE_FILE
- );
-
-@@ -620,7 +620,7 @@
- )
- {
- sar_parm_mission_new_objective_struct *pv =
-- (sar_parm_mission_new_objective_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MISSION_NEW_OBJECTIVE
- );
-
-@@ -660,7 +660,7 @@
- )
- {
- sar_parm_mission_time_left_struct *pv =
-- (sar_parm_mission_time_left_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MISSION_TIME_LEFT
- );
-
-@@ -676,7 +676,7 @@
- )
- {
- sar_parm_mission_begin_at_struct *pv =
-- (sar_parm_mission_begin_at_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MISSION_BEGIN_AT
- );
-
-@@ -695,7 +695,7 @@
- )
- {
- sar_parm_mission_begin_at_pos_struct *pv =
-- (sar_parm_mission_begin_at_pos_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MISSION_BEGIN_AT_POS
- );
-
-@@ -723,7 +723,7 @@
- )
- {
- sar_parm_mission_arrive_at_struct *pv =
-- (sar_parm_mission_arrive_at_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MISSION_ARRIVE_AT
- );
-
-@@ -742,7 +742,7 @@
- )
- {
- sar_parm_mission_message_success_struct *pv =
-- (sar_parm_mission_message_success_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MISSION_MESSAGE_SUCCESS
- );
-
-@@ -761,7 +761,7 @@
- )
- {
- sar_parm_mission_message_fail_struct *pv =
-- (sar_parm_mission_message_fail_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MISSION_MESSAGE_FAIL
- );
-
-@@ -780,7 +780,7 @@
- )
- {
- sar_parm_mission_humans_tally_struct *pv =
-- (sar_parm_mission_humans_tally_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MISSION_HUMANS_TALLY
- );
-
-@@ -810,7 +810,7 @@
- )
- {
- sar_parm_mission_add_intercept_struct *pv =
-- (sar_parm_mission_add_intercept_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MISSION_ADD_INTERCEPT
- );
-
-@@ -883,7 +883,7 @@
- )
- {
- sar_parm_new_object_struct *pv =
-- (sar_parm_new_object_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_NEW_OBJECT
- );
-
-@@ -901,7 +901,7 @@
- )
- {
- sar_parm_new_helipad_struct *pv =
-- (sar_parm_new_helipad_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_NEW_HELIPAD
- );
-
-@@ -1005,7 +1005,7 @@
- )
- {
- sar_parm_new_runway_struct *pv =
-- (sar_parm_new_runway_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_NEW_RUNWAY
- );
-
-@@ -1108,7 +1108,7 @@
- )
- {
- sar_parm_new_human_struct *pv =
-- (sar_parm_new_human_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_NEW_HUMAN
- );
-
-@@ -1186,7 +1186,7 @@
- )
- {
- sar_parm_new_fire_struct *pv =
-- (sar_parm_new_fire_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_NEW_FIRE
- );
-
-@@ -1211,7 +1211,7 @@
- )
- {
- sar_parm_new_smoke_struct *pv =
-- (sar_parm_new_smoke_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_NEW_SMOKE
- );
-
-@@ -1254,7 +1254,7 @@
- )
- {
- sar_parm_new_premodeled_struct *pv =
-- (sar_parm_new_premodeled_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_NEW_PREMODELED
- );
-
-@@ -1278,7 +1278,7 @@
- )
- {
- sar_parm_select_object_by_name_struct *pv =
-- (sar_parm_select_object_by_name_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_SELECT_OBJECT_BY_NAME
- );
-
-@@ -1298,7 +1298,7 @@
- )
- {
- sar_parm_model_file_struct *pv =
-- (sar_parm_model_file_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_MODEL_FILE
- );
-
-@@ -1316,7 +1316,7 @@
- )
- {
- sar_parm_range_struct *pv =
-- (sar_parm_range_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_RANGE
- );
-
-@@ -1338,7 +1338,7 @@
- )
- {
- sar_parm_range_far_struct *pv =
-- (sar_parm_range_far_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_RANGE_FAR
- );
-
-@@ -1361,7 +1361,7 @@
- )
- {
- sar_parm_translate_struct *pv =
-- (sar_parm_translate_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_TRANSLATE
- );
-
-@@ -1382,7 +1382,7 @@
- )
- {
- sar_parm_translate_random_struct *pv =
-- (sar_parm_translate_random_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_TRANSLATE_RANDOM
- );
-
-@@ -1401,7 +1401,7 @@
- )
- {
- sar_parm_rotate_struct *pv =
-- (sar_parm_rotate_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_ROTATE
- );
-
-@@ -1421,7 +1421,7 @@
- )
- {
- sar_parm_no_depth_test_struct *pv =
-- (sar_parm_no_depth_test_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_NO_DEPTH_TEST
- );
-
-@@ -1435,7 +1435,7 @@
- )
- {
- sar_parm_polygon_offset_struct *pv =
-- (sar_parm_polygon_offset_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_POLYGON_OFFSET
- );
-
-@@ -1481,7 +1481,7 @@
- )
- {
- sar_parm_contact_bounds_spherical_struct *pv =
-- (sar_parm_contact_bounds_spherical_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_CONTACT_BOUNDS_SPHERICAL
- );
-
-@@ -1503,7 +1503,7 @@
- )
- {
- sar_parm_contact_bounds_cylendrical_struct *pv =
-- (sar_parm_contact_bounds_cylendrical_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_CONTACT_BOUNDS_CYLENDRICAL
- );
-
-@@ -1538,7 +1538,7 @@
- )
- {
- sar_parm_contact_bounds_rectangular_struct *pv =
-- (sar_parm_contact_bounds_rectangular_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_CONTACT_BOUNDS_RECTANGULAR
- );
-
-@@ -1589,7 +1589,7 @@
- )
- {
- sar_parm_ground_elevation_struct *pv =
-- (sar_parm_ground_elevation_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_GROUND_ELEVATION
- );
-
-@@ -1606,7 +1606,7 @@
- )
- {
- sar_parm_object_name_struct *pv =
-- (sar_parm_object_name_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_OBJECT_NAME
- );
-
-@@ -1627,7 +1627,7 @@
- )
- {
- sar_parm_object_map_description_struct *pv =
-- (sar_parm_object_map_description_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_OBJECT_MAP_DESCRIPTION
- );
-
-@@ -1645,7 +1645,7 @@
- )
- {
- sar_parm_fuel_struct *pv =
-- (sar_parm_fuel_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_FUEL
- );
-
-@@ -1670,7 +1670,7 @@
- )
- {
- sar_parm_hitpoints_struct *pv =
-- (sar_parm_hitpoints_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_HITPOINTS
- );
-
-@@ -1695,7 +1695,7 @@
- )
- {
- sar_parm_engine_state_struct *pv =
-- (sar_parm_engine_state_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_ENGINE_STATE
- );
-
-@@ -1711,7 +1711,7 @@
- )
- {
- sar_parm_passengers_struct *pv =
-- (sar_parm_passengers_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_PASSENGERS
- );
-
-@@ -1738,7 +1738,7 @@
- )
- {
- sar_parm_runway_approach_lighting_north_struct *pv =
-- (sar_parm_runway_approach_lighting_north_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_RUNWAY_APPROACH_LIGHTING_NORTH
- );
-
-@@ -1776,7 +1776,7 @@
- )
- {
- sar_parm_runway_approach_lighting_south_struct *pv =
-- (sar_parm_runway_approach_lighting_south_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_RUNWAY_APPROACH_LIGHTING_SOUTH
- );
-
-@@ -1815,7 +1815,7 @@
- )
- {
- sar_parm_human_message_enter_struct *pv =
-- (sar_parm_human_message_enter_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_HUMAN_MESSAGE_ENTER
- );
-
-@@ -1834,7 +1834,7 @@
- )
- {
- sar_parm_human_reference_struct *pv =
-- (sar_parm_human_reference_struct *)p = SARParmNew(
-+ p = SARParmNew(
- SAR_PARM_HUMAN_REFERENCE
- );
-
-@@ -2030,7 +2030,7 @@
- if(FILTER_CHECK(SAR_PARM_MISSION_LOG_HEADER))
- {
- p_mission_log_header =
-- (sar_parm_mission_log_header_struct *)p =
-+ p =
- SARParmNew(SAR_PARM_MISSION_LOG_HEADER);
-
- DO_ADD_PARM
---- sar/menu.c.old 2006-04-08 11:27:14.000000000 +0200
-+++ sar/menu.c 2006-04-08 11:40:37.000000000 +0200
-@@ -701,9 +701,8 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)label_ptr = SAR_MENU_LABEL(calloc(
-- 1, sizeof(sar_menu_label_struct)
-- ));
-+ m->object[n] = SAR_MENU_LABEL(calloc(1, sizeof(sar_menu_label_struct)));
-+ label_ptr = (sar_menu_label_struct *)m->object[n];
- if(label_ptr == NULL)
- return(-3);
-
-@@ -780,9 +779,10 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)button = SAR_MENU_BUTTON(calloc(
-+ m->object[n] = SAR_MENU_BUTTON(calloc(
- 1, sizeof(sar_menu_button_struct)
- ));
-+ button = (sar_menu_button_struct *)m->object[n];
- if(button == NULL)
- return(-3);
-
-@@ -861,9 +861,10 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)pb = SAR_MENU_PROGRESS(calloc(
-+ m->object[n] = SAR_MENU_PROGRESS(calloc(
- 1, sizeof(sar_menu_progress_struct)
- ));
-+ pb = (sar_menu_progress_struct *)m->object[n];
- if(pb == NULL)
- return(-3);
-
-@@ -964,9 +965,10 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)mesgbox = SAR_MENU_MESSAGE_BOX(calloc(
-+ m->object[n] = SAR_MENU_MESSAGE_BOX(calloc(
- 1, sizeof(sar_menu_message_box_struct)
- ));
-+ mesgbox = (sar_menu_message_box_struct *)m->object[n];
- if(mesgbox == NULL)
- return(-3);
-
-@@ -1078,9 +1080,10 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)list = SAR_MENU_LIST(calloc(
-+ m->object[n] = SAR_MENU_LIST(calloc(
- 1, sizeof(sar_menu_list_struct)
- ));
-+ list = (sar_menu_list_struct *)m->object[n];
- if(list == NULL)
- return(-3);
-
-@@ -1326,9 +1329,10 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)mdpy = SAR_MENU_MDISPLAY(calloc(
-+ m->object[n] = SAR_MENU_MDISPLAY(calloc(
- 1, sizeof(sar_menu_mdisplay_struct)
- ));
-+ mdpy = (sar_menu_mdisplay_struct *)m->object[n];
- if(mdpy == NULL)
- return(-3);
-
-@@ -1416,9 +1420,10 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)sw = SAR_MENU_SWITCH(calloc(
-+ m->object[n] = SAR_MENU_SWITCH(calloc(
- 1, sizeof(sar_menu_switch_struct)
- ));
-+ sw = (sar_menu_switch_struct *)m->object[n];
- if(sw == NULL)
- return(-3);
-
-@@ -1556,9 +1561,10 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)spin = SAR_MENU_SPIN(calloc(
-+ m->object[n] = SAR_MENU_SPIN(calloc(
- 1, sizeof(sar_menu_spin_struct)
- ));
-+ spin = (sar_menu_spin_struct *)m->object[n];
- if(spin == NULL)
- return(-3);
-
-@@ -2010,9 +2016,10 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)slider = SAR_MENU_SLIDER(calloc(
-+ m->object[n] = SAR_MENU_SLIDER(calloc(
- 1, sizeof(sar_menu_slider_struct)
- ));
-+ slider = (sar_menu_slider_struct *)m->object[n];
- if(slider == NULL)
- return(-3);
-
---- sar/menuobjview.c.old 2006-04-08 11:42:14.000000000 +0200
-+++ sar/menuobjview.c 2006-04-08 11:43:00.000000000 +0200
-@@ -151,9 +151,10 @@
- }
-
- /* Allocate structure */
-- m->object[n] = (void *)objview = SAR_MENU_OBJVIEW(calloc(
-+ m->object[n] = SAR_MENU_OBJVIEW(calloc(
- 1, sizeof(sar_menu_objview_struct)
- ));
-+ objview = (sar_menu_objview_struct *)m->object[n];
- if(objview == NULL)
- return(-1);
-
---- sar/sound.c.old 2006-04-08 12:04:32.000000000 +0200
-+++ sar/sound.c 2006-04-08 12:05:57.000000000 +0200
-@@ -230,7 +230,7 @@
- * YIDNULL.
- */
- #define SET_SND_PLAY_YID_NULL(p) \
-- { if((p) != NULL) (snd_play_struct *)(p)->data = (void *)YIDNULL; }
-+ { if((p) != NULL) (p)->data = (void *)YIDNULL; }
-
- if(recorder->con != NULL)
- {
diff --git a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc412.patch b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc412.patch
deleted file mode 100644
index 48384693f4ee..000000000000
--- a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc412.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- sar/string.cpp.old 2007-05-31 21:48:38.000000000 +0200
-+++ sar/string.cpp 2007-05-31 21:48:50.000000000 +0200
-@@ -3,7 +3,7 @@
- #include <stdlib.h>
- #include <ctype.h>
-
--extern char *tzname[2];
-+extern "C" char *tzname[2];
-
- #include <time.h>
- #include "../include/os.h"
---- sar/explosion.c.old 2007-05-31 22:02:05.000000000 +0200
-+++ sar/explosion.c 2007-05-31 22:02:15.000000000 +0200
-@@ -1,4 +1,5 @@
- #include <stdlib.h>
-+#include <string.h>
- #include "v3dtex.h"
- #include "obj.h"
- #include "objutils.h"
---- sar/fire.c.old 2007-05-31 22:03:08.000000000 +0200
-+++ sar/fire.c 2007-05-31 22:03:34.000000000 +0200
-@@ -1,4 +1,5 @@
- #include <stdlib.h>
-+#include <string.h>
- #include "v3dtex.h"
- #include "obj.h"
- #include "objutils.h"
---- sar/sardraw.c.old 2007-05-31 22:13:32.000000000 +0200
-+++ sar/sardraw.c 2007-05-31 22:13:57.000000000 +0200
-@@ -2,6 +2,7 @@
- #include <stdlib.h>
- #include <sys/types.h>
- #include <math.h>
-+#include <string.h>
-
- #ifdef __MSW__
- # include <windows.h>
---- sar/sardrawmessages.c.old 2007-05-31 22:14:43.000000000 +0200
-+++ sar/sardrawmessages.c 2007-05-31 22:15:02.000000000 +0200
-@@ -2,6 +2,7 @@
- #include <stdlib.h>
- #include <sys/types.h>
- #include <math.h>
-+#include <string.h>
-
- #ifdef __MSW__
- # include <windows.h>
---- sar/sardrawrunway.c.old 2007-05-31 22:17:02.000000000 +0200
-+++ sar/sardrawrunway.c 2007-05-31 22:17:35.000000000 +0200
-@@ -1,5 +1,6 @@
- #include <math.h>
- #include <sys/types.h>
-+#include <string.h>
-
- #ifdef __MSW__
- # include <windows.h>
diff --git a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc441.patch b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc441.patch
deleted file mode 100644
index 605c41501718..000000000000
--- a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc441.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- include/string.h.old 2009-09-04 09:18:54.000000000 +0200
-+++ include/string.h 2009-09-04 09:19:41.000000000 +0200
-@@ -43,7 +43,9 @@
- #ifdef __MSW__
- extern int strcasecmp(const char *s1, const char *s2);
- #endif
-+#ifndef _GNU_SOURCE
- extern char *strcasestr(const char *haystack, const char *needle);
-+#endif
- extern int strpfx(const char *s, const char *pfx);
- extern int strcasepfx(const char *s, const char *pfx);
-
diff --git a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-makejs.patch b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-makejs.patch
deleted file mode 100644
index 650aa0bedb99..000000000000
--- a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-makejs.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- Makefile.old 2009-09-04 10:13:22.000000000 +0200
-+++ Makefile 2009-09-04 10:16:43.000000000 +0200
-@@ -1,5 +1,5 @@
- ALL_SRC_DIRS=sar
- all install clean:
- @for subdir in $(ALL_SRC_DIRS); do \
-- make -s -C $$subdir -f Makefile $@; \
-+ $(MAKE) -s -C $$subdir -f Makefile $@; \
- done
diff --git a/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild b/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
deleted file mode 100644
index 945cc0b51ca4..000000000000
--- a/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild,v 1.6 2009/09/04 08:24:32 tupone Exp $
-
-EAPI=2
-inherit eutils games
-
-MY_PN=SearchAndRescue
-DESCRIPTION="Helicopter based air rescue flight simulator"
-HOMEPAGE="http://wolfpack.twu.net/SearchAndRescue/"
-SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${MY_PN}-${PV}.tar.bz2
- ftp://wolfpack.twu.net/users/wolfpack/${MY_PN}-data-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE="joystick"
-
-RDEPEND="x11-libs/libXxf86vm
- x11-libs/libXmu
- x11-libs/libXi
- x11-libs/libXpm
- virtual/opengl
- virtual/glu
- media-libs/yiff
- joystick? ( media-libs/libjsw )"
-DEPEND="${RDEPEND}
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto"
-
-S=${WORKDIR}/${MY_PN}-${PV}
-
-src_unpack() {
- unpack ${MY_PN}-${PV}.tar.bz2
- mkdir data ; cd data
- unpack ${MY_PN}-data-${PV}.tar.bz2
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc33.patch \
- "${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}"/${P}-gcc412.patch \
- "${FILESDIR}"/${P}-gcc441.patch \
- "${FILESDIR}"/${P}-makejs.patch
- bunzip2 sar/man/${MY_PN}.6.bz2
- sed -i \
- -e '/FeatureCFLAGS.*march/s:=.*:=:g' sar/platforms.ini \
- || die "sed failed"
- sed -i \
- -e "1i\#include <stdio.h>
- " sar/gctl.c \
- || die "sed failed"
-}
-
-src_configure() {
- local myconf
-
- use joystick \
- && myconf="--enable=libjsw" \
- || myconf="--disable=libjsw"
-
- # NOTE: not an autoconf script
- ./configure Linux \
- --prefix="${GAMES_PREFIX}" \
- ${myconf} \
- || die
-}
-
-src_install() {
- dogamesbin sar/${MY_PN} || die "dogamesbin failed"
- doman sar/man/${MY_PN}.6
- insinto /usr/share/icons/
- doins sar/icons/*.{ico,xpm}
- dodoc AUTHORS HACKING README
- newicon sar/icons/SearchAndRescue.xpm ${PN}.xpm
- cd "${WORKDIR}/data"
- dodir "${GAMES_DATADIR}/${MY_PN}"
- cp -r * "${D}/${GAMES_DATADIR}/${MY_PN}/" || die "cp failed"
- make_desktop_entry SearchAndRescue "SearchAndRescue" \
- /usr/share/pixmaps/${PN}.xpm
- prepgamesdirs
-}