summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-08-14 22:18:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-08-14 22:18:55 +0000
commita1db17759bcb4b9e7875feaf50cb4e8b5e79e402 (patch)
tree55dd113f9d94dd4f3e423152d56bf8a9146b5437 /games-simulation
parentStable on amd64 wrt bug #379019 (diff)
downloadgentoo-2-a1db17759bcb4b9e7875feaf50cb4e8b5e79e402.tar.gz
gentoo-2-a1db17759bcb4b9e7875feaf50cb4e8b5e79e402.tar.bz2
gentoo-2-a1db17759bcb4b9e7875feaf50cb4e8b5e79e402.zip
version bump
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/searchandrescue/ChangeLog8
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-1.4.0-build.patch68
-rw-r--r--games-simulation/searchandrescue/searchandrescue-1.4.0.ebuild74
3 files changed, 149 insertions, 1 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
index dd92369d160f..32690bbf4ed8 100644
--- a/games-simulation/searchandrescue/ChangeLog
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/searchandrescue
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.32 2011/05/26 21:23:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.33 2011/08/14 22:18:55 mr_bones_ Exp $
+
+*searchandrescue-1.4.0 (14 Aug 2011)
+
+ 14 Aug 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ +searchandrescue-1.4.0.ebuild, +files/searchandrescue-1.4.0-build.patch:
+ version bump
26 May 2011; Markus Meier <maekke@gentoo.org> searchandrescue-1.3.0.ebuild:
x86 stable, bug #366401
diff --git a/games-simulation/searchandrescue/files/searchandrescue-1.4.0-build.patch b/games-simulation/searchandrescue/files/searchandrescue-1.4.0-build.patch
new file mode 100644
index 000000000000..fe7236fbced0
--- /dev/null
+++ b/games-simulation/searchandrescue/files/searchandrescue-1.4.0-build.patch
@@ -0,0 +1,68 @@
+diff -ru searchandrescue_1.3.0.orig/sar/makefile_append.ini searchandrescue_1.3.0/sar/makefile_append.ini
+--- searchandrescue_1.3.0.orig/sar/makefile_append.ini 2004-08-05 18:34:15.000000000 -0400
++++ searchandrescue_1.3.0/sar/makefile_append.ini 2011-04-06 18:12:26.599574441 -0400
+@@ -3,7 +3,7 @@
+
+
+ # C++ flags:
+-CPPFLAGS = -D__cplusplus -Dc_plusplus
++CPPFLAGS += -D__cplusplus -Dc_plusplus
+
+
+ # Source files list:
+@@ -16,14 +16,12 @@
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+ @echo "Compiling module $*.o"
+- @$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+ @echo "Compiling module $*.o"
+- @$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC_DIRS) $(CPPFLAGS)
+
+ # Programs
+-LS = ls
+-LSFLAGS = -s -h -c --color=auto
+ RM = rm
+ RMFLAGS = -f
+
+@@ -32,9 +30,8 @@
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+ @echo -n "Linking modules..."
+- @$(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
++ $(CPP) $(OBJ_C) $(OBJ_CPP) $(LDFLAGS) -o $(BIN) $(LIBS) $(LIB_DIRS)
+ @echo -n " "
+- @-$(LS) $(LSFLAGS) $(BIN)
+
+ prebuild:
+ @echo "Building program \"$(BIN)\"..."
+@@ -54,5 +51,5 @@
+ clean:
+ @echo "Cleaning program \"$(BIN)\"..."
+ @echo "Deleting all intermediate files..."
+- @$(RM) $(RMFLAGS) a.out core *.o $(BIN)
++ $(RM) $(RMFLAGS) a.out core *.o $(BIN)
+ @echo "Clean done."
+diff -ru searchandrescue_1.3.0.orig/sar/platforms.ini searchandrescue_1.3.0/sar/platforms.ini
+--- searchandrescue_1.3.0.orig/sar/platforms.ini 2011-03-08 19:29:52.000000000 -0500
++++ searchandrescue_1.3.0/sar/platforms.ini 2011-04-06 18:12:11.277632730 -0400
+@@ -102,7 +102,7 @@
+ FeatureDepend = xf86vidmode-lib
+ DependType = Library
+ MustExist = Yes
+- DependPath = libXxf86vm.a
++ DependPath = libXxf86vm.so
+ DependGrepString = XF86VidModeQueryExtension
+ FeatureDepend = xf86vidmode-devel
+ DependType = Header
+@@ -223,7 +223,7 @@
+ FeatureDepend = xf86vidmode-lib
+ DependType = Library
+ MustExist = Yes
+- DependPath = libXxf86vm.a
++ DependPath = libXxf86vm.so
+ DependGrepString = XF86VidModeQueryExtension
+ FeatureDepend = xf86vidmode-devel
+ DependType = Header
diff --git a/games-simulation/searchandrescue/searchandrescue-1.4.0.ebuild b/games-simulation/searchandrescue/searchandrescue-1.4.0.ebuild
new file mode 100644
index 000000000000..fd56793517a3
--- /dev/null
+++ b/games-simulation/searchandrescue/searchandrescue-1.4.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-1.4.0.ebuild,v 1.1 2011/08/14 22:18:55 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils flag-o-matic toolchain-funcs games
+
+MY_DATA_PV=1.3.0
+MY_PN=SearchAndRescue
+DESCRIPTION="Helicopter based air rescue flight simulator"
+HOMEPAGE="http://searchandrescue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/searchandrescue/${MY_PN}-${PV}.tar.gz
+ mirror://sourceforge/searchandrescue/${MY_PN}-data-${MY_DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXxf86vm
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXmu
+ x11-libs/libXi
+ x11-libs/libXpm
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${MY_PN}-${PV}.tar.gz
+ mkdir data && cd data && \
+ unpack ${MY_PN}-data-${MY_DATA_PV}.tar.gz
+ bunzip2 "${S}"/sar/man/${MY_PN}.6.bz2 || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_configure() {
+ append-flags -DNEW_GRAPHICS -DHAVE_SDL_MIXER
+ export CPP="$(tc-getCXX)"
+ export CPPFLAGS="${CXXFLAGS}"
+ # NOTE: not an autoconf script
+ ./configure Linux \
+ --prefix="${GAMES_PREFIX}" \
+ --disable=Y2 \
+ || die
+ sed -i -e 's/@\$/$/' sar/Makefile || die
+}
+
+src_compile() {
+ emake -C sar || die
+}
+src_install() {
+ dogamesbin sar/${MY_PN} || die "dogamesbin failed"
+ doman sar/man/${MY_PN}.6
+ dodoc AUTHORS HACKING README
+ doicon sar/icons/SearchAndRescue.xpm
+ newicon sar/icons/SearchAndRescue.xpm ${PN}.xpm
+ cd "${WORKDIR}/data"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r * "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
+ make_desktop_entry SearchAndRescue "SearchAndRescue" \
+ /usr/share/pixmaps/${PN}.xpm
+ prepgamesdirs
+}