summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-18 13:26:44 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-18 13:26:44 +0000
commita6b6599ff7ca8e9c4c0812b599614af1d188b381 (patch)
tree5e572c5a585b921513a149beb4e2dd4af597b1ee /games-simulation
parentAdd missing flag-o-matic inherit. (diff)
downloadgentoo-2-a6b6599ff7ca8e9c4c0812b599614af1d188b381.tar.gz
gentoo-2-a6b6599ff7ca8e9c4c0812b599614af1d188b381.tar.bz2
gentoo-2-a6b6599ff7ca8e9c4c0812b599614af1d188b381.zip
Respect LDFLAGS. Bug #333649
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/cannonsmash/ChangeLog8
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild7
-rw-r--r--games-simulation/cannonsmash/files/cannonsmash-0.6.6-ldflags.patch11
3 files changed, 21 insertions, 5 deletions
diff --git a/games-simulation/cannonsmash/ChangeLog b/games-simulation/cannonsmash/ChangeLog
index 3d625293693b..90b9775de604 100644
--- a/games-simulation/cannonsmash/ChangeLog
+++ b/games-simulation/cannonsmash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/cannonsmash
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.19 2009/11/04 06:29:39 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.20 2010/10/18 13:26:44 tupone Exp $
+
+ 18 Oct 2010; Tupone Alfredo <tupone@gentoo.org> cannonsmash-0.6.6.ebuild,
+ +files/cannonsmash-0.6.6-ldflags.patch:
+ Respect LDFLAGS. Bug #333649 by flameeyes@gentoo.org
04 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
cannonsmash-0.6.6.ebuild:
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
index 5aae608b2495..dc20e1085f73 100644
--- a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.15 2009/11/04 06:29:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.16 2010/10/18 13:26:44 tupone Exp $
EAPI=2
inherit eutils games
@@ -37,7 +37,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-x-inc.patch \
"${FILESDIR}"/${P}-sizeof-cast.patch \
- "${FILESDIR}"/${P}-gcc41.patch
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
if use vorbis ; then
sed -i \
-e "s:${MY_OGG}:${GAMES_DATADIR}/csmash/${MY_OGG}:" ttinc.h \
diff --git a/games-simulation/cannonsmash/files/cannonsmash-0.6.6-ldflags.patch b/games-simulation/cannonsmash/files/cannonsmash-0.6.6-ldflags.patch
new file mode 100644
index 000000000000..ad6168a463ed
--- /dev/null
+++ b/games-simulation/cannonsmash/files/cannonsmash-0.6.6-ldflags.patch
@@ -0,0 +1,11 @@
+--- configure.old 2010-10-18 15:05:02.000000000 +0200
++++ configure 2010-10-18 15:05:31.000000000 +0200
+@@ -5520,7 +5520,7 @@
+ else
+ CFLAGS=""
+ fi
+-LDFLAGS="-L/usr/local/lib -L$x_libraries -L$libdir"
++LDFLAGS="${LDFLAGS} -L/usr/local/lib -L$x_libraries -L$libdir"
+ CXXFLAGS="$CFLAGS -Wall"
+
+