summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-12 21:47:41 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-12 21:47:41 +0000
commitb171eb2de4eb565c23c5711d99b4c3dfa99cc78b (patch)
treea2a8ed1cf753f2ca9d6bb0a2413e645a4b29a1a4 /games-simulation
parentAdd ~sparc-fbsd keyword. (diff)
downloadgentoo-2-b171eb2de4eb565c23c5711d99b4c3dfa99cc78b.tar.gz
gentoo-2-b171eb2de4eb565c23c5711d99b4c3dfa99cc78b.tar.bz2
gentoo-2-b171eb2de4eb565c23c5711d99b4c3dfa99cc78b.zip
Version bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/dangerdeep/ChangeLog8
-rw-r--r--games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild65
-rw-r--r--games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch37
-rw-r--r--games-simulation/dangerdeep/files/digest-dangerdeep-0.3.06
4 files changed, 115 insertions, 1 deletions
diff --git a/games-simulation/dangerdeep/ChangeLog b/games-simulation/dangerdeep/ChangeLog
index 04252b67ce7f..eb083998a4fa 100644
--- a/games-simulation/dangerdeep/ChangeLog
+++ b/games-simulation/dangerdeep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/dangerdeep
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.4 2007/03/07 08:19:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.5 2007/06/12 21:47:41 nyhm Exp $
+
+*dangerdeep-0.3.0 (12 Jun 2007)
+
+ 12 Jun 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/dangerdeep-0.3.0-build.patch, +dangerdeep-0.3.0.ebuild:
+ Version bump
07 Mar 2007; Michael Sterrett <mr_bones_@gentoo.org>
dangerdeep-0.2.0.ebuild:
diff --git a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
new file mode 100644
index 000000000000..03ad6f9c5bbe
--- /dev/null
+++ b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild,v 1.1 2007/06/12 21:47:41 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="a World War II German submarine simulation"
+HOMEPAGE="http://www.dangerdeep.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${PN}-data-${PV}.zip"
+
+LICENSE="GPL-2 CCPL-Attribution-NonCommercial-NoDerivs-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sse debug"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ sci-libs/fftw
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-net"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/scons"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+ sed -i \
+ -e "/console_log.txt/ s:fopen.*:stderr;:" \
+ src/system.cpp \
+ || die "sed failed"
+}
+
+src_compile() {
+ local sse=-1
+
+ if use sse ; then
+ use amd64 && sse=3 || sse=1
+ fi
+
+ scons \
+ usex86sse=${sse} \
+ datadir="${GAMES_DATADIR}"/${PN} \
+ $(use debug && echo debug=1) \
+ || die "scons failed"
+}
+
+src_install() {
+ dogamesbin build/linux/${PN} || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../data/* || die "doins failed"
+
+ newicon logo.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Danger from the Deep" ${PN}.xpm
+
+ dodoc ChangeLog CREDITS README
+ doman doc/man/${PN}.6
+
+ prepgamesdirs
+}
diff --git a/games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch
new file mode 100644
index 000000000000..1f3c4a47ce6d
--- /dev/null
+++ b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-build.patch
@@ -0,0 +1,37 @@
+--- SConstruct
++++ SConstruct
+@@ -119,6 +119,7 @@
+
+ else:
+ print "Compiling for Unix/Posix/Linux Environment"
++ SConsignFile()
+ env = Environment(ENV = os.environ)
+ env.Append(CPPPATH = ['/usr/include/SDL', '/usr/include/GL'])
+ libpath = ['/usr/X11R6/lib']
+@@ -126,13 +127,16 @@
+ sdllibs = ['SDL', 'SDL_image']
+ ccflags = '-Wall `sdl-config --cflags` `pkg-config --cflags x11`'
+ env.Append(LINKFLAGS = '`pkg-config --libs-only-L x11`')
++ if os.environ.has_key('CXXFLAGS'):
++ ccflags += os.environ['CXXFLAGS']
++ if os.environ.has_key('LDFLAGS'):
++ env.Append(LINKFLAGS = os.environ['LDFLAGS'])
+ if (debug >= 3):
+ ccflags += ' -g -pg -O3' # profiling
+ elif (debug == 2):
+ ccflags += ' -g -O0'
+ env.Append(CPPDEFINES = ['DEBUG'])
+ elif (debug == 1):
+- ccflags += ' -g -O1'
+ env.Append(CPPDEFINES = ['DEBUG'])
+ elif (debug == -1):
+ ccflags += ' -g -O3 -march=athlon-xp -mfpmath=sse -mmmx -msse -m3dnow'
+@@ -140,8 +144,6 @@
+ ccflags += ' -g -O3 -march=athlon-xp -mfpmath=sse -mmmx -msse -m3dnow -ftree-vectorize -ftree-vectorizer-verbose=2'
+ elif (debug == -3): # special g++4.0+ auto vectorization
+ ccflags += ' -g -O3 -march=athlon64 -mfpmath=sse -mmmx -msse -msse2 -m3dnow -ftree-vectorize -ftree-vectorizer-verbose=2'
+- else:
+- ccflags += ' -g -O2' # debug symbols will be stripped by the linker for a debian package
+ # choose specific architecture if requested
+ if archflag != '':
+ ccflags += ' -march=' + archflag
diff --git a/games-simulation/dangerdeep/files/digest-dangerdeep-0.3.0 b/games-simulation/dangerdeep/files/digest-dangerdeep-0.3.0
new file mode 100644
index 000000000000..6e442980ff50
--- /dev/null
+++ b/games-simulation/dangerdeep/files/digest-dangerdeep-0.3.0
@@ -0,0 +1,6 @@
+MD5 8a1d19326a9a0bd8bb91a652bfa51bd9 dangerdeep-0.3.0.tar.gz 1100972
+RMD160 f4959c78592700542514b31beb5e641cc43e10a8 dangerdeep-0.3.0.tar.gz 1100972
+SHA256 bdab6b9b1c2b5f8e618f5c346965ec1f48c9edc9bff1d4f5ff7c8d235464283f dangerdeep-0.3.0.tar.gz 1100972
+MD5 b9a2f2ff756cd7715a3b58de7504c1d0 dangerdeep-data-0.3.0.zip 61914764
+RMD160 b37fc081824089db6eda3491288b83f4bd0f3dd7 dangerdeep-data-0.3.0.zip 61914764
+SHA256 00412a4f8f571a9291df48fa40fbbe846680b4fcb1de2f168539b1606cb4fb81 dangerdeep-data-0.3.0.zip 61914764