summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-08-08 16:29:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-08-08 16:29:31 +0000
commitb5265f2263ddec3baf3ba02a6de32ed2a4a06d7d (patch)
tree7aa459c4e6cb0ac849b49b6cb7eeb51a7a41e838 /games-simulation
parentadd ~amd64-linux kw as well (diff)
downloadgentoo-2-b5265f2263ddec3baf3ba02a6de32ed2a4a06d7d.tar.gz
gentoo-2-b5265f2263ddec3baf3ba02a6de32ed2a4a06d7d.tar.bz2
gentoo-2-b5265f2263ddec3baf3ba02a6de32ed2a4a06d7d.zip
Add patch to avoid mangling CFLAGS (reported in bug #378141)
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/ChangeLog6
-rw-r--r--games-simulation/openttd/files/openttd-1.1.1-cflags.patch45
-rw-r--r--games-simulation/openttd/openttd-1.1.1.ebuild3
3 files changed, 52 insertions, 2 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index fa7bd3a3723c..5e032b6e1430 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.110 2011/08/08 16:23:42 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.111 2011/08/08 16:29:31 mr_bones_ Exp $
+
+ 08 Aug 2011; Michael Sterrett <mr_bones_@gentoo.org> openttd-1.1.1.ebuild,
+ +files/openttd-1.1.1-cflags.patch:
+ Add patch to avoid mangling CFLAGS (reported in bug #378141)
08 Aug 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> openttd-1.1.1.ebuild:
x86 stable wrt bug #378141
diff --git a/games-simulation/openttd/files/openttd-1.1.1-cflags.patch b/games-simulation/openttd/files/openttd-1.1.1-cflags.patch
new file mode 100644
index 000000000000..60a9056a6634
--- /dev/null
+++ b/games-simulation/openttd/files/openttd-1.1.1-cflags.patch
@@ -0,0 +1,45 @@
+--- config.lib.orig 2011-08-08 11:40:21.641085825 -0400
++++ config.lib 2011-08-08 11:44:19.655285851 -0400
+@@ -1357,14 +1357,12 @@
+ CFLAGS="-I/gg/os-include -noixemul -fstrict-aliasing -fexpensive-optimizations -mcpu=604 -fno-inline -mstring -mmultiple $CFLAGS"
+ LDFLAGS="$LDFLAGS -noixemul"
+ fi
+-
+- CFLAGS="-O2 -fomit-frame-pointer $CFLAGS"
+ else
+ OBJS_SUBDIR="debug"
+
+ # Each debug level reduces the optimization by a bit
+ if [ $enable_debug -ge 1 ]; then
+- CFLAGS="$CFLAGS -g -D_DEBUG"
++ CFLAGS="-D_DEBUG $CFLAGS"
+ if basename "$cc_host" | grep "gcc" &>/dev/null; then
+ # Define only when compiling with GCC, some
+ # GLIBC versions use GNU extensions in a way
+@@ -1375,14 +1373,6 @@
+ CFLAGS="$CFLAGS -G0"
+ fi
+ fi
+- if [ $enable_debug -ge 2 ]; then
+- CFLAGS="$CFLAGS -fno-inline"
+- fi
+- if [ $enable_debug -ge 3 ]; then
+- CFLAGS="$CFLAGS -O0"
+- else
+- CFLAGS="$CFLAGS -O2"
+- fi
+ fi
+
+ if [ "$os" = "OSX" ] && [ $cc_version -eq 40 ]; then
+@@ -1391,11 +1381,6 @@
+ CFLAGS="$CFLAGS -fno-expensive-optimizations"
+ fi
+
+- if [ "$enable_profiling" != "0" ]; then
+- CFLAGS="$CFLAGS -p"
+- LDFLAGS="$LDFLAGS -pg"
+- fi
+-
+ if [ "$with_threads" = "0" ]; then
+ CFLAGS="$CFLAGS -DNO_THREADS"
+ fi
diff --git a/games-simulation/openttd/openttd-1.1.1.ebuild b/games-simulation/openttd/openttd-1.1.1.ebuild
index 49fbd3896ed0..bf9352f09b29 100644
--- a/games-simulation/openttd/openttd-1.1.1.ebuild
+++ b/games-simulation/openttd/openttd-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-1.1.1.ebuild,v 1.2 2011/08/08 16:23:42 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-1.1.1.ebuild,v 1.3 2011/08/08 16:29:31 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -39,6 +39,7 @@ PDEPEND="
)
openmedia? ( games-misc/opengfx )
"
+PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
src_configure() {
# there is an allegro interface available as well as sdl, but