summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-06-19 12:54:43 +0000
committerChris Reffett <creffett@gentoo.org>2014-06-19 12:54:43 +0000
commitc6fffd67aeedc52abfeabcfe6bbeeecd278bce64 (patch)
tree8b482b7d75150d679bc8ba9df43cd81833ba904f /games-simulation
parentVersion bump; UDisks2 compability wrt #439650 (diff)
downloadgentoo-2-c6fffd67aeedc52abfeabcfe6bbeeecd278bce64.tar.gz
gentoo-2-c6fffd67aeedc52abfeabcfe6bbeeecd278bce64.tar.bz2
gentoo-2-c6fffd67aeedc52abfeabcfe6bbeeecd278bce64.zip
[QA] Respect LDFLAGS wrt bug 335095, credit to Christophe Lefebvre <chtof62@gmail.com> for the fix.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 28DB029C)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/micropolis/ChangeLog9
-rw-r--r--games-simulation/micropolis/micropolis-1.0.ebuild14
2 files changed, 15 insertions, 8 deletions
diff --git a/games-simulation/micropolis/ChangeLog b/games-simulation/micropolis/ChangeLog
index 607dbb32735a..bb72657c5aa0 100644
--- a/games-simulation/micropolis/ChangeLog
+++ b/games-simulation/micropolis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/micropolis
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/micropolis/ChangeLog,v 1.4 2010/03/09 12:23:23 abcd Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/micropolis/ChangeLog,v 1.5 2014/06/19 12:54:43 creffett Exp $
+
+ 19 Jun 2014; Chris Reffett <creffett@gentoo.org> micropolis-1.0.ebuild:
+ [QA] Respect LDFLAGS wrt bug 335095, credit to Christophe Lefebvre
+ <chtof62@gmail.com> for the fix.
09 Mar 2010; Jonathan Callen <abcd@gentoo.org> micropolis-1.0.ebuild:
QA: When not using an absolute path, you MUST NOT use a file extension
@@ -16,4 +20,3 @@
11 Jun 2008; Hanno Boeck <hanno@gentoo.org> +micropolis-1.0.ebuild:
Initial commit, based on the ebuilds from matsuu and Mike Gualtieri.
-
diff --git a/games-simulation/micropolis/micropolis-1.0.ebuild b/games-simulation/micropolis/micropolis-1.0.ebuild
index e072cabe0321..d82ae5d8267d 100644
--- a/games-simulation/micropolis/micropolis-1.0.ebuild
+++ b/games-simulation/micropolis/micropolis-1.0.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/micropolis/micropolis-1.0.ebuild,v 1.6 2010/03/09 12:23:23 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/micropolis/micropolis-1.0.ebuild,v 1.7 2014/06/19 12:54:43 creffett Exp $
+EAPI=5
inherit eutils games
@@ -26,16 +27,19 @@ S="${WORKDIR}/${PN}-activity/"
dir="${GAMES_DATADIR}/${PN}"
src_unpack() {
- unpack "${PN}-activity-source.tgz"
- cd "${S}"
+ unpack ${PN}-activity-source.tgz
+}
+src_prepare() {
epatch "${DISTDIR}"/${PN}_git.patch
sed -i -e "s:-O3:${CFLAGS}:" \
src/tclx/config.mk src/{sim,tcl,tk}/makefile || die
+ sed -i -e "s:XLDFLAGS=:&${LDFLAGS}:" \
+ src/tclx/config.mk || die
}
src_compile() {
- emake -C src || die
+ emake -C src LDFLAGS="${LDFLAGS}" || die
}
src_install() {