summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-02-02 08:08:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-02-02 08:08:40 +0000
commitcce51ab6460880101140bdcbe984df843410c38b (patch)
tree9f1dbd066a6885fbc6e2b3389d5943991fe807b0 /games-simulation
parentold (diff)
downloadgentoo-2-cce51ab6460880101140bdcbe984df843410c38b.tar.gz
gentoo-2-cce51ab6460880101140bdcbe984df843410c38b.tar.bz2
gentoo-2-cce51ab6460880101140bdcbe984df843410c38b.zip
old
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/simutrans/ChangeLog9
-rw-r--r--games-simulation/simutrans/files/simutrans-0.112.1-Makefile.patch102
-rw-r--r--games-simulation/simutrans/files/simutrans-0.112.1-overflow.patch11
-rw-r--r--games-simulation/simutrans/simutrans-0.112.1.ebuild60
4 files changed, 7 insertions, 175 deletions
diff --git a/games-simulation/simutrans/ChangeLog b/games-simulation/simutrans/ChangeLog
index 33dbe64c2da3..56d7af86cb0e 100644
--- a/games-simulation/simutrans/ChangeLog
+++ b/games-simulation/simutrans/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/simutrans
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/ChangeLog,v 1.32 2013/05/28 23:20:04 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/ChangeLog,v 1.33 2014/02/02 08:08:40 mr_bones_ Exp $
+
+ 02 Feb 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/simutrans-0.112.1-Makefile.patch,
+ -files/simutrans-0.112.1-overflow.patch, -simutrans-0.112.1.ebuild:
+ old
*simutrans-0.112.3 (28 May 2013)
diff --git a/games-simulation/simutrans/files/simutrans-0.112.1-Makefile.patch b/games-simulation/simutrans/files/simutrans-0.112.1-Makefile.patch
deleted file mode 100644
index 26a563a58454..000000000000
--- a/games-simulation/simutrans/files/simutrans-0.112.1-Makefile.patch
+++ /dev/null
@@ -1,102 +0,0 @@
---- Makefile.orig 2013-01-22 16:53:11.574351933 -0500
-+++ Makefile 2013-01-22 16:57:38.801999641 -0500
-@@ -90,7 +90,6 @@
- endif
- endif
- else
-- CFLAGS += -O
- endif
-
- ifdef DEBUG
-@@ -109,6 +108,7 @@
- endif
- else
- CFLAGS += -DNDEBUG
-+ CXXFLAGS += -DNDEBUG
- endif
-
- ifneq ($(PROFILE),)
-@@ -121,6 +121,7 @@
-
- ifneq ($(MULTI_THREAD),)
- CFLAGS += -DMULTI_THREAD=$(MULTI_THREAD)
-+ CXXFLAGS += -DMULTI_THREAD=$(MULTI_THREAD)
- ifneq ($(MULTI_THREAD),1)
- ifeq ($(OSTYPE),mingw)
- #use lpthreadGC2d for debug alternatively
-@@ -135,10 +136,12 @@
- REV = $(shell svnversion)
- ifneq ($(REV),)
- CFLAGS += -DREVISION="$(REV)"
-+ CXXFLAGS += -DREVISION="$(REV)"
- endif
- endif
-
- CFLAGS += -Wall -W -Wcast-qual -Wpointer-arith -Wcast-align $(FLAGS)
-+CXXFLAGS += -Wall -W -Wcast-qual -Wpointer-arith -Wcast-align $(FLAGS)
- CCFLAGS += -Wstrict-prototypes
-
-
-@@ -450,6 +453,7 @@
- ifeq ($(BACKEND),sdl)
- SOURCES += simsys_s.cc
- CFLAGS += -DUSE_16BIT_DIB
-+ CXXFLAGS += -DUSE_16BIT_DIB
- ifeq ($(OSTYPE),mac)
- # Core Audio (Quicktime) base sound system routines
- SOURCES += sound/core-audio_sound.mm
-@@ -482,6 +486,7 @@
- endif
- endif
- CFLAGS += $(SDL_CFLAGS)
-+ CXXFLAGS += $(SDL_CFLAGS)
- LIBS += $(SDL_LDFLAGS)
- endif
-
-@@ -491,6 +496,7 @@
- SOURCES += sound/sdl_mixer_sound.cc
- SOURCES += music/sdl_midi.cc
- CFLAGS += -DUSE_16BIT_DIB
-+ CXXFLAGS += -DUSE_16BIT_DIB
- ifeq ($(SDL_CONFIG),)
- SDL_CFLAGS := -I$(MINGDIR)/include/SDL -Dmain=SDL_main
- SDL_LDFLAGS := -lmingw32 -lSDLmain -lSDL
-@@ -505,12 +511,14 @@
- endif
- endif
- CFLAGS += $(SDL_CFLAGS)
-+ CXXFLAGS += $(SDL_CFLAGS)
- LIBS += $(SDL_LDFLAGS) -lSDL_mixer
- endif
-
- ifeq ($(BACKEND),opengl)
- SOURCES += simsys_opengl.cc
- CFLAGS += -DUSE_16BIT_DIB
-+ CXXFLAGS += -DUSE_16BIT_DIB
- ifeq ($(OSTYPE),mac)
- # Core Audio (Quicktime) base sound system routines
- SOURCES += sound/core-audio_sound.mm
-@@ -538,6 +546,7 @@
- endif
- endif
- CFLAGS += $(SDL_CFLAGS)
-+ CXXFLAGS += $(SDL_CFLAGS)
- LIBS += $(SDL_LDFLAGS)
- ifeq ($(OSTYPE),mingw)
- LIBS += -lopengl32
-@@ -553,6 +562,7 @@
- endif
-
- CFLAGS += -DCOLOUR_DEPTH=$(COLOUR_DEPTH)
-+CXXFLAGS += -DCOLOUR_DEPTH=$(COLOUR_DEPTH)
-
- ifneq ($(findstring $(OSTYPE), cygwin mingw),)
- SOURCES += simres.rc
-@@ -560,7 +570,6 @@
- endif
-
- CCFLAGS += $(CFLAGS)
--CXXFLAGS += $(CFLAGS)
-
- BUILDDIR ?= build/$(CFG)
- PROGDIR ?= $(BUILDDIR)
diff --git a/games-simulation/simutrans/files/simutrans-0.112.1-overflow.patch b/games-simulation/simutrans/files/simutrans-0.112.1-overflow.patch
deleted file mode 100644
index 6597ca071f92..000000000000
--- a/games-simulation/simutrans/files/simutrans-0.112.1-overflow.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- besch/reader/obj_reader.cc.orig 2013-01-22 17:22:02.509818038 -0500
-+++ besch/reader/obj_reader.cc 2013-01-22 17:22:58.650846577 -0500
-@@ -308,7 +308,7 @@
- void obj_reader_t::skip_nodes(FILE *fp,uint32 version)
- {
- obj_node_info_t node;
-- char load_dummy[OBJ_NODE_INFO_SIZE], *p;
-+ char load_dummy[OBJ_NODE_INFO_SIZE + 4], *p; // extra 4 for LARGE_RECORD_SIZE
-
- p = load_dummy;
- if( version==COMPILER_VERSION_CODE_11 ) {
diff --git a/games-simulation/simutrans/simutrans-0.112.1.ebuild b/games-simulation/simutrans/simutrans-0.112.1.ebuild
deleted file mode 100644
index f2998dbf3060..000000000000
--- a/games-simulation/simutrans/simutrans-0.112.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/simutrans-0.112.1.ebuild,v 1.1 2013/01/22 22:33:42 mr_bones_ Exp $
-
-EAPI=5
-inherit flag-o-matic eutils games
-
-MY_PV=${PV/0./}
-MY_PV=${MY_PV//./-}
-MY_FOOD_PV=${MY_PV/%-2/-1}
-DESCRIPTION="A free Transport Tycoon clone"
-HOMEPAGE="http://www.simutrans.com/"
-SRC_URI="mirror://sourceforge/simutrans/simutrans-src-${MY_PV}.zip
- mirror://sourceforge/simutrans/simupak64-${MY_PV}.zip
- mirror://sourceforge/simutrans/simupak64-addon-food-${MY_FOOD_PV}.zip"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-
-RDEPEND="media-libs/libsdl[audio,video]
- sys-libs/zlib
- app-arch/bzip2
- media-libs/libpng:0
- media-libs/sdl-mixer"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}
-
-src_prepare() {
- strip-flags # bug #293927
- echo "BACKEND=mixer_sdl
-COLOUR_DEPTH=16
-OSTYPE=linux
-VERBOSE=1" > config.default || die
-
- if use !x86 ; then
- echo "FLAGS+= -DUSE_C" >> config.default
- fi
- # make it look in the install location for the data
- sed -i \
- -e "s:argv\[0\]:\"${GAMES_DATADIR}/${PN}/\":" \
- simmain.cc || die
-
- epatch \
- "${FILESDIR}"/${P}-Makefile.patch \
- "${FILESDIR}"/${P}-overflow.patch
-}
-
-src_install() {
- newgamesbin build/default/sim ${PN}
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r simutrans/*
- dodoc documentation/* todo.txt
- doicon simutrans.ico
- make_desktop_entry simutrans Simutrans /usr/share/pixmaps/simutrans.ico
- prepgamesdirs
-}