summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-01 06:04:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-01 06:04:41 +0000
commit495cc61ce4e8a17a40f08fffe082a2e50b381c17 (patch)
treead36000fa38acb48d19252ac9ada1596552dcf67 /games-sports/racer-bin
parentAdd a block for app-arch/upx-ucl. (diff)
downloadgentoo-2-495cc61ce4e8a17a40f08fffe082a2e50b381c17.tar.gz
gentoo-2-495cc61ce4e8a17a40f08fffe082a2e50b381c17.tar.bz2
gentoo-2-495cc61ce4e8a17a40f08fffe082a2e50b381c17.zip
more error checking/messages; local variables; fix permissions for bug 31694
Diffstat (limited to 'games-sports/racer-bin')
-rw-r--r--games-sports/racer-bin/ChangeLog6
-rw-r--r--games-sports/racer-bin/Manifest4
-rw-r--r--games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild34
3 files changed, 31 insertions, 13 deletions
diff --git a/games-sports/racer-bin/ChangeLog b/games-sports/racer-bin/ChangeLog
index 23cd8e3c93c3..90968d437762 100644
--- a/games-sports/racer-bin/ChangeLog
+++ b/games-sports/racer-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/racer-bin
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/racer-bin/ChangeLog,v 1.2 2003/09/12 15:39:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/racer-bin/ChangeLog,v 1.3 2003/11/01 06:04:39 mr_bones_ Exp $
+
+ 31 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org>
+ racer-bin-0.5.0-r1.ebuild:
+ more error checking/messages; local variables; fix permissions for bug 31694
12 Jul 2003; Michael Sterrett <msterret@gentoo.org>
racer-bin-0.5.0-r1.ebuild:
diff --git a/games-sports/racer-bin/Manifest b/games-sports/racer-bin/Manifest
index df6ec69c066d..a77549d91470 100644
--- a/games-sports/racer-bin/Manifest
+++ b/games-sports/racer-bin/Manifest
@@ -1,4 +1,4 @@
+MD5 55b36b113559a202606095fd3a1f33d4 ChangeLog 1011
+MD5 614180d1b0f0a2f6c6ab7d8bc3ebdda2 racer-bin-0.5.0-r1.ebuild 1680
MD5 ec793a18da62c3b624926d6f67647d50 files/digest-racer-bin-0.5.0-r1 248
MD5 eb49db94f23e77efd23b9f5bb0aea6ac files/racer-skel 108
-MD5 2c970151e13326bf06364e8bb32d8998 racer-bin-0.5.0-r1.ebuild 1317
-MD5 a26f0402fda9dc5cf508a14417ff4e00 ChangeLog 844
diff --git a/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild b/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild
index 5433ee25c42d..1ab613d2c641 100644
--- a/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild
+++ b/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild,v 1.1 2003/09/11 12:26:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild,v 1.2 2003/11/01 06:04:39 mr_bones_ Exp $
inherit games
@@ -26,20 +26,34 @@ src_compile() {
src_install( ) {
local dir=${GAMES_PREFIX_OPT}/${PN}
- dodir ${dir}
-
- dodoc *.txt ; rm *.txt
- cp -R ${S}/* ${D}/${dir}/
-
- sed -e "s:GENTOO_DIR:${dir}:" ${FILESDIR}/racer-skel > racer-skel
- for bin in carlab gplex modeler pacejka racer tracked ; do
- newgamesbin racer-skel ${bin}
- dosed "s:GENTOO_BIN:${bin}:" ${GAMES_BINDIR}/${bin}
+ local f
+ dodir ${dir} || die "dodir failed"
+
+ dodoc *.txt || die "dodoc failed"
+ rm -f *.txt
+ cp -R ${S}/* ${D}/${dir}/ || die "cp failed"
+
+ sed -e "s:GENTOO_DIR:${dir}:" ${FILESDIR}/racer-skel > racer-skel || \
+ die "sed failed"
+
+ for f in carlab gplex modeler pacejka racer tracked
+ do
+ newgamesbin racer-skel ${f} || \
+ die "newgamesbin ${f} failed"
+ dosed "s:GENTOO_BIN:${f}:" ${GAMES_BINDIR}/${f} || \
+ die "dosed ${f} failed"
done
local libfmod=`find /usr/lib/ -name 'libfmod-*so' -maxdepth 1 -type f -printf '%f'`
dosym /usr/lib/${libfmod} ${dir}/bin/libfmod-3.61.so
dosym /usr/lib/${libfmod} ${dir}/bin/libfmod-3.5.so
+ # Fix up some permissions for bug 31694
+ for f in racer.ini data/drivers/default/driver.ini data/tracks/carlswood_nt/bestlaps.ini
+ do
+ fperms 664 ${dir}/${f} || \
+ die "fperms ${f} failed"
+ done
+
prepgamesdirs
}