summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-08 22:06:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-08 22:06:45 +0000
commit0c918088a62ce9393091faffcffed12be2e5f298 (patch)
treeb315186c81f216d465de8624241911f646d22ace /games-sports
parentEAPI=2; add use-based dep for media-libs/sdl-mixer (diff)
downloadgentoo-2-0c918088a62ce9393091faffcffed12be2e5f298.tar.gz
gentoo-2-0c918088a62ce9393091faffcffed12be2e5f298.tar.bz2
gentoo-2-0c918088a62ce9393091faffcffed12be2e5f298.zip
old
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/xmoto/Manifest1
-rw-r--r--games-sports/xmoto/xmoto-0.5.0.ebuild114
2 files changed, 0 insertions, 115 deletions
diff --git a/games-sports/xmoto/Manifest b/games-sports/xmoto/Manifest
index 27dee98391d3..1f04db6966ad 100644
--- a/games-sports/xmoto/Manifest
+++ b/games-sports/xmoto/Manifest
@@ -4,6 +4,5 @@ DIST xmoto-0.4.2-src.tar.gz 21518240 RMD160 b87ac63714772b54d8b5fd45a8b7bdacf557
DIST xmoto-0.5.0-src.tar.gz 21913971 RMD160 a9e2b9f077b17e17bb2ffab04542ee0f737c3e0f SHA1 9d89c0c7fa7da23378577c8ed572cc381267dfae SHA256 705a70c3cda8300179e049c5b1fb8d5d241ede0a3bc1961d5e93682babccc93f
EBUILD xmoto-0.4.2.ebuild 2913 RMD160 cc977532c504ad002c3514fa87505c141c13a275 SHA1 19cec89c8b589529b25bf7c0a11ff4acbc9ce13e SHA256 f911a4f6c0f6909380ad23a69415ef5bf7276422c3f22177b3dc9a7594212b95
EBUILD xmoto-0.5.0-r1.ebuild 2716 RMD160 20e66a8a36fb3be58514c8045d63dcba337ef939 SHA1 5fbef72d5d328ed7aede612068b8331381bc75dd SHA256 6f78100acbfc8a6aa9c89aa764982d526dfdaa763e4039c051a4f51a6969283c
-EBUILD xmoto-0.5.0.ebuild 3015 RMD160 725003e279f03f94f6cdebd6bd870fd569439a9a SHA1 b1a3b66e993b3c323c34a6f24a01defac4997823 SHA256 19b8268fc6e566d95007f554059864371efe9f01bbdab64726354f3de4e48a0a
MISC ChangeLog 4196 RMD160 0f245ad7f4021107f2f811fb7511575c1835b1b8 SHA1 9ca58cf55e7da1117432dbc86bf212ffea0a0d56 SHA256 5c9ae4e8c8a623c7b6beba195abd7cbc10f7e534e0ed2b846ceaad49e5032945
MISC metadata.xml 339 RMD160 b003e2b8bb90a2ada8c8ba870aab3e6e73f7de71 SHA1 aa5548496eb75effe84bb3849e0f021cdbeac476 SHA256 019501d6ea5973371f60c6407a8fe9e0cd13daef856182fd2974c5145dd2dfed
diff --git a/games-sports/xmoto/xmoto-0.5.0.ebuild b/games-sports/xmoto/xmoto-0.5.0.ebuild
deleted file mode 100644
index e0c135507150..000000000000
--- a/games-sports/xmoto/xmoto-0.5.0.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.5.0.ebuild,v 1.2 2008/12/05 15:15:06 mr_bones_ Exp $
-
-inherit eutils games
-
-LVL="inksmoto-0.4.1" #they unfortunately don't release both at the same time
-DESCRIPTION="A challenging 2D motocross platform game"
-HOMEPAGE="http://xmoto.tuxfamily.org"
-SRC_URI="http://download.tuxfamily.org/${PN}/${PN}/${PV}/${P}-src.tar.gz
- editor? ( http://download.tuxfamily.org/xmoto/svg2lvl/${PV}/${LVL}.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="X editor nls" # sdl"
-
-RDEPEND="dev-games/ode
- dev-lang/lua
- media-libs/jpeg
- media-libs/libpng
- media-libs/libsdl
- media-libs/sdl-mixer
- media-libs/sdl-ttf
- media-libs/sdl-net
- net-misc/curl
- virtual/opengl
- virtual/glu
- nls? ( virtual/libintl )
- editor? ( >=media-gfx/inkscape-0.45 )"
-DEPEND="${RDEPEND}
- >=dev-db/sqlite-3
- !=dev-db/sqlite-3.6.2
- nls? ( sys-devel/gettext )"
-pkg_setup() {
- if has_version ">=dev-lang/lua-5.1.3-r1" && ! built_with_use dev-lang/lua deprecated ; then
- eerror "Re-emerge dev-lang/lua with 'deprecated' USE flag"
- eerror "Check your USE flags, re-emerge the dependencies and then"
- eerror "emerge this package."
- die
- fi
- games_pkg_setup
-}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use editor && rm -f "${WORKDIR}"/${LVL}/{bezmisc,inkex}.py
-}
-
-src_compile() {
- #if use sdl ; then
- # ewarn "SDL is known to be broken, if you experience any troubles please"
- # ewarn "try again without this useflag"
- # RENDERER="--with-renderer-sdlGfx=1 --with-renderer-openGl=0"
- #else
- RENDERER="--with-renderer-sdlGfx=0 --with-renderer-openGl=1"
- #fi
- if ! use nls ; then
- NLS="--disable-nls"
- else
- NLS="--with-gettext"
- fi
- # using some nice dejavu font, better than nothing
- egamesconf \
- --disable-dependency-tracking \
- --with-enable-zoom=1 \
- --enable-threads=posix \
- --with-gnu-ld \
- $(use_with X) \
- --with-localesdir=/usr/share/locale \
- ${RENDERER} \
- ${NLS} \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- ## if it is not working nice way, we'll do it ugly way
- if use nls ; then
- dodir /usr/share/locale
-
- cd "${S}"/po
- for i in `ls -c1 |grep "\.gmo$"` ; do
- BASE=$(echo ${i} |sed 's/\.gmo$//g')
- msgfmt -v -o ${BASE}.mo ${BASE}.po
-
- insinto /usr/share/locale/${BASE}/LC_MESSAGES
- newins ${BASE}.gmo xmoto.mo
- done;
- fi
- cd "${S}"
- dodoc README TODO NEWS ChangeLog
-
- doicon extra/xmoto.xpm
- domenu extra/xmoto.desktop
-
- prepgamesdirs
-
- if use editor; then
- insinto /usr/share/inkscape/extensions
- doins "${WORKDIR}"/${LVL}/*.{inx,py,xml} || die "doins failed"
- fi
-}
-
-pkg_postinst() {
- games_pkg_postinst
- if use editor; then
- elog "If you want to know how to create Xmoto levels"
- elog "have a look at this Tutorial:"
- elog "http://wiki.xmoto.tuxfamily.org/index.php?title=Inkscape-0.4.0"
- elog "You can share your levels on the Xmoto homepage."
- fi
-}