summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-01-26 23:15:10 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-01-26 23:15:10 +0000
commit327efd7c27b67b88780420a612b8bf5d1f0ff10f (patch)
tree7e9847acc1f90954fa65d1844559ad836610c435 /games-sports
parentversion bump (diff)
downloadgentoo-2-327efd7c27b67b88780420a612b8bf5d1f0ff10f.tar.gz
gentoo-2-327efd7c27b67b88780420a612b8bf5d1f0ff10f.tar.bz2
gentoo-2-327efd7c27b67b88780420a612b8bf5d1f0ff10f.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/dustrac/ChangeLog11
-rw-r--r--games-sports/dustrac/dustrac-1.6.3.ebuild68
-rw-r--r--games-sports/dustrac/files/dustrac-1.6.3-cmake.patch79
-rw-r--r--games-sports/dustrac/files/dustrac-1.6.3-desktopfile.patch40
4 files changed, 195 insertions, 3 deletions
diff --git a/games-sports/dustrac/ChangeLog b/games-sports/dustrac/ChangeLog
index d27b90f0ac38..5b2a274dbef5 100644
--- a/games-sports/dustrac/ChangeLog
+++ b/games-sports/dustrac/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-sports/dustrac
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/dustrac/ChangeLog,v 1.1 2013/12/26 13:53:52 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/dustrac/ChangeLog,v 1.2 2014/01/26 23:15:10 hasufell Exp $
+
+*dustrac-1.6.3 (26 Jan 2014)
+
+ 26 Jan 2014; Julian Ospald <hasufell@gentoo.org> +dustrac-1.6.3.ebuild,
+ +files/dustrac-1.6.3-cmake.patch, +files/dustrac-1.6.3-desktopfile.patch:
+ version bump
*dustrac-1.6.2 (26 Dec 2013)
@@ -8,4 +14,3 @@
+files/dustrac-1.6.2-cmake.patch, +files/dustrac-1.6.2-desktopfile.patch,
+metadata.xml:
initial import
-
diff --git a/games-sports/dustrac/dustrac-1.6.3.ebuild b/games-sports/dustrac/dustrac-1.6.3.ebuild
new file mode 100644
index 000000000000..6afadcaedaa0
--- /dev/null
+++ b/games-sports/dustrac/dustrac-1.6.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/dustrac/dustrac-1.6.3.ebuild,v 1.1 2014/01/26 23:15:10 hasufell Exp $
+
+EAPI=5
+
+inherit eutils gnome2-utils cmake-utils games
+
+DESCRIPTION="Tile-based, cross-platform 2D racing game"
+HOMEPAGE="http://dustrac.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dustrac/${P}.tar.gz"
+
+LICENSE="GPL-3 CC-BY-NC-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/mesa[gles2]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cmake.patch \
+ "${FILESDIR}"/${P}-desktopfile.patch
+}
+
+src_configure() {
+ # build failure without gles 2.0
+ local mycmakeargs=(
+ -DGLES=ON
+ -DGL30=ON
+ -DReleaseBuild=ON
+ -DDATA_PATH="${GAMES_DATADIR}/${PN}"
+ -DBIN_PATH="${GAMES_BINDIR}"
+ -DDOC_PATH=/usr/share/doc/${PF}
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-sports/dustrac/files/dustrac-1.6.3-cmake.patch b/games-sports/dustrac/files/dustrac-1.6.3-cmake.patch
new file mode 100644
index 000000000000..335fd46accf6
--- /dev/null
+++ b/games-sports/dustrac/files/dustrac-1.6.3-cmake.patch
@@ -0,0 +1,79 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Dec 25 22:55:09 UTC 2013
+Subject: respect flags, fix installation
+
+--- dustrac-1.6.2/CMakeLists.txt
++++ dustrac-1.6.2/CMakeLists.txt
+@@ -43,7 +43,7 @@
+ endif()
+
+ set(CMAKE_VERBOSE_MAKEFILE OFF)
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -W -Wall -O3 -pedantic")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -W -Wall")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fomit-frame-pointer -finline-functions -ffast-math")
+
+ set(GAME_BINARY_NAME "dustrac-game")
+--- dustrac-1.6.2/src/game/CMakeLists.txt
++++ dustrac-1.6.2/src/game/CMakeLists.txt
+@@ -128,16 +128,11 @@
+
+ # Copy desktop file
+ if(ReleaseBuild AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+- set(DesktopFileSourcePath)
+ if(USC)
+- set(DesktopFileSourcePath ${CMAKE_SOURCE_DIR}/src/dustrac-game.desktop.opt.in)
++ configure_file(${CMAKE_SOURCE_DIR}/src/dustrac-game.desktop.opt.in ${CMAKE_BINARY_DIR}/src/dustrac-game.desktop)
+ else()
+- set(DesktopFileSourcePath ${CMAKE_SOURCE_DIR}/src/dustrac-game.desktop.in)
++ configure_file(${CMAKE_SOURCE_DIR}/src/dustrac-game.desktop.in ${CMAKE_BINARY_DIR}/src/dustrac-game.desktop)
+ endif()
+- add_custom_target(desktop-file-game ALL
+- COMMAND cmake -E copy ${DesktopFileSourcePath}
+- ${CMAKE_BINARY_DIR}/dustrac-game.desktop
+- DEPENDS ${GAME_BINARY_NAME})
+ endif()
+
+ # Resource compilation for MinGW
+--- dustrac-1.6.2/src/editor/CMakeLists.txt
++++ dustrac-1.6.2/src/editor/CMakeLists.txt
+@@ -76,16 +76,11 @@
+
+ # Copy desktop file
+ if(ReleaseBuild AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+- set(DesktopFileSourcePath)
+ if(USC)
+- set(DesktopFileSourcePath ${CMAKE_SOURCE_DIR}/src/dustrac-editor.desktop.opt.in)
++ configure_file(${CMAKE_SOURCE_DIR}/src/dustrac-editor.desktop.opt.in ${CMAKE_BINARY_DIR}/src/dustrac-editor.desktop)
+ else()
+- set(DesktopFileSourcePath ${CMAKE_SOURCE_DIR}/src/dustrac-editor.desktop.in)
++ configure_file(${CMAKE_SOURCE_DIR}/src/dustrac-editor.desktop.in ${CMAKE_BINARY_DIR}/src/dustrac-editor.desktop)
+ endif()
+- add_custom_target(desktop-file-editor ALL
+- COMMAND cmake -E copy ${DesktopFileSourcePath}
+- ${CMAKE_BINARY_DIR}/dustrac-editor.desktop
+- DEPENDS ${EDITOR_BINARY_NAME})
+ endif()
+
+ # Add the executable
+--- dustrac-1.6.2/InstallLinux.cmake
++++ dustrac-1.6.2/InstallLinux.cmake
+@@ -58,7 +58,7 @@
+ install(FILES data/fonts.conf DESTINATION ${DATA_PATH})
+ install(FILES data/meshes.conf DESTINATION ${DATA_PATH})
+ install(FILES data/textures.conf DESTINATION ${DATA_PATH})
+- install(FILES AUTHORS CHANGELOG COPYING README DESTINATION ${DOC_PATH})
++ install(FILES AUTHORS CHANGELOG README DESTINATION ${DOC_PATH})
+ install(DIRECTORY data/images DESTINATION ${DATA_PATH} FILES_MATCHING PATTERN "*.jpg")
+ install(DIRECTORY data/images DESTINATION ${DATA_PATH} FILES_MATCHING PATTERN "*.png")
+ install(DIRECTORY data/levels DESTINATION ${DATA_PATH} FILES_MATCHING PATTERN "*.trk")
+@@ -69,8 +69,8 @@
+
+ if(ReleaseBuild)
+ # Install .desktop files
+- install(FILES dustrac-game.desktop DESTINATION share/applications)
+- install(FILES dustrac-editor.desktop DESTINATION share/applications)
++ install(FILES ${CMAKE_BINARY_DIR}/src/dustrac-game.desktop DESTINATION share/applications)
++ install(FILES ${CMAKE_BINARY_DIR}/src/dustrac-editor.desktop DESTINATION share/applications)
+
+ # Install icons
+ install(FILES data/icons/dustrac-game.png DESTINATION share/pixmaps)
diff --git a/games-sports/dustrac/files/dustrac-1.6.3-desktopfile.patch b/games-sports/dustrac/files/dustrac-1.6.3-desktopfile.patch
new file mode 100644
index 000000000000..a09edc194ecd
--- /dev/null
+++ b/games-sports/dustrac/files/dustrac-1.6.3-desktopfile.patch
@@ -0,0 +1,40 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Dec 25 23:21:50 UTC 2013
+Subject: fix desktop files
+
+--- dustrac-1.6.2/src/dustrac-editor.desktop.in
++++ dustrac-1.6.2/src/dustrac-editor.desktop.in
+@@ -4,5 +4,5 @@
+ Exec=dustrac-editor
+ Icon=dustrac-editor
+ Type=Application
+-Categories=Game
++Categories=Game;
+ StartupNotify=true
+--- dustrac-1.6.2/src/dustrac-editor.desktop.opt.in
++++ dustrac-1.6.2/src/dustrac-editor.desktop.opt.in
+@@ -4,5 +4,5 @@
+ Exec=/opt/dustrac/dustrac-editor
+ Icon=dustrac-editor
+ Type=Application
+-Categories=Game
++Categories=Game;
+ StartupNotify=true
+--- dustrac-1.6.2/src/dustrac-game.desktop.in
++++ dustrac-1.6.2/src/dustrac-game.desktop.in
+@@ -4,5 +4,5 @@
+ Exec=dustrac-game
+ Icon=dustrac-game
+ Type=Application
+-Categories=Game
++Categories=Game;
+ StartupNotify=true
+--- dustrac-1.6.2/src/dustrac-game.desktop.opt.in
++++ dustrac-1.6.2/src/dustrac-game.desktop.opt.in
+@@ -4,5 +4,5 @@
+ Exec=/opt/dustrac/dustrac-game
+ Icon=dustrac-game
+ Type=Application
+-Categories=Game
++Categories=Game;
+ StartupNotify=true