summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-12-14 22:57:22 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-12-14 22:57:22 +0000
commit77bc75e5a6a764ecc846190e9ae9b1acbefa0eeb (patch)
tree2de4f3595ac18292b883d0c0b8eb63b6912d824f /games-sports
parentFix ar detection per bug#438160 by Sean McGovern (diff)
downloadgentoo-2-77bc75e5a6a764ecc846190e9ae9b1acbefa0eeb.tar.gz
gentoo-2-77bc75e5a6a764ecc846190e9ae9b1acbefa0eeb.tar.bz2
gentoo-2-77bc75e5a6a764ecc846190e9ae9b1acbefa0eeb.zip
version bump wrt #415909
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/torcs/ChangeLog9
-rw-r--r--games-sports/torcs/files/torcs-1.3.4-as-needed.patch106
-rw-r--r--games-sports/torcs/files/torcs-1.3.4-flags.patch14
-rw-r--r--games-sports/torcs/files/torcs-1.3.4-no-automake.patch21
-rw-r--r--games-sports/torcs/torcs-1.3.4.ebuild62
5 files changed, 211 insertions, 1 deletions
diff --git a/games-sports/torcs/ChangeLog b/games-sports/torcs/ChangeLog
index acbbd7633584..5e08a8868320 100644
--- a/games-sports/torcs/ChangeLog
+++ b/games-sports/torcs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-sports/torcs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.35 2012/03/22 15:05:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.36 2012/12/14 22:57:22 hasufell Exp $
+
+*torcs-1.3.4 (14 Dec 2012)
+
+ 14 Dec 2012; Julian Ospald <hasufell@gentoo.org> +torcs-1.3.4.ebuild,
+ +files/torcs-1.3.4-as-needed.patch, +files/torcs-1.3.4-flags.patch,
+ +files/torcs-1.3.4-no-automake.patch:
+ version bump wrt #415909
22 Mar 2012; Mike Frysinger <vapier@gentoo.org> torcs-1.3.1.ebuild,
files/torcs-1.3.1-libpng15.patch, +files/torcs-1.3.1-no-automake.patch:
diff --git a/games-sports/torcs/files/torcs-1.3.4-as-needed.patch b/games-sports/torcs/files/torcs-1.3.4-as-needed.patch
new file mode 100644
index 000000000000..d94eb8e061c0
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.4-as-needed.patch
@@ -0,0 +1,106 @@
+--- torcs-1.3.4/configure.in
++++ torcs-1.3.4/configure.in
+@@ -123,11 +123,10 @@
+ AC_CHECK_LIB(Xxf86vm, XF86VidModeSetViewPort,,AC_MSG_ERROR([Can't find libXxf86vm. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xrender, XRenderSetSubpixelOrder,,AC_MSG_ERROR([Can't find libXrender. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xrandr, XRRQueryVersion,,AC_MSG_ERROR([Can't find libXrandr. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+-AC_CHECK_LIB(openal, alEnable, LDFLAGS="$LDFLAGS -lopenal", AC_MSG_ERROR([Can't find AL/al.h. OpenAL can be found on http://www.openal.org/]))
++AC_CHECK_LIB(openal, alEnable, LIBS="$LIBS -lopenal", AC_MSG_ERROR([Can't find AL/al.h. OpenAL can be found on http://www.openal.org/]))
+ AC_CHECK_LIB(alut, alutLoadWAVFile,
+- LDFLAGS="$LDFLAGS -lalut",
+- LDFLAGS="$LDFLAGS")
+-AC_CHECK_LIB(vorbisfile, ov_fopen, LDFLAGS="$LDFLAGS -lvorbisfile", AC_MSG_ERROR([Can't find libvorbis.]))
++ LIBS="$LIBS -lalut", )
++AC_CHECK_LIB(vorbisfile, ov_fopen, LIBS="$LIBS -lvorbisfile", AC_MSG_ERROR([Can't find libvorbis.]))
+
+ AC_CHECK_LIB(dl, dlopen)
+ AC_CHECK_FUNC(dlopen,,AC_MSG_ERROR([Can't find dlopen function. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+--- torcs-1.3.4/Make-default.mk
++++ torcs-1.3.4/Make-default.mk
+@@ -402,7 +402,7 @@
+ ifdef PROGRAM
+
+ ${PROGRAM}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${SOLIBS} ${EXT_LIBS} -o $@
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ installprogram: ${PROGRAM}
+ @ createdir="${INSTLIBBASE}" ; \
+@@ -420,14 +420,14 @@
+ ifdef LOCALTOOLS
+
+ ${LOCALTOOLS}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${EXT_LIBS} ${SOLIBS} -o $@
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ endif
+
+ ifdef TOOLS
+
+ ${TOOLS}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${EXT_LIBS} ${SOLIBS} -o $@
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ installtools: ${TOOLS}
+ @createdir="${INSTBINBASE}/${TOOLSDIR}" ; \
+@@ -478,7 +478,7 @@
+ ifdef SOLIBRARY
+
+ ${SOLIBRARY}: ${OBJECTS}
+- ${CXX} -shared -o ${SOLIBRARY} ${OBJECTS} ${LDFLAGS} ${LIBSPATH} ${LIBS} ${DEBUG_LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -shared -o ${SOLIBRARY} ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+ @D=`pwd` ; \
+ createdir="${EXPORTBASE}/lib" ; \
+ $(mkinstalldirs) $$createdir ; \
+@@ -509,7 +509,7 @@
+ ifdef MODULE
+
+ ${MODULE}: ${OBJECTS}
+- ${CXX} -shared -o ${MODULE} ${OBJECTS} ${LDFLAGS} ${LIBSPATH} ${LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -shared -o ${MODULE} ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+ @D=`pwd` ; \
+ createdir="${EXPORTBASE}/${MODULEDIR}" ; \
+ $(mkinstalldirs) $$createdir ; \
+--- torcs-1.3.4/src/libs/client/Makefile
++++ torcs-1.3.4/src/libs/client/Makefile
+@@ -23,6 +23,8 @@
+ SOURCES = entry.cpp mainmenu.cpp splash.cpp exitmenu.cpp \
+ optionmenu.cpp
+
++SOLIBS = -lconfscreens -lraceengine
++
+ LIBS = -lplibssg -lplibsg -lplibul
+
+ EXPDIR = include
+--- torcs-1.3.4/src/libs/Makefile
++++ torcs-1.3.4/src/libs/Makefile
+@@ -23,7 +23,7 @@
+
+ TOOLSUBDIRS = txml
+
+-SUBDIRS = confscreens racescreens robottools txml tgf tgfclient client raceengineclient learning \
++SUBDIRS = confscreens racescreens robottools txml tgf tgfclient raceengineclient client learning \
+ portability math musicplayer
+
+ PKGSUBDIRS = $(SUBDIRS)
+--- torcs-1.3.4/src/libs/raceengineclient/Makefile
++++ torcs-1.3.4/src/libs/raceengineclient/Makefile
+@@ -23,6 +23,8 @@
+ SOURCES = singleplayer.cpp raceinit.cpp racemain.cpp racemanmenu.cpp racestate.cpp racegl.cpp \
+ raceengine.cpp raceresults.cpp
+
++SOLIBS = -lconfscreens -lrobottools -lracescreens
++
+ EXPDIR = include
+
+ EXPORTS = singleplayer.h raceinit.h
+--- torcs-1.3.4/src/libs/tgf/Makefile
++++ torcs-1.3.4/src/libs/tgf/Makefile
+@@ -29,6 +29,7 @@
+ profiler.cpp \
+ hash.cpp
+
++SOLIBS = -ltxml
+
+ EXPDIR = include
+
diff --git a/games-sports/torcs/files/torcs-1.3.4-flags.patch b/games-sports/torcs/files/torcs-1.3.4-flags.patch
new file mode 100644
index 000000000000..170303804da2
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.4-flags.patch
@@ -0,0 +1,14 @@
+respect cflags
+
+--- torcs-1.3.4/configure.in
++++ torcs-1.3.4/configure.in
+@@ -50,8 +50,7 @@
+ ADDCFLAGS="-Wall -fPIC -fno-strict-aliasing"
+ AC_ARG_ENABLE(debug,
+ [ --enable-debug set the debug mode],
+- ADDCFLAGS="$ADDCFLAGS -g -DDEBUG -DDEBUG_OUT",
+- ADDCFLAGS="$ADDCFLAGS -O2")
++ ADDCFLAGS="$ADDCFLAGS -g -DDEBUG -DDEBUG_OUT")
+
+ AC_ARG_ENABLE(xrandr,
+ [ --disable-xrandr reset the XRANDR mode],
diff --git a/games-sports/torcs/files/torcs-1.3.4-no-automake.patch b/games-sports/torcs/files/torcs-1.3.4-no-automake.patch
new file mode 100644
index 000000000000..7f0a921b1760
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.4-no-automake.patch
@@ -0,0 +1,21 @@
+torcs doesn't use automake, so it shouldn't be calling the macro
+
+http://bugs.gentoo.org/408473
+
+--- torcs-1.3.4/configure.in
++++ torcs-1.3.4/configure.in
+@@ -15,9 +15,12 @@
+ #
+ ##############################################################################
+
+-AC_INIT(Make-config.in)
++AC_INIT(torcs, 1.3.4)
+ AC_CONFIG_HEADERS(config.h)
+-AM_INIT_AUTOMAKE(torcs, 1.3.4)
++dnl Workaround code using old VERSION instead of new PACKAGE_VERSION
++VERSION=$PACKAGE_VERSION
++AC_DEFINE_UNQUOTED([VERSION], "$VERSION", [old VERSION workaround])
++AC_SUBST(VERSION)
+
+ dnl Checks for programs.
+ AC_PROG_CC
diff --git a/games-sports/torcs/torcs-1.3.4.ebuild b/games-sports/torcs/torcs-1.3.4.ebuild
new file mode 100644
index 000000000000..8e4f1f7bf1e7
--- /dev/null
+++ b/games-sports/torcs/torcs-1.3.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.3.4.ebuild,v 1.1 2012/12/14 22:57:22 hasufell Exp $
+
+EAPI=5
+inherit autotools eutils multilib games
+
+DESCRIPTION="The Open Racing Car Simulator"
+HOMEPAGE="http://torcs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/torcs/${P}.tar.bz2"
+
+LICENSE="GPL-2 FreeArt"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/freealut
+ media-libs/freeglut
+ media-libs/libpng:0
+ media-libs/libvorbis
+ media-libs/openal
+ >=media-libs/plib-1.8.4
+ sys-libs/zlib
+ virtual/opengl
+ virtual/glu
+ x11-libs/libX11
+ x11-libs/libXrandr
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-no-automake.patch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-flags.patch
+ eautoreconf
+ ecvs_clean
+}
+
+src_configure() {
+ addpredict $(echo /dev/snd/controlC? | sed 's/ /:/g')
+ [[ -e /dev/dsp ]] && addpredict /dev/dsp
+ egamesconf \
+ --datadir="${GAMES_DATADIR_BASE}" \
+ --x-libraries=/usr/$(get_libdir) \
+ --enable-xrandr
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install datainstall
+ newicon Ticon.png ${PN}.png
+ make_desktop_entry ${PN} TORCS
+ dodoc README doc/history/history.txt
+ doman doc/man/*.6
+ dohtml -r doc/faq/faq.html doc/tutorials doc/userman
+ prepgamesdirs
+}