summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-09 18:45:51 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-09 18:45:51 +0000
commitdf3797837c89b594006618af87bd32a668f3a080 (patch)
tree58f0cc9108f1db8245d23a601cca0c64bc87683c /games-sports
parentversion bump, ported to EAPI 2 and played around with econf switches. This is... (diff)
downloadgentoo-2-df3797837c89b594006618af87bd32a668f3a080.tar.gz
gentoo-2-df3797837c89b594006618af87bd32a668f3a080.tar.bz2
gentoo-2-df3797837c89b594006618af87bd32a668f3a080.zip
Fix building with gcc-4.4, bug #273369
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/stormbaancoureur/ChangeLog6
-rw-r--r--games-sports/stormbaancoureur/files/stormbaancoureur-2.1.5-gcc44.patch10
-rw-r--r--games-sports/stormbaancoureur/stormbaancoureur-2.1.5.ebuild9
3 files changed, 19 insertions, 6 deletions
diff --git a/games-sports/stormbaancoureur/ChangeLog b/games-sports/stormbaancoureur/ChangeLog
index 15d260c903c3..59bc26d82771 100644
--- a/games-sports/stormbaancoureur/ChangeLog
+++ b/games-sports/stormbaancoureur/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/stormbaancoureur
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/stormbaancoureur/ChangeLog,v 1.14 2009/03/09 16:00:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/stormbaancoureur/ChangeLog,v 1.15 2009/06/09 18:45:51 nyhm Exp $
+
+ 09 Jun 2009; Tristan Heaven <nyhm@gentoo.org>
+ stormbaancoureur-2.1.5.ebuild, +files/stormbaancoureur-2.1.5-gcc44.patch:
+ Fix building with gcc-4.4, bug #273369
09 Mar 2009; Raúl Porcel <armin76@gentoo.org>
stormbaancoureur-2.1.5.ebuild:
diff --git a/games-sports/stormbaancoureur/files/stormbaancoureur-2.1.5-gcc44.patch b/games-sports/stormbaancoureur/files/stormbaancoureur-2.1.5-gcc44.patch
new file mode 100644
index 000000000000..8171c4663e3e
--- /dev/null
+++ b/games-sports/stormbaancoureur/files/stormbaancoureur-2.1.5-gcc44.patch
@@ -0,0 +1,10 @@
+--- src-stormbaancoureur/controllerkey.cxx
++++ src-stormbaancoureur/controllerkey.cxx
+@@ -9,6 +9,7 @@
+ #include <math.h>
+ #include <errno.h>
+ #include <fcntl.h>
++#include <cstdio>
+
+ #include "controller.h"
+
diff --git a/games-sports/stormbaancoureur/stormbaancoureur-2.1.5.ebuild b/games-sports/stormbaancoureur/stormbaancoureur-2.1.5.ebuild
index d5eaef252f18..0260e3d0fa3a 100644
--- a/games-sports/stormbaancoureur/stormbaancoureur-2.1.5.ebuild
+++ b/games-sports/stormbaancoureur/stormbaancoureur-2.1.5.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/stormbaancoureur/stormbaancoureur-2.1.5.ebuild,v 1.2 2009/03/09 16:00:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/stormbaancoureur/stormbaancoureur-2.1.5.ebuild,v 1.3 2009/06/09 18:45:51 nyhm Exp $
+EAPI=2
inherit eutils toolchain-funcs games
DESCRIPTION="Simulated obstacle course for automobiles"
@@ -22,10 +23,7 @@ DEPEND="virtual/opengl
S=${WORKDIR}/${P}/src-${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
sed -i \
-e "/dirprefix \?=\"/s:=.*: = \"${GAMES_DATADIR}/${PN}\";:" main.cxx \
|| die "sed failed"
@@ -38,6 +36,7 @@ src_unpack() {
-e '/^LFLAGS=/s:=:= $(LDFLAGS) :' \
-e 's:$(ODEPREFIX)/$(LIBDIRNAME)/libode.a:-lode:' \
Makefile || die "sed failed"
+ epatch "${FILESDIR}"/${P}-gcc44.patch
}
src_install() {