summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-01-16 16:21:18 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-01-16 16:21:18 +0000
commit15a88b014dc6e653da631af35dcf41cced12f7b7 (patch)
treec449f962f3d13422171093781c5515f861469a0b /games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild
parentInclude look&feel settings in the .jar file again, this time unpack them from... (diff)
downloadgentoo-2-15a88b014dc6e653da631af35dcf41cced12f7b7.tar.gz
gentoo-2-15a88b014dc6e653da631af35dcf41cced12f7b7.tar.bz2
gentoo-2-15a88b014dc6e653da631af35dcf41cced12f7b7.zip
New ebuild. Bug #96781
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild')
-rw-r--r--games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild b/games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild
new file mode 100644
index 000000000000..4a64e38b86f6
--- /dev/null
+++ b/games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/dark-oberon/dark-oberon-1.0.2_rc1.ebuild,v 1.1 2007/01/16 16:21:18 tupone Exp $
+
+inherit eutils games
+
+MY_PV=${PV/_rc/-RC}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="a Warcraft like RTS game"
+HOMEPAGE="http://dark-oberon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="fmod"
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/glfw
+ fmod? ( media-libs/fmod )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-gentoo.patch
+}
+
+src_compile() {
+ cd src
+ if use fmod; then
+ emake SOUND=1 ../${PN} || die "emake failed"
+ else
+ emake ../${PN} || die "emake failed"
+ fi
+}
+
+src_install() {
+ dogamesbin dark-oberon || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r dat maps races schemes || die "doins failed"
+ dodoc README docs/* || die "dodoc failed"
+
+ prepgamesdirs
+}