summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-10-31 16:57:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-10-31 16:57:47 +0000
commit67bc0cfd0913c22325b2b4c2771b7769e40cfa79 (patch)
treee8951610994d2f81dc489307a34617b39f6c1f5b /games-strategy/freeciv
parentVersion bump for change in dmesg format to report FFB devices. (diff)
downloadgentoo-2-67bc0cfd0913c22325b2b4c2771b7769e40cfa79.tar.gz
gentoo-2-67bc0cfd0913c22325b2b4c2771b7769e40cfa79.tar.bz2
gentoo-2-67bc0cfd0913c22325b2b4c2771b7769e40cfa79.zip
version bump (bug #197644)
(Portage version: 2.1.3.16)
Diffstat (limited to 'games-strategy/freeciv')
-rw-r--r--games-strategy/freeciv/ChangeLog8
-rw-r--r--games-strategy/freeciv/files/digest-freeciv-2.1.09
-rw-r--r--games-strategy/freeciv/freeciv-2.1.0.ebuild167
3 files changed, 183 insertions, 1 deletions
diff --git a/games-strategy/freeciv/ChangeLog b/games-strategy/freeciv/ChangeLog
index 187555280347..2661de3b2258 100644
--- a/games-strategy/freeciv/ChangeLog
+++ b/games-strategy/freeciv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freeciv
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.61 2007/05/12 09:15:35 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.62 2007/10/31 16:57:47 mr_bones_ Exp $
+
+*freeciv-2.1.0 (31 Oct 2007)
+
+ 31 Oct 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +freeciv-2.1.0.ebuild:
+ version bump (bug #197644)
12 May 2007; Stefan Schweizer <genstef@gentoo.org> freeciv-2.0.9.ebuild:
Fix unavailable stdsounds3.tar.gz url
diff --git a/games-strategy/freeciv/files/digest-freeciv-2.1.0 b/games-strategy/freeciv/files/digest-freeciv-2.1.0
new file mode 100644
index 000000000000..e8c72ac0d599
--- /dev/null
+++ b/games-strategy/freeciv/files/digest-freeciv-2.1.0
@@ -0,0 +1,9 @@
+MD5 f640aa48abca0a235220d6df22b9bc82 freeciv-2.1.0.tar.bz2 29463631
+RMD160 0f48b6841940a0ea4d7607face12e448dfd5f268 freeciv-2.1.0.tar.bz2 29463631
+SHA256 bc9a9f54e6775ad300da973cbce6728cd081cac79b4c95032da1c62f07918883 freeciv-2.1.0.tar.bz2 29463631
+MD5 42ae5aa07b3e176f81dfa905bcc0eb4f freeciv.png 3657
+RMD160 6f283d6031b7b4ae3da21ddd5145084f147a7acd freeciv.png 3657
+SHA256 50af34df5f43fb90844561ea5f91bbf1fbb762d15ea56811e39c7ad3f2cc0160 freeciv.png 3657
+MD5 77215914712f2f351092918f5e41e39e stdsounds3.tar.gz 118278
+RMD160 46bb5fef4b2d3acf9959b3228c962bdf6591ea09 stdsounds3.tar.gz 118278
+SHA256 a3cc2be93c006c3a9492349aa4552bf059e45efc94135f09241877c221ae1bfa stdsounds3.tar.gz 118278
diff --git a/games-strategy/freeciv/freeciv-2.1.0.ebuild b/games-strategy/freeciv/freeciv-2.1.0.ebuild
new file mode 100644
index 000000000000..b0101d8b0f1b
--- /dev/null
+++ b/games-strategy/freeciv/freeciv-2.1.0.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.1.0.ebuild,v 1.1 2007/10/31 16:57:47 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P=${PN}-${PV/_/-}
+DESCRIPTION="multiplayer strategy game (Civilization Clone)"
+HOMEPAGE="http://www.freeciv.org/"
+SRC_URI="ftp://ftp.freeciv.org/pub/freeciv/stable/${MY_P}.tar.bz2
+ mirror://gentoo/${PN}.png
+ !dedicated? (
+ alsa? (
+ ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
+ esd? (
+ ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
+ sdl? (
+ ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa auth dedicated esd gtk nls readline sdl Xaw3d"
+
+RDEPEND="readline? ( sys-libs/readline )
+ !dedicated? (
+ nls? ( virtual/libintl )
+ gtk? ( >=x11-libs/gtk+-2 )
+ !gtk? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ x11-libs/libXmu
+ x11-libs/libXpm
+ )
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/audiofile
+ )
+ esd? ( media-sound/esound )
+ sdl? ( media-libs/sdl-mixer )
+ auth? ( virtual/mysql )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !dedicated? ( gtk? ( dev-util/pkgconfig ) )
+ x11-proto/xextproto
+ media-libs/libpng"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ games_pkg_setup
+ if ! use dedicated ; then
+ if use gtk ; then
+ elog "The Freeciv Client will be built with the GTK+-2 toolkit"
+ elif use Xaw3d ; then
+ elog "The Freeciv Client will be built with the Xaw3d toolkit"
+ else
+ elog "The Freeciv Client will be built with the Xaw toolkit"
+ fi
+ if ! use esd && ! use alsa && ! use sdl ; then
+ ewarn
+ ewarn "To enable sound support in civclient, you must enable"
+ ewarn "at least one of this USE flags: alsa, esd, sdl"
+ ewarn
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # install locales in /usr/share/locale
+ sed -i \
+ -e 's:^\(localedir = \).*:\1/usr/share/locale:' \
+ intl/Makefile.in po/Makefile.in.in \
+ || die "sed failed"
+ sed -i \
+ -e 's:$datadir/locale:/usr/share/locale:' \
+ configure \
+ || die "sed failed"
+
+ # change .desktop category so it is not gnome specific
+ sed -i \
+ -e 's:^\(Categories=GNOME;Application;Game;Strategy;\):Categories=Application;Game;StrategyGame;:' \
+ -e 's:^\(Icon=\).*:\1freeciv.png:' \
+ bootstrap/freeciv.desktop.in \
+ || die "sed failed"
+ # install the .desktop in /usr/share/applications
+ sed -i \
+ -e 's:^\(desktopfiledir = \).*:\1/usr/share/applications:' \
+ client/Makefile.in \
+ || die "sed failed"
+
+ # remove civclient manpage if dedicated server
+ if use dedicated ; then
+ sed -i \
+ -e '/man_MANS = /s:civclient.6::' \
+ doc/man/Makefile.in \
+ || die "sed failed"
+ fi
+}
+
+src_compile() {
+ local mysoundconf
+ local myclient
+
+ if use dedicated ; then
+ mysoundconf="--disable-alsa --disable-esd --disable-sdl-mixer"
+ myclient="no"
+ else
+ myclient="xaw"
+ use Xaw3d && myclient="xaw3d"
+ if use gtk ; then
+ myclient="gtk-2.0"
+ fi
+ #FIXME --enable-{alsa,esd,sdl-mixer} actually disable them...
+ #FIXME ==> use --disable-* only, and autodetect to enable.
+ use alsa || mysoundconf="${mysoundconf} --disable-alsa"
+ use esd || mysoundconf="${mysoundconf} --disable-esd"
+ use sdl || mysoundconf="${mysoundconf} --disable-sdl-mixer"
+ fi
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-zlib \
+ $(use_enable auth) \
+ $(use_enable nls) \
+ $(use_with readline) \
+ --enable-client=${myclient} \
+ ${mysoundconf} \
+ || die "egamesconf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if ! use dedicated ; then
+ # Install the app-defaults if Xaw/Xaw3d toolkit
+ if ! use gtk ; then
+ insinto /etc/X11/app-defaults
+ doins data/Freeciv || die "doins failed"
+ fi
+ # Install sounds if at least one sound plugin was built
+ if use alsa || use esd || use sdl ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../data/stdsounds* || die "doins sounds failed"
+ fi
+ # Create and install the html manual. It can't be done for dedicated
+ # servers, because the 'civmanual' tool is then not built. Also
+ # delete civmanual from the GAMES_BINDIR, because it's then useless.
+ # Note: to have it localized, it should be ran from _postinst, or
+ # something like that, but then it's a PITA to avoid orphan files...
+ ./manual/civmanual || die "civmanual failed"
+ dohtml manual*.html || die "dohtml failed"
+ rm -f "${D}/${GAMES_BINDIR}"/civmanual
+ fi
+
+ dodoc ChangeLog NEWS doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,README*,TODO}
+
+ doicon "${DISTDIR}"/${PN}.png
+ prepgamesdirs
+}