summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-10-31 23:04:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-10-31 23:04:47 +0000
commit88e773a207e63e6bea0a893ca028b20fee75be58 (patch)
treed13fe25323a9bbfa1ba4dd38c4eaa50c031c3933 /games-strategy/freeciv
parentarm/s390/sh stable (diff)
downloadgentoo-2-88e773a207e63e6bea0a893ca028b20fee75be58.tar.gz
gentoo-2-88e773a207e63e6bea0a893ca028b20fee75be58.tar.bz2
gentoo-2-88e773a207e63e6bea0a893ca028b20fee75be58.zip
add sdl patch to ebuild from Andrei Slavoiu (bug #197697)
(Portage version: 2.1.3.16)
Diffstat (limited to 'games-strategy/freeciv')
-rw-r--r--games-strategy/freeciv/ChangeLog5
-rw-r--r--games-strategy/freeciv/freeciv-2.1.0.ebuild21
2 files changed, 19 insertions, 7 deletions
diff --git a/games-strategy/freeciv/ChangeLog b/games-strategy/freeciv/ChangeLog
index 2661de3b2258..256f74b93d92 100644
--- a/games-strategy/freeciv/ChangeLog
+++ b/games-strategy/freeciv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/freeciv
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.62 2007/10/31 16:57:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.63 2007/10/31 23:04:47 mr_bones_ Exp $
+
+ 31 Oct 2007; Michael Sterrett <mr_bones_@gentoo.org> freeciv-2.1.0.ebuild:
+ add sdl patch to ebuild from Andrei Slavoiu (bug #197697)
*freeciv-2.1.0 (31 Oct 2007)
diff --git a/games-strategy/freeciv/freeciv-2.1.0.ebuild b/games-strategy/freeciv/freeciv-2.1.0.ebuild
index b0101d8b0f1b..fca6ee5f6d19 100644
--- a/games-strategy/freeciv/freeciv-2.1.0.ebuild
+++ b/games-strategy/freeciv/freeciv-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.1.0.ebuild,v 1.1 2007/10/31 16:57:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.1.0.ebuild,v 1.2 2007/10/31 23:04:47 mr_bones_ Exp $
inherit eutils games
@@ -28,10 +28,16 @@ RDEPEND="readline? ( sys-libs/readline )
nls? ( virtual/libintl )
gtk? ( >=x11-libs/gtk+-2 )
!gtk? (
- Xaw3d? ( x11-libs/Xaw3d )
- !Xaw3d? ( x11-libs/libXaw )
- x11-libs/libXmu
- x11-libs/libXpm
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-image
+ )
+ !sdl? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ x11-libs/libXmu
+ x11-libs/libXpm
+ )
)
alsa? (
media-libs/alsa-lib
@@ -56,6 +62,8 @@ pkg_setup() {
elog "The Freeciv Client will be built with the GTK+-2 toolkit"
elif use Xaw3d ; then
elog "The Freeciv Client will be built with the Xaw3d toolkit"
+ elif use sdl ; then
+ elog "The Freeciv Client will be built with the SDL toolkit"
else
elog "The Freeciv Client will be built with the Xaw toolkit"
fi
@@ -112,6 +120,7 @@ src_compile() {
myclient="no"
else
myclient="xaw"
+ use sdl && myclient="sdl"
use Xaw3d && myclient="xaw3d"
if use gtk ; then
myclient="gtk-2.0"
@@ -141,7 +150,7 @@ src_install() {
if ! use dedicated ; then
# Install the app-defaults if Xaw/Xaw3d toolkit
- if ! use gtk ; then
+ if ! use gtk && ! use sdl ; then
insinto /etc/X11/app-defaults
doins data/Freeciv || die "doins failed"
fi