summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-05-12 15:46:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-05-12 15:46:35 +0000
commit3ed5525166d0c17d7cd6a817abf2a7b48e2a3509 (patch)
tree5d966faf0ea659378cbd765dcafd034587cd0132 /games-strategy/freecol
parentdepend on >=tk-8.4.18-r1, as suggested on bug #259833 comment #6 (diff)
downloadgentoo-2-3ed5525166d0c17d7cd6a817abf2a7b48e2a3509.tar.gz
gentoo-2-3ed5525166d0c17d7cd6a817abf2a7b48e2a3509.tar.bz2
gentoo-2-3ed5525166d0c17d7cd6a817abf2a7b48e2a3509.zip
version bump
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'games-strategy/freecol')
-rw-r--r--games-strategy/freecol/ChangeLog8
-rw-r--r--games-strategy/freecol/files/freecol-0.8.3-home.patch11
-rw-r--r--games-strategy/freecol/freecol-0.8.3.ebuild68
3 files changed, 86 insertions, 1 deletions
diff --git a/games-strategy/freecol/ChangeLog b/games-strategy/freecol/ChangeLog
index 45abce0062cb..d20405705078 100644
--- a/games-strategy/freecol/ChangeLog
+++ b/games-strategy/freecol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freecol
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/ChangeLog,v 1.32 2009/05/09 20:51:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/ChangeLog,v 1.33 2009/05/12 15:46:35 mr_bones_ Exp $
+
+*freecol-0.8.3 (12 May 2009)
+
+ 12 May 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/freecol-0.8.3-home.patch, +freecol-0.8.3.ebuild:
+ version bump
*freecol-0.8.2 (09 May 2009)
diff --git a/games-strategy/freecol/files/freecol-0.8.3-home.patch b/games-strategy/freecol/files/freecol-0.8.3-home.patch
new file mode 100644
index 000000000000..c2af74e48f3b
--- /dev/null
+++ b/games-strategy/freecol/files/freecol-0.8.3-home.patch
@@ -0,0 +1,11 @@
+--- src/net/sf/freecol/common/logging/DefaultHandler.java
++++ src/net/sf/freecol/common/logging/DefaultHandler.java
+@@ -22,7 +22,7 @@
+
+ public static final String REVISION = "$Revision: 1.1 $";
+
+- private static final String fileName = new String("FreeCol.log");
++ private static final String fileName = new String(System.getProperty("user.home") + "/.freecol/FreeCol.log");
+
+ private FileWriter fileWriter;
+
diff --git a/games-strategy/freecol/freecol-0.8.3.ebuild b/games-strategy/freecol/freecol-0.8.3.ebuild
new file mode 100644
index 000000000000..ed637a422c19
--- /dev/null
+++ b/games-strategy/freecol/freecol-0.8.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/freecol-0.8.3.ebuild,v 1.1 2009/05/12 15:46:35 mr_bones_ Exp $
+
+WANT_ANT_TASKS="ant-nodeps"
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="An open source clone of the game Colonization"
+HOMEPAGE="http://www.freecol.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-java/higlayout"
+DEPEND="${RDEPEND}
+ test? (
+ dev-java/ant-junit
+ dev-java/ant-trax
+ )
+ >=virtual/jdk-1.6"
+RDEPEND="${RDEPEND}
+ >=virtual/jre-1.6"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -fv $(find . -name '*.jar')
+ java-pkg_jar-from --into jars higlayout
+ epatch "${FILESDIR}"/${P}-home.patch
+ sed -i \
+ -e "/Class-Path/s:jars/.*\":$(java-pkg_getjars higlayout)\":" \
+ build.xml \
+ || die "sed failed"
+}
+
+src_compile() {
+ eant
+}
+
+src_test() {
+ java-pkg_jar-from --into test/lib junit
+ ANT_TASKS="ant-junit ant-trax ant-nodeps" eant testall
+}
+
+src_install () {
+ java-pkg_jarinto "${GAMES_DATADIR}"/${PN}
+ java-pkg_dojar FreeCol.jar
+ java-pkg_dolauncher ${PN} \
+ -into "${GAMES_PREFIX}" \
+ --pwd "${GAMES_DATADIR}"/${PN} \
+ --java_args -Xmx512M
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data || die "doins failed"
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} FreeCol
+ dodoc README
+ prepgamesdirs
+}