summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-04-19 08:05:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-04-19 08:05:07 +0000
commit3c8b4d347642fe00a2e810ea4842aef68b3da40e (patch)
tree8cfacb6c424bf788a0e97806f9c161f27ed6a615 /games-strategy/glob2
parentstable amd64, bug 174973 (diff)
downloadgentoo-2-3c8b4d347642fe00a2e810ea4842aef68b3da40e.tar.gz
gentoo-2-3c8b4d347642fe00a2e810ea4842aef68b3da40e.tar.bz2
gentoo-2-3c8b4d347642fe00a2e810ea4842aef68b3da40e.zip
version bump
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-strategy/glob2')
-rw-r--r--games-strategy/glob2/ChangeLog9
-rw-r--r--games-strategy/glob2/files/digest-glob2-0.8.233
-rw-r--r--games-strategy/glob2/glob2-0.8.23.ebuild56
3 files changed, 66 insertions, 2 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index 1ce76aeb4261..86f7ccf85614 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glob2
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.33 2006/09/27 14:23:47 nyhm Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.34 2007/04/19 08:05:07 mr_bones_ Exp $
+
+*glob2-0.8.23 (19 Apr 2007)
+
+ 19 Apr 2007; Michael Sterrett <mr_bones_@gentoo.org> +glob2-0.8.23.ebuild:
+ version bump
27 Sep 2006; Tristan Heaven <nyhm@gentoo.org> glob2-0.8.19.ebuild:
Add inherit eutils
diff --git a/games-strategy/glob2/files/digest-glob2-0.8.23 b/games-strategy/glob2/files/digest-glob2-0.8.23
new file mode 100644
index 000000000000..be236388cb02
--- /dev/null
+++ b/games-strategy/glob2/files/digest-glob2-0.8.23
@@ -0,0 +1,3 @@
+MD5 d8807da21fc32db1727dd62b8d5c786a glob2-0.8.23.tar.gz 9845036
+RMD160 7dc50854d42f5b94860c3f4d3c77e5eac40914bb glob2-0.8.23.tar.gz 9845036
+SHA256 4d6e0ae73a4e0fda33cb5a344d678f379ad177c886f1730268eec27158aeaff1 glob2-0.8.23.tar.gz 9845036
diff --git a/games-strategy/glob2/glob2-0.8.23.ebuild b/games-strategy/glob2/glob2-0.8.23.ebuild
new file mode 100644
index 000000000000..1ddc0ae6ca95
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.8.23.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.8.23.ebuild,v 1.1 2007/04/19 08:05:07 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://globulation2.org/"
+SRC_URI="http://dl.sv.nongnu.org/releases/glob2/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ dev-libs/boost
+ >=media-libs/libsdl-1.2.0
+ media-libs/libpng
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/libvorbis
+ >=media-libs/speex-1.1
+ =media-libs/freetype-2*
+ sys-libs/zlib"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^glob2linkdir/s:\$(datadir):/usr/share:" \
+ data/Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e "/^glob2icondir/s:\$(datadir):/usr/share:" \
+ data/icons/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ #./configure assumes that vorbis will be installed under PREFIX bug #46352
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-vorbis=/usr \
+ --with-speex=/usr \
+ --with-speex-includes=/usr/include/speex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README TODO
+ prepgamesdirs
+}