summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-08-06 07:12:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-08-06 07:12:38 +0000
commit93346df025cf6f28753185899eb178185d5b8fb1 (patch)
treea2b1861e5b1c54b37582759ee5932ad13b0eae01 /games-strategy/glob2
parentold (diff)
downloadgentoo-2-93346df025cf6f28753185899eb178185d5b8fb1.tar.gz
gentoo-2-93346df025cf6f28753185899eb178185d5b8fb1.tar.bz2
gentoo-2-93346df025cf6f28753185899eb178185d5b8fb1.zip
version bump
(Portage version: 2.1.1_pre4-r3)
Diffstat (limited to 'games-strategy/glob2')
-rw-r--r--games-strategy/glob2/ChangeLog7
-rw-r--r--games-strategy/glob2/files/digest-glob2-0.8.213
-rw-r--r--games-strategy/glob2/glob2-0.8.21.ebuild55
3 files changed, 64 insertions, 1 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index 8129620c30f4..1a77fd246832 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glob2
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.30 2006/05/28 10:13:20 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.31 2006/08/06 07:12:38 mr_bones_ Exp $
+
+*glob2-0.8.21 (06 Aug 2006)
+
+ 06 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org> +glob2-0.8.21.ebuild:
+ version bump
28 May 2006; <Tupone@gentoo.org> +files/glob2-0.8.19-gcc41.patch,
glob2-0.8.19.ebuild:
diff --git a/games-strategy/glob2/files/digest-glob2-0.8.21 b/games-strategy/glob2/files/digest-glob2-0.8.21
new file mode 100644
index 000000000000..70a5b21ff7eb
--- /dev/null
+++ b/games-strategy/glob2/files/digest-glob2-0.8.21
@@ -0,0 +1,3 @@
+MD5 3173f82572f1dd5fba79019ebc43d427 glob2-0.8.21.tar.gz 9496398
+RMD160 f8f69e8d86d8f175d8ed152278241900584c67d1 glob2-0.8.21.tar.gz 9496398
+SHA256 db687dafbba0f7b3b49ce6e0bc70205445b870a6a9afda504f8f7a7f48631ec4 glob2-0.8.21.tar.gz 9496398
diff --git a/games-strategy/glob2/glob2-0.8.21.ebuild b/games-strategy/glob2/glob2-0.8.21.ebuild
new file mode 100644
index 000000000000..ede581f275e4
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.8.21.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.8.21.ebuild,v 1.1 2006/08/06 07:12:38 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://globulation2.org/"
+SRC_URI="http://globulation2.org/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ dev-libs/boost
+ >=media-libs/libsdl-1.2.0
+ media-libs/libpng
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/libvorbis
+ >=media-libs/speex-1.1
+ =media-libs/freetype-2*
+ sys-libs/zlib"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^glob2linkdir/s:\$(datadir):/usr/share:" \
+ data/Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e "/^glob2icondir/s:\$(datadir):/usr/share:" \
+ data/icons/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ #./configure assumes that vorbis will be installed under PREFIX bug #46352
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-vorbis=/usr \
+ --with-speex=/usr \
+ --with-speex-includes=/usr/include/speex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO
+ prepgamesdirs
+}