summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-07-29 19:42:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-07-29 19:42:07 +0000
commitee62f5008d5215fe155873afd41f27d731996554 (patch)
tree9e0df7417836b29bc0887ad051dc23180444d719 /games-strategy/naev
parentBumping to 1.6 (diff)
downloadgentoo-2-ee62f5008d5215fe155873afd41f27d731996554.tar.gz
gentoo-2-ee62f5008d5215fe155873afd41f27d731996554.tar.bz2
gentoo-2-ee62f5008d5215fe155873afd41f27d731996554.zip
Fix missing zlib.h include for Z_DEFAULT_COMPRESSION after libpng headers got cleaned up.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy/naev')
-rw-r--r--games-strategy/naev/ChangeLog7
-rw-r--r--games-strategy/naev/files/naev-0.5.0-libpng15.patch15
-rw-r--r--games-strategy/naev/naev-0.5.0.ebuild8
3 files changed, 27 insertions, 3 deletions
diff --git a/games-strategy/naev/ChangeLog b/games-strategy/naev/ChangeLog
index ff552af15286..09e5e7843309 100644
--- a/games-strategy/naev/ChangeLog
+++ b/games-strategy/naev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/naev
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/ChangeLog,v 1.6 2011/07/19 20:08:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/ChangeLog,v 1.7 2011/07/29 19:42:07 ssuominen Exp $
+
+ 29 Jul 2011; Samuli Suominen <ssuominen@gentoo.org> naev-0.5.0.ebuild,
+ +files/naev-0.5.0-libpng15.patch:
+ Fix missing zlib.h include for Z_DEFAULT_COMPRESSION after libpng headers got
+ cleaned up.
19 Jul 2011; Markus Meier <maekke@gentoo.org> naev-0.5.0.ebuild:
amd64/x86 stable, bug #375489
diff --git a/games-strategy/naev/files/naev-0.5.0-libpng15.patch b/games-strategy/naev/files/naev-0.5.0-libpng15.patch
new file mode 100644
index 000000000000..1d144af45c5a
--- /dev/null
+++ b/games-strategy/naev/files/naev-0.5.0-libpng15.patch
@@ -0,0 +1,15 @@
+http://code.google.com/p/naev/issues/detail?id=129
+
+opengl.c: In function ‘write_png’:
+opengl.c:820:39: error: ‘Z_DEFAULT_COMPRESSION’ undeclared (first use in this function)
+
+--- src/opengl.c
++++ src/opengl.c
+@@ -39,6 +39,7 @@
+ #include <string.h>
+ #include <stdarg.h> /* va_list for gl_print */
+
++#include <zlib.h> /* Z_DEFAULT_COMPRESSION */
+ #include <png.h>
+
+ #include "SDL.h"
diff --git a/games-strategy/naev/naev-0.5.0.ebuild b/games-strategy/naev/naev-0.5.0.ebuild
index b03b9fd75f13..bf63981b6c8b 100644
--- a/games-strategy/naev/naev-0.5.0.ebuild
+++ b/games-strategy/naev/naev-0.5.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/naev-0.5.0.ebuild,v 1.2 2011/07/19 20:08:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/naev-0.5.0.ebuild,v 1.3 2011/07/29 19:42:07 ssuominen Exp $
EAPI=2
-inherit gnome2-utils games
+inherit eutils gnome2-utils games
DESCRIPTION="A 2D space trading and combat game, in a similar vein to Escape Velocity"
HOMEPAGE="http://code.google.com/p/naev/"
@@ -32,6 +32,10 @@ src_unpack() {
unpack ${P}.tar.bz2
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+}
+
src_configure() {
egamesconf \
--docdir=/usr/share/doc/${PF} \