summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-05-28 21:53:08 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-05-28 21:53:08 +0000
commitbc3afc8981df0e7a310769fc62eaf104805aed02 (patch)
tree277533d029ae98584c4edbe4c556750710804e63 /games-strategy/outerspace
parentVersion bump (diff)
downloadgentoo-2-bc3afc8981df0e7a310769fc62eaf104805aed02.tar.gz
gentoo-2-bc3afc8981df0e7a310769fc62eaf104805aed02.tar.bz2
gentoo-2-bc3afc8981df0e7a310769fc62eaf104805aed02.zip
Version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'games-strategy/outerspace')
-rw-r--r--games-strategy/outerspace/ChangeLog7
-rw-r--r--games-strategy/outerspace/files/digest-outerspace-0.5.63.13
-rw-r--r--games-strategy/outerspace/outerspace-0.5.63.1.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/games-strategy/outerspace/ChangeLog b/games-strategy/outerspace/ChangeLog
index 888cd74aa443..2603cef2cccf 100644
--- a/games-strategy/outerspace/ChangeLog
+++ b/games-strategy/outerspace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/outerspace
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.6 2007/05/27 13:31:14 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.7 2007/05/28 21:53:08 nyhm Exp $
+
+*outerspace-0.5.63.1 (28 May 2007)
+
+ 28 May 2007; Tristan Heaven <nyhm@gentoo.org> +outerspace-0.5.63.1.ebuild:
+ Version bump
*outerspace-0.5.63 (27 May 2007)
diff --git a/games-strategy/outerspace/files/digest-outerspace-0.5.63.1 b/games-strategy/outerspace/files/digest-outerspace-0.5.63.1
new file mode 100644
index 000000000000..b579c2dcb495
--- /dev/null
+++ b/games-strategy/outerspace/files/digest-outerspace-0.5.63.1
@@ -0,0 +1,3 @@
+MD5 bde2d76ee6c0ed462f61bf0320e537a1 OuterSpace-0.5.63.1.tar.gz 1682349
+RMD160 254c0986f577a8af9c6d3ef7618f63a763db64b4 OuterSpace-0.5.63.1.tar.gz 1682349
+SHA256 12b941e90067c9dd5800be27ac6fea994bab9e14c8362b56421011d3bf6856b5 OuterSpace-0.5.63.1.tar.gz 1682349
diff --git a/games-strategy/outerspace/outerspace-0.5.63.1.ebuild b/games-strategy/outerspace/outerspace-0.5.63.1.ebuild
new file mode 100644
index 000000000000..9c8af0df84b6
--- /dev/null
+++ b/games-strategy/outerspace/outerspace-0.5.63.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.63.1.ebuild,v 1.1 2007/05/28 21:53:08 nyhm Exp $
+
+inherit eutils games
+
+MY_PN=${PN/outerspace/OuterSpace}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="on-line strategy game taking place in the dangerous universe"
+HOMEPAGE="http://www.ospace.net/"
+SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygame-1.7
+ >=dev-lang/python-2.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_LIBDIR@:$(games_get_libdir)/${PN}:" \
+ "${FILESDIR}"/${PN} > ${PN} \
+ || die "sed failed"
+}
+
+src_install() {
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r osc.py lib libsrvr || die "doins lib failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r res || die "doins data failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ newicon res/icon32.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+ prepgamesdirs
+}