summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-19 09:29:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-19 09:29:18 +0000
commit5384c34c6e28700dd7b613dc85cb6262646680ef (patch)
tree1e7cbbde92cd00cbc802e9737551143a30537647 /games-strategy/uqm
parentEAPI=5 (diff)
downloadgentoo-2-5384c34c6e28700dd7b613dc85cb6262646680ef.tar.gz
gentoo-2-5384c34c6e28700dd7b613dc85cb6262646680ef.tar.bz2
gentoo-2-5384c34c6e28700dd7b613dc85cb6262646680ef.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy/uqm')
-rw-r--r--games-strategy/uqm/ChangeLog7
-rw-r--r--games-strategy/uqm/uqm-0.7.0-r2.ebuild36
2 files changed, 21 insertions, 22 deletions
diff --git a/games-strategy/uqm/ChangeLog b/games-strategy/uqm/ChangeLog
index c447c02af465..32cda6c83cb8 100644
--- a/games-strategy/uqm/ChangeLog
+++ b/games-strategy/uqm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/uqm
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/ChangeLog,v 1.45 2014/05/15 17:07:33 ulm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/ChangeLog,v 1.46 2015/02/19 09:29:18 mr_bones_ Exp $
+
+ 19 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> uqm-0.7.0-r2.ebuild:
+ EAPI=5
15 May 2014; Ulrich Müller <ulm@gentoo.org> uqm-0.7.0-r2.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
diff --git a/games-strategy/uqm/uqm-0.7.0-r2.ebuild b/games-strategy/uqm/uqm-0.7.0-r2.ebuild
index 099434fa1e69..0fc520c0a8d6 100644
--- a/games-strategy/uqm/uqm-0.7.0-r2.ebuild
+++ b/games-strategy/uqm/uqm-0.7.0-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/uqm-0.7.0-r2.ebuild,v 1.6 2014/05/15 17:07:33 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/uqm-0.7.0-r2.ebuild,v 1.7 2015/02/19 09:29:18 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils multilib toolchain-funcs games
DESCRIPTION="The Ur-Quan Masters: Port of Star Control 2"
@@ -51,54 +51,50 @@ src_prepare() {
# Take out the read so we can be non-interactive.
sed -i \
- -e '/read CHOICE/d' build/unix/menu_functions \
- || die "sed menu_functions failed"
+ -e '/read CHOICE/d' build/unix/menu_functions || die
# respect CFLAGS
sed -i \
- -e "s/-O3//" build/unix/build.config \
- || die "sed build.config failed"
+ -e "s/-O3//" build/unix/build.config || die
sed -i \
- -e "s:@INSTALL_LIBDIR@:$(games_get_libdir)/:g" build/unix/uqm-wrapper.in \
- || die "sed uqm-wrapper.in failed"
+ -e "s:@INSTALL_LIBDIR@:$(games_get_libdir)/:g" \
+ build/unix/uqm-wrapper.in || die
# respect CC
sed -i \
-e "s/PROG_gcc_FILE=\"gcc\"/PROG_gcc_FILE=\"$(tc-getCC)\"/" \
- build/unix/config_proginfo_build \
- || die "sed config_proginfo_build failed"
+ build/unix/config_proginfo_build || die
}
src_compile() {
- MAKE_VERBOSE=1 ./build.sh uqm || die "build failed"
+ MAKE_VERBOSE=1 ./build.sh uqm || die
}
src_install() {
# Using the included install scripts seems quite painful.
# This manual install is totally fragile but maybe they'll
# use a sane build system for the next release.
- newgamesbin uqm-wrapper uqm || die "newgamesbin failed"
+ newgamesbin uqm-wrapper uqm
exeinto "$(games_get_libdir)"/${PN}
- doexe uqm || die "doexe failed"
+ doexe uqm
insinto "${GAMES_DATADIR}"/${PN}/content/packages
- doins "${DISTDIR}"/${P}-content.uqm || die "doins failed"
- echo ${P} > "${D}${GAMES_DATADIR}"/${PN}/content/version \
- || die "creating version file failed"
+ doins "${DISTDIR}"/${P}-content.uqm
+ echo ${P} > "${D}${GAMES_DATADIR}"/${PN}/content/version || die
insinto "${GAMES_DATADIR}"/${PN}/content/addons
if use music; then
- doins "${DISTDIR}"/${P}-3domusic.uqm || die "doins failed"
+ doins "${DISTDIR}"/${P}-3domusic.uqm
fi
if use voice; then
- doins "${DISTDIR}"/${P}-voice.uqm || die "doins failed"
+ doins "${DISTDIR}"/${P}-voice.uqm
fi
if use remix; then
insinto "${GAMES_DATADIR}"/${PN}/content/addons
- doins "${DISTDIR}"/${PN}-remix-disc{1,2,3}.uqm || die "doins failed"
+ doins "${DISTDIR}"/${PN}-remix-disc{1,2,3}.uqm
fi
dodoc AUTHORS ChangeLog Contributing README WhatsNew doc/users/manual.txt