summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-03-07 18:07:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-03-07 18:07:04 +0000
commit01b804d17ad513776473c0e33354d5604a99fd2d (patch)
treedf7efa1ee09d31a62e7856d5d0cfe95d260ef71e /games-strategy/warzone2100
parentalpha/arm/ia64/s390/sh/sparc/x86 stable wrt #261508 (diff)
downloadgentoo-2-01b804d17ad513776473c0e33354d5604a99fd2d.tar.gz
gentoo-2-01b804d17ad513776473c0e33354d5604a99fd2d.tar.bz2
gentoo-2-01b804d17ad513776473c0e33354d5604a99fd2d.zip
version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-strategy/warzone2100')
-rw-r--r--games-strategy/warzone2100/ChangeLog8
-rw-r--r--games-strategy/warzone2100/warzone2100-2.1.2.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index 2bc1e7df3852..271f1040b08f 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.27 2009/01/21 23:10:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.28 2009/03/07 18:07:03 mr_bones_ Exp $
+
+*warzone2100-2.1.2 (07 Mar 2009)
+
+ 07 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +warzone2100-2.1.2.ebuild:
+ version bump
21 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
warzone2100-2.1.1.ebuild:
diff --git a/games-strategy/warzone2100/warzone2100-2.1.2.ebuild b/games-strategy/warzone2100/warzone2100-2.1.2.ebuild
new file mode 100644
index 000000000000..5d49a207b570
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-2.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.1.2.ebuild,v 1.1 2009/03/07 18:07:04 mr_bones_ Exp $
+
+EAPI=2
+inherit versionator games
+
+MY_PV=$(get_version_component_range -2)
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="http://download.gna.org/warzone/releases/${MY_PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# upstream requested debug support
+IUSE="debug nls"
+
+RDEPEND="dev-games/physfs
+ dev-libs/popt
+ media-libs/jpeg
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl[opengl]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-net
+ media-libs/quesoglc
+ virtual/glu
+ virtual/opengl
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ media-fonts/dejavu"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --with-distributor="Gentoo ${PF}" \
+ --with-icondir=/usr/share/pixmaps \
+ --with-applicationdir=/usr/share/applications \
+ $(use_enable debug) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING*
+ prepgamesdirs
+}