summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-07-24 00:27:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-07-24 00:27:22 +0000
commit87203421d380db71ff03bc3f79b2e32429cacd2a (patch)
treec28873fa9b8335db91c1162851b91a0620d2afc7 /games-strategy/wesnoth/wesnoth-0.9.4.ebuild
parentAdd ~x86 keyword. (diff)
downloadgentoo-2-87203421d380db71ff03bc3f79b2e32429cacd2a.tar.gz
gentoo-2-87203421d380db71ff03bc3f79b2e32429cacd2a.tar.bz2
gentoo-2-87203421d380db71ff03bc3f79b2e32429cacd2a.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-strategy/wesnoth/wesnoth-0.9.4.ebuild')
-rw-r--r--games-strategy/wesnoth/wesnoth-0.9.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/wesnoth-0.9.4.ebuild b/games-strategy/wesnoth/wesnoth-0.9.4.ebuild
new file mode 100644
index 000000000000..bcc4f0d5db11
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.9.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.9.4.ebuild,v 1.1 2005/07/24 00:27:22 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/freetype-2
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/x11"
+
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ dodoc MANUAL changelog
+ prepgamesdirs
+}