summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-04 04:39:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-04 04:39:52 +0000
commitb9c1719973cccdb49c901e4330e18238b9067a1e (patch)
tree4252e5cce07a7f6715d3d7ea7c59ed8e3ae74fef /games-strategy/wesnoth
parentadd missing uclibc flag for gcc (diff)
downloadgentoo-2-b9c1719973cccdb49c901e4330e18238b9067a1e.tar.gz
gentoo-2-b9c1719973cccdb49c901e4330e18238b9067a1e.tar.bz2
gentoo-2-b9c1719973cccdb49c901e4330e18238b9067a1e.zip
version bump
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.7.61
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.6.ebuild40
4 files changed, 50 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 15459efd82b1..5465a2a82816 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.22 2004/04/25 08:49:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.23 2004/05/04 04:39:50 mr_bones_ Exp $
+
+*wesnoth-0.7.6 (03 May 2004)
+
+ 03 May 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.6.ebuild:
+ version bump; unsigned char issue is supposed to be fixed upstream so the
+ work around was removed.
*wesnoth-0.7.5 (25 Apr 2004)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index e9af65a721c0..46b017425c07 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -5,8 +5,10 @@ MD5 8e682d1d562a88ad935d27893417ffac wesnoth-0.7.2.ebuild 1011
MD5 68343aa5c3c7919a357a99c16b316431 wesnoth-0.7.1.ebuild 957
MD5 e5a28a60716ca01c3d5795c244713c20 wesnoth-0.7.3.ebuild 1089
MD5 760d9b172f31550fab4b1a5e876076d6 wesnoth-0.7.5.ebuild 1089
+MD5 760d9b172f31550fab4b1a5e876076d6 wesnoth-0.7.6.ebuild 1089
MD5 2218dd653ddf591503d9bde5beb4df8c files/digest-wesnoth-0.7 65
MD5 943fc665866e98d256c99403826c7cbd files/digest-wesnoth-0.7.2 67
MD5 eed8758f69d700eedc02234ae1a428d8 files/digest-wesnoth-0.7.1 67
MD5 30a5ab6c2f9337bb39ceb1fa8e5118c7 files/digest-wesnoth-0.7.3 67
MD5 ff60debaba2a5e123a23173f56bb03e8 files/digest-wesnoth-0.7.5 67
+MD5 85c8760fa128b26e3a29168510ffe3fd files/digest-wesnoth-0.7.6 67
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.7.6 b/games-strategy/wesnoth/files/digest-wesnoth-0.7.6
new file mode 100644
index 000000000000..d4f643de2549
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.7.6
@@ -0,0 +1 @@
+MD5 9e5be4ca1420b4c4f6e3fdc2b981aaef wesnoth-0.7.6.tar.gz 19662171
diff --git a/games-strategy/wesnoth/wesnoth-0.7.6.ebuild b/games-strategy/wesnoth/wesnoth-0.7.6.ebuild
new file mode 100644
index 000000000000..fc4c55f5a42e
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.7.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.6.ebuild,v 1.1 2004/05/04 04:39:50 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc ~sparc"
+IUSE="server editor tools gnome kde"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable gnome) \
+ $(use_enable kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/icons" "${D}/usr/share/"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}