summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-09-17 19:29:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-09-17 19:29:12 +0000
commitd51d6defb48a99d7a2c99c90be1d7d0b2a04de8d (patch)
tree5f4bf8a9e067d8305c6e06438560a4f0eda417e7 /games-strategy/wormux
parentFix linking with --as-needed, fix HOMEPAGE and SRC_URI, quotes, add ~amd64 ke... (diff)
downloadgentoo-2-d51d6defb48a99d7a2c99c90be1d7d0b2a04de8d.tar.gz
gentoo-2-d51d6defb48a99d7a2c99c90be1d7d0b2a04de8d.tar.bz2
gentoo-2-d51d6defb48a99d7a2c99c90be1d7d0b2a04de8d.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-strategy/wormux')
-rw-r--r--games-strategy/wormux/ChangeLog7
-rw-r--r--games-strategy/wormux/wormux-0.8.1.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/games-strategy/wormux/ChangeLog b/games-strategy/wormux/ChangeLog
index 007adc61d2c9..bce36fa0c2f0 100644
--- a/games-strategy/wormux/ChangeLog
+++ b/games-strategy/wormux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wormux
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/ChangeLog,v 1.21 2008/06/08 21:38:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/ChangeLog,v 1.22 2008/09/17 19:29:12 mr_bones_ Exp $
+
+*wormux-0.8.1 (17 Sep 2008)
+
+ 17 Sep 2008; Michael Sterrett <mr_bones_@gentoo.org> +wormux-0.8.1.ebuild:
+ version bump
*wormux-0.8 (08 Jun 2008)
diff --git a/games-strategy/wormux/wormux-0.8.1.ebuild b/games-strategy/wormux/wormux-0.8.1.ebuild
new file mode 100644
index 000000000000..fc208c0c8cde
--- /dev/null
+++ b/games-strategy/wormux/wormux-0.8.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/wormux-0.8.1.ebuild,v 1.1 2008/09/17 19:29:12 mr_bones_ Exp $
+
+inherit autotools eutils games
+
+DESCRIPTION="A free Worms clone"
+HOMEPAGE="http://www.wormux.org/"
+SRC_URI="http://download.gna.org/wormux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug nls unicode"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ media-libs/sdl-gfx
+ net-misc/curl
+ media-fonts/dejavu
+ >=dev-cpp/libxmlpp-2.6
+ nls? ( virtual/libintl )
+ unicode? ( dev-libs/fribidi )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/AX_CFLAGS_WARN_ALL/d" \
+ configure.ac \
+ || die "sed failed"
+ sed -i \
+ -e "s/-Werror//" \
+ src/Makefile.am \
+ || die "sed failed"
+ sed -i \
+ -e "/xdg/d" \
+ -e "/pixmaps/d" \
+ data/Makefile.am \
+ || die "sed failed"
+ eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-localedir-name=/usr/share/locale \
+ --with-datadir-name="${GAMES_DATADIR}/${PN}" \
+ --with-font-path=/usr/share/fonts/dejavu/DejaVuSans.ttf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode fribidi) \
+ || die "configuration failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ newicon data/wormux.svg wormux.svg
+ make_desktop_entry wormux Wormux
+ prepgamesdirs
+}