summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2004-11-08 02:08:23 +0000
committerJoseph Jezak <josejx@gentoo.org>2004-11-08 02:08:23 +0000
commitfe29dfc87ba7a6437595da661d99ab4e9c36986d (patch)
treea0872d198cc5017875996dfabb9bb191a956e30d /games-strategy/xconq
parentAdded ~ppc. (Manifest recommit) (diff)
downloadgentoo-2-fe29dfc87ba7a6437595da661d99ab4e9c36986d.tar.gz
gentoo-2-fe29dfc87ba7a6437595da661d99ab4e9c36986d.tar.bz2
gentoo-2-fe29dfc87ba7a6437595da661d99ab4e9c36986d.zip
Fixed gcc 3.4 compile problems and added ~ppc.
Diffstat (limited to 'games-strategy/xconq')
-rw-r--r--games-strategy/xconq/ChangeLog6
-rw-r--r--games-strategy/xconq/files/xconq-gcc-3.4.patch10
-rw-r--r--games-strategy/xconq/xconq-7.4.1.ebuild10
3 files changed, 23 insertions, 3 deletions
diff --git a/games-strategy/xconq/ChangeLog b/games-strategy/xconq/ChangeLog
index 090b56adf79e..c561b5e15b0b 100644
--- a/games-strategy/xconq/ChangeLog
+++ b/games-strategy/xconq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/xconq
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/ChangeLog,v 1.2 2004/06/24 23:30:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/ChangeLog,v 1.3 2004/11/08 02:08:23 josejx Exp $
+
+ 08 Nov 2004; Joseph Jezak <josejx@gentoo.org> +files/xconq-gcc-3.4.patch,
+ xconq-7.4.1.ebuild:
+ Fixed compiling with gcc 3.4 and addded ~ppc.
*xconq-7.4.1 (12 Dec 2003)
diff --git a/games-strategy/xconq/files/xconq-gcc-3.4.patch b/games-strategy/xconq/files/xconq-gcc-3.4.patch
new file mode 100644
index 000000000000..28191039b0e0
--- /dev/null
+++ b/games-strategy/xconq/files/xconq-gcc-3.4.patch
@@ -0,0 +1,10 @@
+--- tcltk/tkmain.c.old 2004-11-05 11:28:11.379166320 +0000
++++ tcltk/tkmain.c 2004-11-05 11:28:25.956950160 +0000
+@@ -1381,6 +1381,7 @@
+ return TRUE;
+ case 1:
+ default:
++ ;
+ }
+ return FALSE;
+ }
diff --git a/games-strategy/xconq/xconq-7.4.1.ebuild b/games-strategy/xconq/xconq-7.4.1.ebuild
index 9fb6dcb4b645..a9794b250c3a 100644
--- a/games-strategy/xconq/xconq-7.4.1.ebuild
+++ b/games-strategy/xconq/xconq-7.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/xconq-7.4.1.ebuild,v 1.4 2004/06/24 23:30:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/xconq-7.4.1.ebuild,v 1.5 2004/11/08 02:08:23 josejx Exp $
inherit games
@@ -10,13 +10,19 @@ SRC_URI="ftp://sources.redhat.com/pub/xconq/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~ppc"
IUSE=""
DEPEND="virtual/x11
dev-lang/tk
dev-lang/tcl"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gcc-3.4.patch
+}
+
src_compile() {
egamesconf \
--enable-alternate-scoresdir=${GAMES_STATEDIR}/${PN}/scores \