summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 05:27:31 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 05:27:31 +0000
commit0c0186e57f9c188f3c71c04a35825c8e134cf141 (patch)
tree764612f703bdba5335d790064606b1f53a330c24 /games-strategy/xscorch/xscorch-0.1.15.ebuild
parentminor version update. resolves bug 27641 (diff)
downloadgentoo-2-0c0186e57f9c188f3c71c04a35825c8e134cf141.tar.gz
gentoo-2-0c0186e57f9c188f3c71c04a35825c8e134cf141.tar.bz2
gentoo-2-0c0186e57f9c188f3c71c04a35825c8e134cf141.zip
mmm strategy games
Diffstat (limited to 'games-strategy/xscorch/xscorch-0.1.15.ebuild')
-rw-r--r--games-strategy/xscorch/xscorch-0.1.15.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-strategy/xscorch/xscorch-0.1.15.ebuild b/games-strategy/xscorch/xscorch-0.1.15.ebuild
new file mode 100644
index 000000000000..edb30d7769bf
--- /dev/null
+++ b/games-strategy/xscorch/xscorch-0.1.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/xscorch-0.1.15.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+inherit games
+
+DESCRIPTION="clone of the classic DOS game, 'Scorched Earth'"
+SRC_URI="http://chaos2.org/xscorch/${P}.tar.gz
+ http://utoxin.kydance.net/xscorch/${P}.tar.gz"
+HOMEPAGE="http://chaos2.org/xscorch/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc alpha"
+IUSE="gtk mikmod readline gnome"
+
+DEPEND="gtk? ( =x11-libs/gtk+-1* )
+ mikmod? ( media-libs/libmikmod )
+ readline? ( sys-libs/readline )
+ gnome? ( gnome-base/gnome-libs )"
+
+src_compile() {
+ local myconf=""
+ use mikmod \
+ && myconf="--enable-sound=yes" \
+ || myconf="--enable-sound=no"
+ egamesconf \
+ --enable-network \
+ --with-readline=maybe \
+ `use_with gtk` \
+ `use_with gnome` \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ prepgamesdirs
+}