summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-12 14:57:19 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-12 14:57:19 +0000
commit019bc3ec605843c0af67a0533da70f91000dfdff (patch)
tree53e2e43b5d95d344e7305ecc126f5589c1c6f044 /games-strategy
parentVersion bumped. (diff)
downloadgentoo-2-019bc3ec605843c0af67a0533da70f91000dfdff.tar.gz
gentoo-2-019bc3ec605843c0af67a0533da70f91000dfdff.tar.bz2
gentoo-2-019bc3ec605843c0af67a0533da70f91000dfdff.zip
Fix --as-needed bug #247511
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/xscorch/ChangeLog8
-rw-r--r--games-strategy/xscorch/files/xscorch-0.2.0-as-needed.patch17
-rw-r--r--games-strategy/xscorch/xscorch-0.2.0-r1.ebuild17
3 files changed, 31 insertions, 11 deletions
diff --git a/games-strategy/xscorch/ChangeLog b/games-strategy/xscorch/ChangeLog
index 867a12e4e127..f80083e1ff92 100644
--- a/games-strategy/xscorch/ChangeLog
+++ b/games-strategy/xscorch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/xscorch
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/ChangeLog,v 1.12 2008/03/25 15:42:11 coldwind Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/ChangeLog,v 1.13 2009/02/12 14:57:18 tupone Exp $
+
+ 12 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/xscorch-0.2.0-as-needed.patch, xscorch-0.2.0-r1.ebuild:
+ Fix --as-needed bug #247511 by flameeyes@gentoo.org
25 Mar 2008; Santiago M. Mola <coldwind@gentoo.org>
xscorch-0.2.0-r1.ebuild:
diff --git a/games-strategy/xscorch/files/xscorch-0.2.0-as-needed.patch b/games-strategy/xscorch/files/xscorch-0.2.0-as-needed.patch
new file mode 100644
index 000000000000..1b937abbdabb
--- /dev/null
+++ b/games-strategy/xscorch/files/xscorch-0.2.0-as-needed.patch
@@ -0,0 +1,17 @@
+--- Makefile.in.old 2009-02-12 15:56:38.000000000 +0100
++++ Makefile.in 2009-02-12 15:58:38.000000000 +0100
+@@ -153,12 +153,12 @@
+
+ xscorch_SOURCES = xscorch.c
+
+-xscorch_LDADD = -lm $(GTK_LIBS) $(LIBMIKMOD_LIBS) sgame/libscorch_game.a sgtk/libscorch_gtk.a sgtk/swidgets/libscorch_widget_gtk.a sai/libscorch_ai.a $(MIKMOD_LD_ADD) $(NETWORK_LD_ADD) sutil/libscorch_util.a sgame/libscorch_game.a libj/jreg/libjreg.a libj/jstr/libjstr.a
++xscorch_LDADD = sgame/libscorch_game.a sgtk/libscorch_gtk.a sgtk/swidgets/libscorch_widget_gtk.a sai/libscorch_ai.a $(MIKMOD_LD_ADD) $(NETWORK_LD_ADD) sutil/libscorch_util.a sgame/libscorch_game.a libj/jreg/libjreg.a libj/jstr/libjstr.a $(GTK_LIBS) $(LIBMIKMOD_LIBS) -lm
+
+
+ xscorch_server_SOURCES = xscorch.c
+
+-xscorch_server_LDADD = -lm $(LIBREADLINE_LIBS) sgame/libscorch_game.a sconsole/libscorch_console.a sai/libscorch_ai.a ssound/libscorch_sound_null.a $(NETWORK_LD_ADD) sutil/libscorch_util.a sgame/libscorch_game.a libj/jreg/libjreg.a libj/jstr/libjstr.a
++xscorch_server_LDADD = $(LIBREADLINE_LIBS) sgame/libscorch_game.a sconsole/libscorch_console.a sai/libscorch_ai.a ssound/libscorch_sound_null.a $(NETWORK_LD_ADD) sutil/libscorch_util.a sgame/libscorch_game.a libj/jreg/libjreg.a libj/jstr/libjstr.a -lm
+
+
+ INCLUDES = -Isgame -Isgtk
diff --git a/games-strategy/xscorch/xscorch-0.2.0-r1.ebuild b/games-strategy/xscorch/xscorch-0.2.0-r1.ebuild
index b997508ba412..10abf9d6f75c 100644
--- a/games-strategy/xscorch/xscorch-0.2.0-r1.ebuild
+++ b/games-strategy/xscorch/xscorch-0.2.0-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/xscorch-0.2.0-r1.ebuild,v 1.4 2008/03/25 15:42:11 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/xscorch-0.2.0-r1.ebuild,v 1.5 2009/02/12 14:57:18 tupone Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="clone of the classic DOS game, 'Scorched Earth'"
@@ -18,15 +19,14 @@ IUSE="gtk mikmod"
DEPEND="gtk? ( =x11-libs/gtk+-1* )
mikmod? ( media-libs/libmikmod )"
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
+src_prepare() {
epatch \
- "${DISTDIR}/${P}-64bit.patch.gz" \
- "${DISTDIR}/${P}-stack-smash.patch.gz"
+ "${WORKDIR}"/${P}-64bit.patch \
+ "${WORKDIR}"/${P}-stack-smash.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
}
-src_compile() {
+src_configure() {
#configure failed on readline support
egamesconf \
--enable-network \
@@ -34,7 +34,6 @@ src_compile() {
$(use_enable mikmod sound) \
$(use_with gtk) \
|| die
- emake || die "emake failed"
}
src_install() {