summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-01-05 08:39:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-01-05 08:39:25 +0000
commitc98d5efc557198f872125f3e71be8de9d6e010eb (patch)
treeacb8eb888bdfb657f9da02b7cbeb33ada6c4116a /games-strategy
parentRevert previous change as upstream has renamed the branch again, bug 299667. (diff)
downloadgentoo-2-c98d5efc557198f872125f3e71be8de9d6e010eb.tar.gz
gentoo-2-c98d5efc557198f872125f3e71be8de9d6e010eb.tar.bz2
gentoo-2-c98d5efc557198f872125f3e71be8de9d6e010eb.zip
EAPI=2; respect CXX
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/boswars/ChangeLog7
-rw-r--r--games-strategy/boswars/boswars-2.5.ebuild17
2 files changed, 14 insertions, 10 deletions
diff --git a/games-strategy/boswars/ChangeLog b/games-strategy/boswars/ChangeLog
index e4ff18226e70..24caccfcda1e 100644
--- a/games-strategy/boswars/ChangeLog
+++ b/games-strategy/boswars/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/boswars
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.9 2009/06/21 00:59:07 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.10 2010/01/05 08:39:25 mr_bones_ Exp $
+
+ 05 Jan 2010; Michael Sterrett <mr_bones_@gentoo.org> boswars-2.5.ebuild:
+ EAPI=2; respect CXX
21 Jun 2009; Tristan Heaven <nyhm@gentoo.org> boswars-2.5.ebuild,
+files/boswars-2.5-gcc44.patch:
diff --git a/games-strategy/boswars/boswars-2.5.ebuild b/games-strategy/boswars/boswars-2.5.ebuild
index c8bb709616c1..12c3274df3da 100644
--- a/games-strategy/boswars/boswars-2.5.ebuild
+++ b/games-strategy/boswars/boswars-2.5.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.5.ebuild,v 1.3 2009/06/21 00:59:07 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.5.ebuild,v 1.4 2010/01/05 08:39:25 mr_bones_ Exp $
-inherit eutils games
+EAPI=2
+inherit toolchain-funcs eutils games
DESCRIPTION="Futuristic real-time strategy game"
HOMEPAGE="http://www.boswars.org/"
@@ -15,7 +16,7 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="dev-lang/lua
- media-libs/libsdl
+ media-libs/libsdl[audio,video]
media-libs/libpng
media-libs/libvorbis
media-libs/libtheora
@@ -27,9 +28,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}-src
-src_unpack() {
- unpack ${A/bos.png}
- cd "${S}"
+src_prepare() {
rm -f doc/{README-SDL.txt,guichan-copyright.txt}
epatch \
"${FILESDIR}"/${P}-gentoo.patch \
@@ -46,7 +45,9 @@ src_unpack() {
}
src_compile() {
- scons || die "scons failed"
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[:space:]*[0-9]\+\).*/\1/; p }")
+
+ scons CXX=$(tc-getCXX) ${sconsopts} || die "scons failed"
}
src_install() {