summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-01 00:21:34 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-01 00:21:34 +0000
commitdac12ef07f0c474875122fc053fc6dfa4f81da98 (patch)
tree37599b7e37784712ca9058af6c5f6fa7c06b5db8 /games-strategy
parentVersion bump. (diff)
downloadgentoo-2-dac12ef07f0c474875122fc053fc6dfa4f81da98.tar.gz
gentoo-2-dac12ef07f0c474875122fc053fc6dfa4f81da98.tar.bz2
gentoo-2-dac12ef07f0c474875122fc053fc6dfa4f81da98.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/boswars/ChangeLog6
-rw-r--r--games-strategy/boswars/boswars-2.5.ebuild12
-rw-r--r--games-strategy/boswars/files/boswars-2.5-gcc43.patch20
3 files changed, 34 insertions, 4 deletions
diff --git a/games-strategy/boswars/ChangeLog b/games-strategy/boswars/ChangeLog
index d0fe33be3353..0d0f67ccbed6 100644
--- a/games-strategy/boswars/ChangeLog
+++ b/games-strategy/boswars/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/boswars
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.7 2008/03/02 07:58:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.8 2008/05/01 00:21:34 nyhm Exp $
+
+ 01 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/boswars-2.5-gcc43.patch, boswars-2.5.ebuild:
+ Fix building with gcc-4.3
*boswars-2.5 (02 Mar 2008)
diff --git a/games-strategy/boswars/boswars-2.5.ebuild b/games-strategy/boswars/boswars-2.5.ebuild
index 7c89d58d4c9c..35625404f464 100644
--- a/games-strategy/boswars/boswars-2.5.ebuild
+++ b/games-strategy/boswars/boswars-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.5.ebuild,v 1.1 2008/03/02 07:58:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.5.ebuild,v 1.2 2008/05/01 00:21:34 nyhm Exp $
inherit eutils games
@@ -31,11 +31,17 @@ src_unpack() {
unpack ${A/bos.png}
cd "${S}"
rm -f doc/{README-SDL.txt,guichan-copyright.txt}
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
engine/include/stratagus.h \
- || die "sed failed"
+ || die "sed stratagus.h failed"
+ sed -i \
+ -e "/-O2/s:-O2.*math:${CXXFLAGS} -Wall:" \
+ SConstruct \
+ || die "sed SConstruct failed"
}
src_compile() {
diff --git a/games-strategy/boswars/files/boswars-2.5-gcc43.patch b/games-strategy/boswars/files/boswars-2.5-gcc43.patch
new file mode 100644
index 000000000000..783934bba215
--- /dev/null
+++ b/games-strategy/boswars/files/boswars-2.5-gcc43.patch
@@ -0,0 +1,20 @@
+--- engine/pathfinder/astar.cpp
++++ engine/pathfinder/astar.cpp
+@@ -35,6 +35,7 @@
+
+ #include "stratagus.h"
+ #include "pathfinder.h"
++#include <cstdlib>
+
+ /*----------------------------------------------------------------------------
+ -- Declarations
+--- engine/stratagus/stratagus.cpp
++++ engine/stratagus/stratagus.cpp
+@@ -160,6 +160,7 @@
+ #include <time.h>
+ #include <ctype.h>
+ #include <sstream>
++#include <algorithm>
+
+ #ifndef _MSC_VER
+ #include <unistd.h>