summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-11-20 17:48:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-11-20 17:48:59 +0000
commitec49b5948cfb7e570970074010e32fdf25d11090 (patch)
treeb7875689dc2681bbbcb1d8eb09dd85d86087d146 /games-strategy
parentRemove redundant version. (diff)
downloadgentoo-2-ec49b5948cfb7e570970074010e32fdf25d11090.tar.gz
gentoo-2-ec49b5948cfb7e570970074010e32fdf25d11090.tar.bz2
gentoo-2-ec49b5948cfb7e570970074010e32fdf25d11090.zip
add locale location fix from Azamat H. Hackimov for bug #346201
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/widelands/ChangeLog6
-rw-r--r--games-strategy/widelands/files/widelands-0.15-locale.patch11
-rw-r--r--games-strategy/widelands/widelands-0.15.ebuild6
3 files changed, 20 insertions, 3 deletions
diff --git a/games-strategy/widelands/ChangeLog b/games-strategy/widelands/ChangeLog
index 335848cc0506..2f69c44a210f 100644
--- a/games-strategy/widelands/ChangeLog
+++ b/games-strategy/widelands/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/widelands
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.26 2010/11/20 10:08:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.27 2010/11/20 17:48:59 mr_bones_ Exp $
+
+ 20 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ widelands-0.15.ebuild, +files/widelands-0.15-locale.patch:
+ add locale location fix from Azamat H. Hackimov for bug #346201
*widelands-0.15 (20 Nov 2010)
diff --git a/games-strategy/widelands/files/widelands-0.15-locale.patch b/games-strategy/widelands/files/widelands-0.15-locale.patch
new file mode 100644
index 000000000000..bddeafc64a48
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-0.15-locale.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.old 2010-11-20 22:07:17.000000000 +0500
++++ CMakeLists.txt 2010-11-20 22:07:55.000000000 +0500
+@@ -79,7 +79,7 @@
+
+ set (WLBUILD_INSTALL_PREFIX ${CMAKE_INSTALL_PREFIX})
+ set (WLBUILD_INSTALL_DATADIR ${WL_INSTALL_DATADIR})
+-set (WLBUILD_INSTALL_LOCALEDIR "${CMAKE_INSTALL_PREFIX}/${WL_INSTALL_DATADIR}/locale")
++set (WLBUILD_INSTALL_LOCALEDIR ${WL_INSTALL_LOCALEDIR})
+ set (WLBUILD_INSTALL_BINDIR ${WL_INSTALL_BINDIR})
+
+ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR)
diff --git a/games-strategy/widelands/widelands-0.15.ebuild b/games-strategy/widelands/widelands-0.15.ebuild
index fc70cf949639..7e0a987073af 100644
--- a/games-strategy/widelands/widelands-0.15.ebuild
+++ b/games-strategy/widelands/widelands-0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.15.ebuild,v 1.1 2010/11/20 10:08:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.15.ebuild,v 1.2 2010/11/20 17:48:59 mr_bones_ Exp $
EAPI=2
inherit eutils versionator cmake-utils games
@@ -33,7 +33,9 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-locale.patch
sed -i \
-e 's:__ppc__:__PPC__:' src/s2map.cc \