summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-07 17:25:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-07 17:25:01 +0000
commite8adf3abd97eff06c320c983ad145e17a7b80c30 (patch)
tree564bb86bb53920cc40ae413571794756ae970163 /games-util/catcodec
parentPrint elog only if USE=suid, bug #312841, thank Martin von Gagern for report. (diff)
downloadgentoo-2-e8adf3abd97eff06c320c983ad145e17a7b80c30.tar.gz
gentoo-2-e8adf3abd97eff06c320c983ad145e17a7b80c30.tar.bz2
gentoo-2-e8adf3abd97eff06c320c983ad145e17a7b80c30.zip
initial commit - ebuild submitted by Locke 'Wizzleby' Shinseiko via bug #308355
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-util/catcodec')
-rw-r--r--games-util/catcodec/ChangeLog11
-rw-r--r--games-util/catcodec/catcodec-1.0.0.ebuild25
-rw-r--r--games-util/catcodec/files/catcodec-1.0.0-build.patch26
-rw-r--r--games-util/catcodec/metadata.xml5
4 files changed, 67 insertions, 0 deletions
diff --git a/games-util/catcodec/ChangeLog b/games-util/catcodec/ChangeLog
new file mode 100644
index 000000000000..14043c94d45a
--- /dev/null
+++ b/games-util/catcodec/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-util/catcodec
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/catcodec/ChangeLog,v 1.1 2010/04/07 17:25:01 mr_bones_ Exp $
+
+*catcodec-1.0.0 (07 Apr 2010)
+
+ 07 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +catcodec-1.0.0.ebuild, +files/catcodec-1.0.0-build.patch:
+ initial commit - ebuild submitted by Locke 'Wizzleby' Shinseiko via bug
+ #308355
+
diff --git a/games-util/catcodec/catcodec-1.0.0.ebuild b/games-util/catcodec/catcodec-1.0.0.ebuild
new file mode 100644
index 000000000000..47383afc5f71
--- /dev/null
+++ b/games-util/catcodec/catcodec-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/catcodec/catcodec-1.0.0.ebuild,v 1.1 2010/04/07 17:25:01 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Decodes and encodes sample catalogues for OpenTTD"
+HOMEPAGE="http://www.openttd.org/en/download-catcodec"
+SRC_URI="http://binaries.openttd.org/extra/catcodec/${PV}/${P}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ dobin catcodec || die
+ dodoc README || die
+ doman catcodec.1 || die
+}
diff --git a/games-util/catcodec/files/catcodec-1.0.0-build.patch b/games-util/catcodec/files/catcodec-1.0.0-build.patch
new file mode 100644
index 000000000000..ebc5f7cda440
--- /dev/null
+++ b/games-util/catcodec/files/catcodec-1.0.0-build.patch
@@ -0,0 +1,26 @@
+diff -ru catcodec-1.0.0.orig/Makefile catcodec-1.0.0/Makefile
+--- catcodec-1.0.0.orig/Makefile 2009-11-05 17:33:48.000000000 -0500
++++ catcodec-1.0.0/Makefile 2010-04-07 12:52:09.839777068 -0400
+@@ -19,18 +19,18 @@
+ OBJS = catcodec.o io.o sample.o rev.o
+ OS = unknown
+
+-CFLAGS += -Wall -Wcast-qual -Wwrite-strings -Wno-multichar
++CXXFLAGS += -Wall -Wcast-qual -Wwrite-strings -Wno-multichar
+ ifdef DEBUG
+- CFLAGS += -g -ggdb
++ CXXFLAGS += -g -ggdb
+ endif
+
+ all: $(CATCODEC)
+
+ %.o: %.cpp
+- $(CXX) $(CFLAGS) -c -o $@ $^
++ $(CXX) $(CXXFLAGS) -c -o $@ $^
+
+ $(CATCODEC): $(OBJS)
+- $(CXX) $(CFLAGS) -o $@ $^
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+
+ VERSION := $(shell ./findversion.sh | cut -f 1 -d' ')
+ RES := $(shell if [ "`cat version.cache 2>/dev/null`" != "$(VERSION)" ]; then echo "$(VERSION)" > version.cache; fi )
diff --git a/games-util/catcodec/metadata.xml b/games-util/catcodec/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/catcodec/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>