summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-05 04:51:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-05 04:51:39 +0000
commit8e0d4b02587202cae11f0bd621b40cac16587890 (patch)
treed0a27273126cff2b44d865f7bdf6fe6814f9978f /games-util/fteqcc/fteqcc-2501.ebuild
parentVersion bump #111500 by Daniel Webert. (diff)
downloadgentoo-2-8e0d4b02587202cae11f0bd621b40cac16587890.tar.gz
gentoo-2-8e0d4b02587202cae11f0bd621b40cac16587890.tar.bz2
gentoo-2-8e0d4b02587202cae11f0bd621b40cac16587890.zip
initial import #111281 by fabien Zouaoui
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-util/fteqcc/fteqcc-2501.ebuild')
-rw-r--r--games-util/fteqcc/fteqcc-2501.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-util/fteqcc/fteqcc-2501.ebuild b/games-util/fteqcc/fteqcc-2501.ebuild
new file mode 100644
index 000000000000..861fdfcc36cb
--- /dev/null
+++ b/games-util/fteqcc/fteqcc-2501.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/fteqcc/fteqcc-2501.ebuild,v 1.1 2005/11/05 04:51:39 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="QC compiler"
+HOMEPAGE="http://fteqw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fteqw/qclibsrc${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-cleanup-source.patch
+ sed -i \
+ -e "s: -O3 : :g" \
+ -e "s: -s : :g" \
+ Makefile || die "sed failed"
+ edos2unix readme.txt
+}
+
+src_compile() {
+ emake BASE_CFLAGS="${CFLAGS} -Wall" || die "emake qcc failed"
+}
+
+src_install() {
+ newbin fteqcc.bin fteqcc || die "newbin fteqcc.bin failed"
+ dodoc readme.txt
+}