summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 18:53:23 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 18:53:23 +0000
commitf832b6aa8af70160dd49b2f91631e66e941b9dbe (patch)
treee28495f9d6e402f2d221775fbef168a3e40e3457 /games-util/qstat
parentAdd local dv USE flag for mjpegtools. (diff)
downloadgentoo-2-f832b6aa8af70160dd49b2f91631e66e941b9dbe.tar.gz
gentoo-2-f832b6aa8af70160dd49b2f91631e66e941b9dbe.tar.bz2
gentoo-2-f832b6aa8af70160dd49b2f91631e66e941b9dbe.zip
welcome to games-util
Diffstat (limited to 'games-util/qstat')
-rw-r--r--games-util/qstat/ChangeLog38
-rw-r--r--games-util/qstat/Manifest6
-rw-r--r--games-util/qstat/files/digest-qstat-25b-r11
-rw-r--r--games-util/qstat/files/digest-qstat-25c1
-rw-r--r--games-util/qstat/files/qstat-25b.gcc3-fix13
-rw-r--r--games-util/qstat/qstat-25b-r1.ebuild34
-rw-r--r--games-util/qstat/qstat-25c.ebuild28
7 files changed, 121 insertions, 0 deletions
diff --git a/games-util/qstat/ChangeLog b/games-util/qstat/ChangeLog
new file mode 100644
index 000000000000..50bcf78a5937
--- /dev/null
+++ b/games-util/qstat/ChangeLog
@@ -0,0 +1,38 @@
+# ChangeLog for app-games/qstat
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/qstat/ChangeLog,v 1.1 2003/09/10 18:53:23 vapier Exp $
+
+*qstat-25c (13 Nov 2002)
+
+ 14 Jan 2003; Jon Nall <nall@gentoo.org> qstat-25c.ebuild :
+ added ~ppc
+
+ 13 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Version bump
+
+*qstat-25b-r1 (16 Sep 2002)
+
+ 16 Sep 2002; Bryon Roche <kain@gentoo.org>
+ qstat-25b-r1.ebuild, files/qstat-25b.gcc3-fix:
+ Off-by-one fix in file-read mode.
+ Gcc-3 fixes.
+
+*qstat-25b (07 Sep 2002)
+
+ 07 Sep 2002; J.Alberto Suárez López <bass@gentoo.org>
+ qstat-25b.ebuild:
+ Bumped version and fix LICENSE. Thanks vapier@netzero.com (SpanKY).
+
+*qstat-24e (29 Mar 2002)
+
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> qstat-24e.ebuild :
+ Added LICENSE, KEYWORDS.
+
+ 13 April 2002; Bart Verwilst <verwilst@gentoo.org> Changelog: removed
+ old version, and did some general cleanups in the ebuild.
+
+ 29 Mar 2002; Bruce A. Locke <blocke@shivan.org> ChangeLog :
+ Qstat updated to 24e and ebuild was revamped to make it more version
+ independent
+
+
diff --git a/games-util/qstat/Manifest b/games-util/qstat/Manifest
new file mode 100644
index 000000000000..77e55bbb0b41
--- /dev/null
+++ b/games-util/qstat/Manifest
@@ -0,0 +1,6 @@
+MD5 caf42601ff548efc2f1a6faf7a5014ce ChangeLog 1146
+MD5 2e03c82fca2a8595a9bbe0f238d50504 qstat-25b-r1.ebuild 764
+MD5 21eebdddbfd85b64dad8bf403bdf2f09 qstat-25c.ebuild 669
+MD5 33e28a49c9ed9bcd4caff226689057c4 files/digest-qstat-25b-r1 59
+MD5 e0b0af4302e67d21a77364daf231b37c files/digest-qstat-25c 60
+MD5 01b5a1271052646c1f629dbe63274be7 files/qstat-25b.gcc3-fix 500
diff --git a/games-util/qstat/files/digest-qstat-25b-r1 b/games-util/qstat/files/digest-qstat-25b-r1
new file mode 100644
index 000000000000..7e4b976eb3fd
--- /dev/null
+++ b/games-util/qstat/files/digest-qstat-25b-r1
@@ -0,0 +1 @@
+MD5 37e8b8ee3dfcae3e6e14e3a6f71a8fe1 qstat25b.tar.gz 99457
diff --git a/games-util/qstat/files/digest-qstat-25c b/games-util/qstat/files/digest-qstat-25c
new file mode 100644
index 000000000000..a61a80b2607e
--- /dev/null
+++ b/games-util/qstat/files/digest-qstat-25c
@@ -0,0 +1 @@
+MD5 a936dc3e15ece567378a026737fe45e2 qstat25c.tar.gz 111739
diff --git a/games-util/qstat/files/qstat-25b.gcc3-fix b/games-util/qstat/files/qstat-25b.gcc3-fix
new file mode 100644
index 000000000000..96f30e5b3600
--- /dev/null
+++ b/games-util/qstat/files/qstat-25b.gcc3-fix
@@ -0,0 +1,13 @@
+Binary files qstat25b/.qstat.c.swp and qstat25b.gcc3-fix/.qstat.c.swp differ
+diff -urN qstat25b/qstat.c qstat25b.gcc3-fix/qstat.c
+--- qstat25b/qstat.c Thu Aug 8 15:26:59 2002
++++ qstat25b.gcc3-fix/qstat.c Mon Sep 16 06:35:28 2002
+@@ -1531,7 +1531,7 @@
+ {
+ server_type *type= &types[0];
+ char *t= type_string;
+- while ( *t) *t++= tolower( *t);
++ while ( *t) {*t= tolower( *t);t++;}
+
+ for ( ; type->id != Q_UNKNOWN_TYPE; type++)
+ if ( strcmp( type->type_string, type_string) == 0)
diff --git a/games-util/qstat/qstat-25b-r1.ebuild b/games-util/qstat/qstat-25b-r1.ebuild
new file mode 100644
index 000000000000..25c9e2d9b622
--- /dev/null
+++ b/games-util/qstat/qstat-25b-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/qstat/qstat-25b-r1.ebuild,v 1.1 2003/09/10 18:53:23 vapier Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="Server statics collector supporting many FPS games"
+SRC_URI="http://www.qstat.org/${PN}${PV}.tar.gz"
+HOMEPAGE="http://www.qstat.org"
+
+KEYWORDS="x86"
+LICENSE="Artistic"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${PN}${PV}.tar.gz
+ cd ${S}
+ patch -p1 < ${FILESDIR}/qstat-25b.gcc3-fix
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ dobin qstat
+
+ dosym /usr/bin/qstat /usr/bin/quakestat
+
+ dodoc CHANGES.txt COMPILE.txt
+ dohtml template/*
+ dohtml qstatdoc.html
+}
diff --git a/games-util/qstat/qstat-25c.ebuild b/games-util/qstat/qstat-25c.ebuild
new file mode 100644
index 000000000000..8c15b2d376df
--- /dev/null
+++ b/games-util/qstat/qstat-25c.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/qstat/qstat-25c.ebuild,v 1.1 2003/09/10 18:53:23 vapier Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="Server statics collector supporting many FPS games"
+SRC_URI="http://www.qstat.org/${PN}${PV}.tar.gz"
+HOMEPAGE="http://www.qstat.org/"
+
+KEYWORDS="x86 ppc"
+LICENSE="Artistic"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ dobin qstat
+
+ dosym /usr/bin/qstat /usr/bin/quakestat
+
+ dodoc CHANGES.txt COMPILE.txt
+ dohtml template/*
+ dohtml qstatdoc.html
+}